summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Marek Srejma2013-12-20 17:00:51 +0100
committer Robby Workman2013-12-25 22:05:37 +0100
commit15631e70fd8fcbe013b26399bb9163d83001ef62 (patch)
tree7054aab8dccf05678635be81c1cd74167dcfca99 /network
parent04d57a565c77f27a17855f7c1912c24cef510dbd (diff)
downloadslackbuilds-15631e70fd8fcbe013b26399bb9163d83001ef62.tar.gz
network/roger-router: Added (former FFGTK Router Manager).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/roger-router/README21
-rw-r--r--network/roger-router/doinst.sh15
-rw-r--r--network/roger-router/roger-router.SlackBuild134
-rw-r--r--network/roger-router/roger-router.info10
-rw-r--r--network/roger-router/slack-desc19
5 files changed, 199 insertions, 0 deletions
diff --git a/network/roger-router/README b/network/roger-router/README
new file mode 100644
index 0000000000..fb57780777
--- /dev/null
+++ b/network/roger-router/README
@@ -0,0 +1,21 @@
+Roger-Router (former FFGTK Router Manager)
+
+Fax-Software and Call-Monitor for AVM FRITZ!Box or compatible
+
+Notice:
+In order to enable fax transfers the user must be member of the
+system group "fax"!
+Use this command as root to add <username> to the "fax" group
+and then log out and log in again as <username>.
+(Replace <username> with the real user name on your system)
+
+"gpasswd -a <username> fax"
+
+You MUST RUN this command after installing this package as root
+lpadmin -p "Roger-Router-Fax" -E -v roger-cups:/ -P /usr/share/roger/roger-fax.ppd
+
+There is an optional firefox-plugin "roger-dial". It can be installed
+by calling http://de.tabos.org/download/roger-dial-1.8.0.xpi
+from your firefox browser.
+
+Optional dependency: pulseaudio, portaudio
diff --git a/network/roger-router/doinst.sh b/network/roger-router/doinst.sh
new file mode 100644
index 0000000000..0254ea06d8
--- /dev/null
+++ b/network/roger-router/doinst.sh
@@ -0,0 +1,15 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
+
+if [ -e usr/share/glib-2.0/schemas ]; then
+ if [ -x /usr/bin/glib-compile-schemas ]; then
+ /usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas >/dev/null 2>&1
+ fi
+fi
diff --git a/network/roger-router/roger-router.SlackBuild b/network/roger-router/roger-router.SlackBuild
new file mode 100644
index 0000000000..4f798b31a9
--- /dev/null
+++ b/network/roger-router/roger-router.SlackBuild
@@ -0,0 +1,134 @@
+#!/bin/sh
+#
+# Slackware build script for roger-router
+#
+# Copyright 2013 Marek Srejma (sam_web@yahoo.de)
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=roger-router
+VERSION=${VERSION:-1.8.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+bailout() {
+ echo " You must have fax group:"
+ echo " # groupadd -g 273 fax"
+ exit 1
+}
+
+# Bail if group isn't valid on your system
+if ! getent group fax 1>/dev/null 2>/dev/null ; then
+ bailout
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+./autogen.sh
+CXXFLAGS="$SLKCFLAGS" \
+CFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --build=$ARCH-slackware-linux
+
+for d in "." "doc" "roger" "roger-cli"
+do
+ sed \
+ -e '/^SPANDSP_LIBS\s*=/ s|-L.*/|-L/usr/|' \
+ -i ${d}/Makefile
+done
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/share/man $PKG/usr/man
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+sed \
+ -e 's|/lib|/lib'${LIBDIRSUFFIX}'|' \
+ -e '/^cp\s*/ s|roger-cups|/usr/share/roger/roger-cups|' \
+ -e '/^lpadmin/ s|roger-fax.ppd|/usr/share/roger/roger-fax.ppd|' \
+ -i $PKG/usr/share/roger/install-fax.sh
+
+# content of /usr/share/roger/install-fax.sh
+mkdir -p $PKG/var/spool/roger/ $PKG/usr/lib/cups/backend/
+chown lp:fax $PKG/var/spool/roger
+chmod 2770 $PKG/var/spool/roger/
+cp $PKG/usr/share/roger/roger-cups $PKG/usr/lib/cups/backend/
+chown root:root $PKG/usr/lib/cups/backend/roger-cups
+chmod 0755 $PKG/usr/lib/cups/backend/roger-cups
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING ChangeLog NEWS README TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/roger-router/roger-router.info b/network/roger-router/roger-router.info
new file mode 100644
index 0000000000..8765e620ff
--- /dev/null
+++ b/network/roger-router/roger-router.info
@@ -0,0 +1,10 @@
+PRGNAM="roger-router"
+VERSION="1.8.1"
+HOMEPAGE="http://de.tabos.org/"
+DOWNLOAD="http://de.tabos.org/download/roger-router-1.8.1.tar.xz"
+MD5SUM="4dc3538373d99e2b41c5fee11d8d454a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="%README% speex libpeas spandsp libcapi20"
+MAINTAINER="slacksam"
+EMAIL="sam_web@yahoo.de"
diff --git a/network/roger-router/slack-desc b/network/roger-router/slack-desc
new file mode 100644
index 0000000000..6f5351d062
--- /dev/null
+++ b/network/roger-router/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+roger-router: Roger-Router (former FFGTK Router Manager)
+roger-router:
+roger-router: Fax-Software and Call-Monitor for AVM FRITZ!Box or compatible
+roger-router:
+roger-router:
+roger-router: http://tabos.org/
+roger-router:
+roger-router:
+roger-router:
+roger-router:
+roger-router: