summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Audrius Kažukauskas2013-12-31 20:33:12 +0100
committer Erik Hanson2013-12-31 20:33:12 +0100
commit005bbcd8bd6576ee288a86a6cbc514a0292ab78d (patch)
treece1a0ffff74cac12ffbafe59fb39210955b7abee /network
parent9fc1b12373db4dd05ea2c31ff5fe3a0d65dde392 (diff)
downloadslackbuilds-005bbcd8bd6576ee288a86a6cbc514a0292ab78d.tar.gz
network/nicotine+: Updated for version 20130813_037e16c.
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/nicotine+/nicotine+.SlackBuild36
-rw-r--r--network/nicotine+/nicotine+.info6
2 files changed, 30 insertions, 12 deletions
diff --git a/network/nicotine+/nicotine+.SlackBuild b/network/nicotine+/nicotine+.SlackBuild
index 3d269185ba..eea88b4ed9 100644
--- a/network/nicotine+/nicotine+.SlackBuild
+++ b/network/nicotine+/nicotine+.SlackBuild
@@ -1,12 +1,30 @@
#!/bin/sh
# Slackware build script for nicotine+
-# Originally written by Iskar Enev <iskar.enev[@]gmail.com>
-# Modified by the SlackBuilds.org project
-# Maintained as of version 1.2.16 by Audrius Kažukauskas <audrius@neutrino.lt>
+
+# Copyright 2006 Iskar Enev <iskar.enev@gmail.com>
+# Copyright 2013 Audrius Kažukauskas <audrius@neutrino.lt>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=nicotine+
-VERSION=${VERSION:-1.2.16}
+VERSION=${VERSION:-20130813_037e16c}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -29,14 +47,14 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar -xjvf $CWD/$PRGNAM-$VERSION.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
diff --git a/network/nicotine+/nicotine+.info b/network/nicotine+/nicotine+.info
index a17a23e6d1..e312fc95cf 100644
--- a/network/nicotine+/nicotine+.info
+++ b/network/nicotine+/nicotine+.info
@@ -1,8 +1,8 @@
PRGNAM="nicotine+"
-VERSION="1.2.16"
+VERSION="20130813_037e16c"
HOMEPAGE="http://nicotine-plus.org/"
-DOWNLOAD="http://downloads.sourceforge.net/nicotine-plus/nicotine+-1.2.16.tar.bz2"
-MD5SUM="ac7433c21ef619a37e079a7ae68da94a"
+DOWNLOAD="http://neutrino.lt/download/slackware/source/nicotine+-20130813_037e16c.tar.xz"
+MD5SUM="fd5acc4fd96c8180b5b46dec6b591c3e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""