summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Matteo Bernardini2024-03-19 15:46:37 +0100
committer Matteo Bernardini2024-04-20 17:28:04 +0200
commitc33742b9e19a909c33e04d074f58ccbd549ea9af (patch)
treed18fcd44e7524f7cc627adf986e4f11c7d335ea4 /network
parent7348664936073e3ad54706addd43560c23807ed8 (diff)
downloadslackbuilds-mosh.tar.gz
network/mosh: Removed (added to Slackware).mosh
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/mosh/1282.patch43
-rw-r--r--network/mosh/README18
-rw-r--r--network/mosh/mosh.SlackBuild107
-rw-r--r--network/mosh/mosh.info10
-rw-r--r--network/mosh/slack-desc19
5 files changed, 0 insertions, 197 deletions
diff --git a/network/mosh/1282.patch b/network/mosh/1282.patch
deleted file mode 100644
index c8376a2c12..0000000000
--- a/network/mosh/1282.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 8012ca9c8d16f99679c171b36ad02655549ab7ff Mon Sep 17 00:00:00 2001
-From: Alex Chernyakhovsky <alex@achernya.com>
-Date: Sun, 30 Jul 2023 16:19:46 -0400
-Subject: [PATCH] Bump C++ version to C++17
-
-Protobuf versions since 3.6.0 have long had a C++11 dependency; even
-more recent versions have picked up an Abseil dependency bumping that
-to C++14. Since it is now 2023, defaulting to C++17 is reasonable, so
-remove the conditional C++ standards version check that mosh
-previously had and replace it with an unconditional C++17 check.
-
-This means that all future commits can use C++17 features. According
-to https://en.cppreference.com/w/cpp/compiler_support/17 this means
-that minimum effective compiler versions for mosh become:
-
-gcc 7 (May 2017)
-clang 5 (September 2017)
-
-This, in turn, implies that future versions of mosh will no longer be
-available for RHEL/CentOS 7 (June 2014).
-
-Closes: #1267
----
- configure.ac | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index ee70c7b86..7f7dc3bc2 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -22,9 +22,9 @@ AS_IF([test x"$PROTOC" = x],
- # automake 1.12 seems to require this, but automake 1.11 doesn't recognize it
- m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
-
--# Protobuf 3.6+ requires C++11.
--AS_IF([pkg-config --atleast-version 3.6.0 protobuf],
-- [AX_CXX_COMPILE_STDCXX([11])])
-+# Protobuf transitively requires at least C++14, get ahead of the
-+# curve and require at least C++17.
-+AX_CXX_COMPILE_STDCXX([17])
-
- WARNING_CXXFLAGS=""
- PICKY_CXXFLAGS=""
diff --git a/network/mosh/README b/network/mosh/README
deleted file mode 100644
index 8b1944f8d5..0000000000
--- a/network/mosh/README
+++ /dev/null
@@ -1,18 +0,0 @@
-mosh (MObile SHell server and client)
-
-Mosh is a remote terminal application that allows roaming, supports
-intermittent connectivity, and provides intelligent local echo and
-line editing of user keystrokes.
-
-Mosh attempts to improve on SSH by being more robust and responsive,
-especially over Wi-Fi, cellular, and long-distance links.
-
-The mosh client must be run with a UTF-8 locale. Locales
-can be configured system-wide in /etc/profile.d/lang.sh or
-/etc/profile.d/lang.csh
-
-Alternatively set LANG to a UTF-8 locale (e.g. LANG=en_GB.UTF-8)
-somewhere else you consider suitable.
-
-Additionally the server that you are connecting to must have the same
-locale installed (though it need not be set as the default).
diff --git a/network/mosh/mosh.SlackBuild b/network/mosh/mosh.SlackBuild
deleted file mode 100644
index 8127e0ff4d..0000000000
--- a/network/mosh/mosh.SlackBuild
+++ /dev/null
@@ -1,107 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for mosh
-
-# Written by ruario
-# Formerly maintained by Donald Cooley, South Haven, Indiana, USA
-# Now maintained by B. Watson <urchlay@slackware.uk>.
-# Original script had no license; modified version licensed under
-# the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
-
-# 20230225 bkw: homepage/download changed.
-
-# 20220425 bkw: BUILD=2
-# - take over maintenance.
-# - relicense script as WTFPL.
-# - include a couple more doc files (THANKS and ocb-license.html).
-# - add bash completion to package.
-# - add ufw integration to package (untested; I don't run ufw).
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=mosh
-VERSION=${VERSION:-1.4.0}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-
-# patch to work with newer protobuf3
-patch -p1 < $CWD/1282.patch
-
-autoreconf -vif
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS -fpermissive" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --build=$ARCH-slackware-linux
-
-make
-make install-strip DESTDIR=$PKG
-gzip -9 $PKG/usr/man/man*/*
-
-install -D -m0644 \
- conf/bash-completion/completions/$PRGNAM \
- $PKG/usr/share/bash-completion/completions/$PRGNAM
-
-install -D -m0644 \
- conf/ufw/applications.d/$PRGNAM \
- $PKG/etc/ufw/applications.d/$PRGNAM
-
-PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
-mkdir -p $PKGDOC
-cp -a AUTHORS COPYING ChangeLog NEWS *.md *.html THANKS $PKGDOC
-cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/mosh/mosh.info b/network/mosh/mosh.info
deleted file mode 100644
index 9578dd57f8..0000000000
--- a/network/mosh/mosh.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="mosh"
-VERSION="1.4.0"
-HOMEPAGE="https://mosh.org"
-DOWNLOAD="https://mosh.org/mosh-1.4.0.tar.gz"
-MD5SUM="c34a647f8545565d79188acacaea7559"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="perl-IO-Tty protobuf3"
-MAINTAINER="B. Watson"
-EMAIL="urchlay@slackware.uk"
diff --git a/network/mosh/slack-desc b/network/mosh/slack-desc
deleted file mode 100644
index 077b45efd6..0000000000
--- a/network/mosh/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-mosh: mosh (MObile SHell server and client)
-mosh:
-mosh: Remote terminal application that allows roaming, supports intermittent
-mosh: connectivity, and provides intelligent local echo and line editing of
-mosh: user keystrokes.
-mosh:
-mosh: Mosh attempts to improve on SSH by being more robust and responsive,
-mosh: especially over Wi-Fi, cellular, and long-distance links.
-mosh:
-mosh: http://mosh.mit.edu/
-mosh: