summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Dimitris Zlatanidis2024-05-12 18:52:32 +0200
committer Willy Sudiarto Raharjo2024-05-18 01:55:35 +0200
commit8f30d54ec09e1964cd289e532bd6a1a1800c49b4 (patch)
tree4cbdb6a6e525a48cdd2a3b8e015bbb4bf29a5613 /network
parent6137974fa8bf629a46639a0a3373e2d94b8eb535 (diff)
downloadslackbuilds-8f30d54ec09e1964cd289e532bd6a1a1800c49b4.tar.gz
network/weathercli: Removed unused.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/weathercli/README7
-rw-r--r--network/weathercli/slack-desc19
-rw-r--r--network/weathercli/weathercli.SlackBuild114
-rw-r--r--network/weathercli/weathercli.info10
4 files changed, 0 insertions, 150 deletions
diff --git a/network/weathercli/README b/network/weathercli/README
deleted file mode 100644
index 149945d250..0000000000
--- a/network/weathercli/README
+++ /dev/null
@@ -1,7 +0,0 @@
-weathercli is a command line weather tool.
-
-Pass the script your API Key:
-API_KEY=my_api_key_here ./weathercli.SlackBuild
-
-Get your API Key on this page:
-https://openweathermap.org/
diff --git a/network/weathercli/slack-desc b/network/weathercli/slack-desc
deleted file mode 100644
index 66c96bdf0c..0000000000
--- a/network/weathercli/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-weathercli: weathercli (a command line weather tool)
-weathercli:
-weathercli: You've spent hours, days, months, maybe years customizing your
-weathercli: terminal. And yet so many things draw your attention away from it.
-weathercli:
-weathercli: Homepage: https://github.com/brianriley/weather-cli
-weathercli:
-weathercli:
-weathercli:
-weathercli:
-weathercli:
diff --git a/network/weathercli/weathercli.SlackBuild b/network/weathercli/weathercli.SlackBuild
deleted file mode 100644
index 12cd688468..0000000000
--- a/network/weathercli/weathercli.SlackBuild
+++ /dev/null
@@ -1,114 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for weathercli
-
-# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=weathercli
-VERSION=${VERSION:-2.3.1}
-BUILD=${BUILD:-3}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-if [ "$API_KEY" = "" ]; then
- echo ""
- echo "API_KEY not found !!! Please pass the script your API Key"
- echo "API_KEY=my_api_key_here ./weathercli.SlackBuild"
- echo "Get your API Key on this page : https://openweathermap.org/"
- echo ""
- exit 1
-fi
-
-# Patch API Key
-API_KEY=${API_KEY}
-echo $API_KEY
-echo $API_KEY | sed -i "s/&units={1}/\&units={1}\&appid=$API_KEY/" weathercli.py
-
-# rename executable
-sed -i "s/bin\/weather/bin\/weathercli/" setup.py
-mv bin/weather bin/weathercli
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE PKG-INFO README.mkd $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/weathercli/weathercli.info b/network/weathercli/weathercli.info
deleted file mode 100644
index 20aa1a84ea..0000000000
--- a/network/weathercli/weathercli.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="weathercli"
-VERSION="2.3.1"
-HOMEPAGE="https://github.com/brianriley/weather-cli"
-DOWNLOAD="https://files.pythonhosted.org/packages/a5/ff/53c22b373493083dcfcea6e2e669016339fc16dbfeb465053b3a854c0fe2/weathercli-2.3.1.tar.gz"
-MD5SUM="09a930ca81da6d79e8ea241ce9bc6567"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="clint"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"