summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Heinz Wiesinger2010-05-13 00:08:35 +0200
committer Heinz Wiesinger2010-05-13 00:08:35 +0200
commit07126c73a9655acc8f4dc4c594ce844593aab05b (patch)
tree0f7071f7b2cb32838d773007f1fd431c97245155 /network
parente95fe2480530d1e0aa6dc20c85d9898d2b4098ca (diff)
downloadslackbuilds-07126c73a9655acc8f4dc4c594ce844593aab05b.tar.gz
network/ccrtp: Removed from 13.0 repository
Diffstat (limited to 'network')
-rw-r--r--network/ccrtp/README10
-rw-r--r--network/ccrtp/ccrtp.SlackBuild105
-rw-r--r--network/ccrtp/ccrtp.info8
-rw-r--r--network/ccrtp/slack-desc19
4 files changed, 0 insertions, 142 deletions
diff --git a/network/ccrtp/README b/network/ccrtp/README
deleted file mode 100644
index 1e84378346..0000000000
--- a/network/ccrtp/README
+++ /dev/null
@@ -1,10 +0,0 @@
-GNU ccRTP is an implementation of RTP, the real-time transport
-protocol from the IETF, supporting the Secure RTP profile, SRTP.
-
-ccRTP is a C++ library based on GNU Common C++ which provides a high
-performance, flexible and extensible standards-compliant RTP stack
-with full RTCP support.
-The design and implementation of ccRTP make it suitable for high
-capacity servers and gateways as well as personal client applications.
-
-This package requires commoncpp2, available on SlackBuilds.org. \ No newline at end of file
diff --git a/network/ccrtp/ccrtp.SlackBuild b/network/ccrtp/ccrtp.SlackBuild
deleted file mode 100644
index cc6518f3fb..0000000000
--- a/network/ccrtp/ccrtp.SlackBuild
+++ /dev/null
@@ -1,105 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for ccrtp
-
-# Copyright 2008 Mauro Giachero (mauro dot giachero at gmail dot com)
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=ccrtp
-VERSION=${VERSION:-1.7.1}
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --infodir=/usr/info
-
-make
-make install DESTDIR=$PKG
-# man pages aren't automatically installed
-mv doc/man $PKG/usr
-
-# Remove static libraries
-rm $PKG/usr/lib/*a
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
-)
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
-rm -f $PKG/usr/info/dir
-gzip -9 $PKG/usr/info/*.info*
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a doc/* demo [A-LN-Z]* $PKG/usr/doc/$PRGNAM-$VERSION
-
-# Remove stale Makefiles
-rm -f $PKG/usr/doc/$PRGNAM-$VERSION/Makefile*
-
-# Fix documentation permissions
-find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
-find $PKG/usr/doc/$PRGNAM-$VERSION -type d -exec chmod 755 {} \;
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/network/ccrtp/ccrtp.info b/network/ccrtp/ccrtp.info
deleted file mode 100644
index 5a466590dd..0000000000
--- a/network/ccrtp/ccrtp.info
+++ /dev/null
@@ -1,8 +0,0 @@
-PRGNAM="ccrtp"
-VERSION="1.7.1"
-HOMEPAGE="http://www.gnutelephony.org/"
-DOWNLOAD="http://www.gnutelephony.org/dist/archive/ccrtp-1.7.1.tar.gz"
-MD5SUM="9f5d34a18f2c1c779d2e5818cc4987f8"
-MAINTAINER="Mauro Giachero"
-EMAIL="mauro dot giachero at gmail dot com"
-APPROVED="dsomero"
diff --git a/network/ccrtp/slack-desc b/network/ccrtp/slack-desc
deleted file mode 100644
index a8474a5681..0000000000
--- a/network/ccrtp/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-ccrtp: ccRTP (real-time transport protocol)
-ccrtp:
-ccrtp: GNU ccRTP is an implementation of RTP, the real-time transport
-ccrtp: protocol from the IETF, supporting the Secure RTP profile, SRTP.
-ccrtp: ccRTP is a C++ library based on GNU Common C++ which provides a high
-ccrtp: performance, flexible and extensible standards-compliant RTP stack
-ccrtp: with full RTCP support.
-ccrtp: The design and implementation of ccRTP make it suitable for high
-ccrtp: capacity servers and gateways as well as personal client
-ccrtp: applications.
-ccrtp: Homepage: http://www.gnutelephony.org/