summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-02-06 13:36:09 +0100
committer Erik Hanson2014-02-08 18:10:11 +0100
commitfa1a4958484810b8157319fb3fb1ff561b98e045 (patch)
tree8fdad55102a296ff98add4ff18e355d55a12118c /network
parentdfb9836279b434137aa000b2c4762cf84e20383a (diff)
downloadslackbuilds-fa1a4958484810b8157319fb3fb1ff561b98e045.tar.gz
network/CherryMusic: Added (A music streaming server).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/CherryMusic/CherryMusic.SlackBuild94
-rw-r--r--network/CherryMusic/CherryMusic.info10
-rw-r--r--network/CherryMusic/README13
-rw-r--r--network/CherryMusic/doinst.sh3
-rw-r--r--network/CherryMusic/slack-desc19
5 files changed, 139 insertions, 0 deletions
diff --git a/network/CherryMusic/CherryMusic.SlackBuild b/network/CherryMusic/CherryMusic.SlackBuild
new file mode 100644
index 0000000000..18d2cbb497
--- /dev/null
+++ b/network/CherryMusic/CherryMusic.SlackBuild
@@ -0,0 +1,94 @@
+#!/bin/sh
+
+# Slackware build script for CherryMusic
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=CherryMusic
+SCRNAM=cherrymusic
+VERSION=${VERSION:-0.30.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SCRNAM-$VERSION
+tar xvf $CWD/$SCRNAM-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
+cd $SCRNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+install -D -m644 doc/man/cherrymusic.1 $PKG/usr/man/man1/cherrymusic.1
+install -D -m644 doc/man/cherrymusic.conf.5 $PKG/usr/man/man5/cherrymusic.conf.5
+install -D -m644 doc/man/cherrymusicd.8 $PKG/usr/man/man8/cherrymusicd.8
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES COPYING README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/CherryMusic/CherryMusic.info b/network/CherryMusic/CherryMusic.info
new file mode 100644
index 0000000000..2f3aa358fd
--- /dev/null
+++ b/network/CherryMusic/CherryMusic.info
@@ -0,0 +1,10 @@
+PRGNAM="CherryMusic"
+VERSION="0.30.0"
+HOMEPAGE="http://www.fomori.org/cherrymusic/"
+DOWNLOAD="https://github.com/devsnd/cherrymusic/archive/0.30.0.tar.gz"
+MD5SUM="e3fa56220446556964c19a52f5d504c3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="CherryPy mutagen"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/network/CherryMusic/README b/network/CherryMusic/README
new file mode 100644
index 0000000000..780549229f
--- /dev/null
+++ b/network/CherryMusic/README
@@ -0,0 +1,13 @@
+CherryMusic is a music streaming server based on CherryPy and jPlayer.
+It plays the music inside your PC, smartphone, tablet, toaster or whatever
+device has a HTML5 compliant browser installed.
+
+current features:
+
+ - stream your music inside the browser (locally or remote)
+ - browse and search your music
+ - completely AJAX based (no page reloads on click, therefore fast)
+ - create and share playlists
+ - multiple user authentication
+ - HTTPS support
+ - automatic album cover art fetching
diff --git a/network/CherryMusic/doinst.sh b/network/CherryMusic/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/network/CherryMusic/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/network/CherryMusic/slack-desc b/network/CherryMusic/slack-desc
new file mode 100644
index 0000000000..2cda5edf43
--- /dev/null
+++ b/network/CherryMusic/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+CherryMusic: CherryMusic (A music streaming server written in python)
+CherryMusic:
+CherryMusic: CherryMusic is a music streaming server based on CherryPy and
+CherryMusic: jPlayer.It plays the music inside your PC, smartphone, tablet,
+CherryMusic: toaster or whatever device has a HTML5 compliant browser installed.
+CherryMusic:
+CherryMusic: Homepage: http://www.fomori.org/cherrymusic/
+CherryMusic:
+CherryMusic:
+CherryMusic:
+CherryMusic: