summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-01-30 11:16:04 +0100
committer Robby Workman2014-02-01 07:40:31 +0100
commite7d79ab4e2757b9756d6469d5a86bab1e536e7f6 (patch)
tree98987791f88bd9b7e59e73427762c14ef3f47b29 /network
parent521afa9bd8f5077013adc7c861770f72d0088103 (diff)
downloadslackbuilds-e7d79ab4e2757b9756d6469d5a86bab1e536e7f6.tar.gz
network/asciinema: Added (Command line recorder for asciinema.org).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/asciinema/README4
-rw-r--r--network/asciinema/asciinema.SlackBuild86
-rw-r--r--network/asciinema/asciinema.info10
-rw-r--r--network/asciinema/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/network/asciinema/README b/network/asciinema/README
new file mode 100644
index 0000000000..21c8dc9e78
--- /dev/null
+++ b/network/asciinema/README
@@ -0,0 +1,4 @@
+Record and share your terminal sessions,
+the right way.
+Forget screen recording apps and blurry video.
+Enjoy a lightweight, purely text based approach to terminal recording.
diff --git a/network/asciinema/asciinema.SlackBuild b/network/asciinema/asciinema.SlackBuild
new file mode 100644
index 0000000000..afe15e8c46
--- /dev/null
+++ b/network/asciinema/asciinema.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for asciinema
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+PRGNAM=asciinema
+VERSION=${VERSION:-0.9.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/asciinema/asciinema.info b/network/asciinema/asciinema.info
new file mode 100644
index 0000000000..58fc6cba8b
--- /dev/null
+++ b/network/asciinema/asciinema.info
@@ -0,0 +1,10 @@
+PRGNAM="asciinema"
+VERSION="0.9.7"
+HOMEPAGE="http://asciinema.org"
+DOWNLOAD="https://pypi.python.org/packages/source/a/asciinema/asciinema-0.9.7.tar.gz"
+MD5SUM="df9cde430210db8f054e78e163914ca5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools python-requests"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/network/asciinema/slack-desc b/network/asciinema/slack-desc
new file mode 100644
index 0000000000..c66a3a18bc
--- /dev/null
+++ b/network/asciinema/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+asciinema: asciinema (Command line recorder for asciinema.org service)
+asciinema:
+asciinema: Record and share your terminal sessions, the right way.
+asciinema:
+asciinema: Homepage: https://asciinema.org
+asciinema:
+asciinema:
+asciinema:
+asciinema:
+asciinema:
+asciinema: