summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Andrew Tkalia2013-06-30 07:11:34 +0200
committer Erik Hanson2013-06-30 07:17:26 +0200
commit918a1e3ff8516fcb6b6dbb03dde3b45f28112440 (patch)
tree8e58cb5bad10e98b192720bf5aaf882fa9b5c7f7 /network
parent4bbe59cb3e2695c3d4526cdb2797fb5bb289bb65 (diff)
downloadslackbuilds-918a1e3ff8516fcb6b6dbb03dde3b45f28112440.tar.gz
network/luakit: Added (micro-browser framework)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/luakit/README12
-rw-r--r--network/luakit/doinst.sh9
-rw-r--r--network/luakit/luakit.SlackBuild98
-rw-r--r--network/luakit/luakit.info10
-rw-r--r--network/luakit/slack-desc19
5 files changed, 148 insertions, 0 deletions
diff --git a/network/luakit/README b/network/luakit/README
new file mode 100644
index 0000000000..506335e951
--- /dev/null
+++ b/network/luakit/README
@@ -0,0 +1,12 @@
+luakit is a fast, light and simple to use micro-browser framework
+exensible by Lua using the WebKit web content engine and the GTK+
+toolkit.
+
+The configuration options are endless, the entire browser is
+constructed by the config files present in /etc/xdg/luakit
+Just copy the files you wish to change (and the rc.lua) into
+$XDG_CONFIG_HOME/luakit (defaults to ~/.config/luakit) and
+luakit will use those files when you next launch it.
+
+luajit and libunique are optional dependencies.
+You can pass LUAJIT=1 UNIQUE=1 to the SlackBuild.
diff --git a/network/luakit/doinst.sh b/network/luakit/doinst.sh
new file mode 100644
index 0000000000..3e5691a052
--- /dev/null
+++ b/network/luakit/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/network/luakit/luakit.SlackBuild b/network/luakit/luakit.SlackBuild
new file mode 100644
index 0000000000..731c4d5877
--- /dev/null
+++ b/network/luakit/luakit.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/sh
+
+# Slackware build script for luakit
+
+# Copyright 2013, Andrew Tkalia <anddt@yandex.ru>, Ukraine, Kyiv
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=luakit
+VERSION=${VERSION:-2012.09.13_r1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+SRCVER=`echo $VERSION |tr _ -`
+LUAJIT=${LUAJIT:-0} # 0 or 1
+UNIQUE=${UNIQUE:-0} # 0 or 1
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+else
+ SLKCFLAGS="-O2"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$SRCVER
+tar xvf $CWD/$SRCVER.tar.gz
+cd $PRGNAM-$SRCVER
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+_CFLAGS=`cat config.mk |grep CFLAGS | sed -e "s/CFLAGS//g" -e "s/+=//g" |tr "\n" " "`
+make \
+ PREFIX=/usr \
+ MANPREFIX=/usr/man \
+ DOCDIR=/usr/doc/luakit-$VERSION \
+ CFLAGS="$_CFLAGS $SLKCFLAGS" \
+ USE_LUAJIT=$LUAJIT \
+ USE_UNIQUE=$UNIQUE
+
+make install \
+ DESTDIR=$PKG \
+ PREFIX=/usr \
+ MANPREFIX=$PKG/usr/man \
+ DOCDIR=$PKG/usr/doc/luakit-$VERSION
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/luakit/luakit.info b/network/luakit/luakit.info
new file mode 100644
index 0000000000..9d98cdfc80
--- /dev/null
+++ b/network/luakit/luakit.info
@@ -0,0 +1,10 @@
+PRGNAM="luakit"
+VERSION="2012.09.13_r1"
+HOMEPAGE="https://github.com/mason-larobina/luakit"
+DOWNLOAD="https://github.com/mason-larobina/luakit/archive/2012.09.13-r1.tar.gz"
+MD5SUM="75106dfacc7506b2640a678a3af56f1f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="lua webkitgtk help2man lua-filesystem"
+MAINTAINER="Andrew Tkalia"
+EMAIL="anddt@yandex.ru"
diff --git a/network/luakit/slack-desc b/network/luakit/slack-desc
new file mode 100644
index 0000000000..a69c6d53ef
--- /dev/null
+++ b/network/luakit/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+luakit: luakit (micro-browser framework)
+luakit:
+luakit: luakit is a fast, light and simple to use micro-browser framework
+luakit: exensible by Lua using the WebKit web content engine and the GTK+
+luakit: toolkit.
+luakit: The configuration options are endless, the entire browser is
+luakit: constructed by the config files present in /etc/xdg/luakit
+luakit: Just copy the files you wish to change (and the rc.lua) into
+luakit: $XDG_CONFIG_HOME/luakit (defaults to ~/.config/luakit) and
+luakit: luakit will use those files when you next launch it.
+luakit: