summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Andrew Tkalia2013-04-28 16:43:08 +0200
committer Niels Horn2013-04-28 16:43:08 +0200
commit25db2752c493338598050d68261c3a5497ef44bb (patch)
tree552891cd1ea714d5638b363b2bb3ea1d970cde71 /network
parentcd5a28a122e4d2e8d62460ed5fd8a07579d5d685 (diff)
downloadslackbuilds-25db2752c493338598050d68261c3a5497ef44bb.tar.gz
network/prosody: Added (Lua XMPP Server)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/prosody/README13
-rw-r--r--network/prosody/README.SBo16
-rw-r--r--network/prosody/doinst.sh16
-rw-r--r--network/prosody/prosody.SlackBuild137
-rw-r--r--network/prosody/prosody.info10
-rw-r--r--network/prosody/slack-desc19
6 files changed, 211 insertions, 0 deletions
diff --git a/network/prosody/README b/network/prosody/README
new file mode 100644
index 0000000000..c426c565c1
--- /dev/null
+++ b/network/prosody/README
@@ -0,0 +1,13 @@
+Prosody is a server for Jabber/XMPP written in Lua. It aims to be
+easy to use and light on resources. For developers, it aims to give a
+flexible system on which to rapidly develop added functionality or
+rapidly prototype new protocols.
+
+Before you can run prosody you'll need to look in README.SBo.
+
+You need a "prosody" user and group prior to building prosody.
+Something like this will suffice for most systems:
+ groupadd -g 274 prosody
+ useradd -u 274 -g 274 -s /sbin/nologin -d /var/lib/prosody prosody
+Feel free to use a different uid and gid if desired, but 274 is
+recommended to avoid conflicts with other stuff from SlackBuilds.org.
diff --git a/network/prosody/README.SBo b/network/prosody/README.SBo
new file mode 100644
index 0000000000..f5a75cd65c
--- /dev/null
+++ b/network/prosody/README.SBo
@@ -0,0 +1,16 @@
+In order to start prosody at boot and stop it properly at shutdown,
+make sure rc.local and rc.local_shutdown contain the following lines:
+
+ /etc/rc.d/rc.local
+ ==================
+ # Startup prosody
+ if [ -x /usr/bin/prosodyctl ]; then
+ lua /usr/bin/prosodyctl start
+ fi
+
+ /etc/rc.d/rc.local_shutdown
+ ===========================
+ # Stop prosody
+ if [ -x /usr/bin/prosodyctl ]; then
+ lua /usr/bin/prosodyctl stop
+ fi
diff --git a/network/prosody/doinst.sh b/network/prosody/doinst.sh
new file mode 100644
index 0000000000..4cac92dbfa
--- /dev/null
+++ b/network/prosody/doinst.sh
@@ -0,0 +1,16 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ rm $NEW
+ fi
+}
+
+config etc/prosody/migrator.cfg.lua.new
+config etc/prosody/prosody.cfg.lua.new
+config etc/prosody/certs/localhost.key.new
+config etc/prosody/certs/localhost.cert.new
+config etc/prosody/certs/Makefile.new
+config etc/prosody/certs/openssl.cnf.new
diff --git a/network/prosody/prosody.SlackBuild b/network/prosody/prosody.SlackBuild
new file mode 100644
index 0000000000..bce75bd00b
--- /dev/null
+++ b/network/prosody/prosody.SlackBuild
@@ -0,0 +1,137 @@
+#!/bin/sh
+
+# Slackware build script for prosody
+
+# Copyright 2013, Andrew Tkalia <anddt@yandex.ru>, Ukraine, Kyiv
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=prosody
+VERSION=${VERSION:-0.8.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+PROSODY_UID=${PROSODY_UID:-274}
+PROSODY_GID=${PROSODY_GID:-274}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+# Bail out if user or group isn't valid on your system
+# Let prosody uid/gid be 274/274 :)
+if ! grep ^prosody: /etc/group 2>&1 > /dev/null; then
+ echo " You must have a prosody group to run this script."
+ echo " # groupadd -g $PROSODY_GID prosody"
+ exit 1
+elif ! grep ^prosody: /etc/passwd 2>&1 > /dev/null; then
+ echo " You must have a prosody user to run this script."
+ echo " # useradd -u $PROSODY_UID -g $PROSODY_GID -s /sbin/nologin -d /var/lib/prosody prosody"
+ exit 1
+fi
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ #SLKCFLAGS="-O2 -fPIC"
+ #LIBDIRSUFFIX="64"
+ echo "Your arch is not supported yet. I am sorry"
+ exit 1
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+mkdir $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+./configure \
+ --ostype=linux \
+ --prefix=/usr \
+ --sysconfdir=/etc/prosody \
+ --datadir=/var/lib/prosody \
+ --with-lua=/usr \
+ --with-lua-lib=/usr/lib${LIBDIRSUFFIX} \
+ --with-lua-include=/usr/include \
+ --cflags="-fPIC -Wall ${SLKCFLAGS}"
+
+make
+make install \
+ DESTDIR=$PKG \
+ MAN="${PKG}/usr/man"
+
+# Install migrator.
+cd tools/migration
+ make
+ make install \
+ DESTDIR=$PKG \
+ MAN="${PKG}/usr/man"
+cd -
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS INSTALL COPYING DEPENDS README HACKERS TODO doc/*.* \
+ tools/{ejabberd2prosody.lua,erlparse.lua,xep227toprosody.lua,ejabberdsql2prosody.lua} \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+chown -R prosody:prosody $PKG/var/lib/prosody
+chmod 700 $PKG/var/lib/prosody
+
+# I like to mv it mv it :)
+for i in `find $PKG/etc/prosody -type f`; do mv $i $i.new; done
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/prosody/prosody.info b/network/prosody/prosody.info
new file mode 100644
index 0000000000..757758eb90
--- /dev/null
+++ b/network/prosody/prosody.info
@@ -0,0 +1,10 @@
+PRGNAM="prosody"
+VERSION="0.8.2"
+HOMEPAGE="http://prosody.im/"
+DOWNLOAD="http://distfiles.macports.org/prosody/prosody-0.8.2.tar.gz"
+MD5SUM="6e907bf0d0acf24f1011083020ba6ffb"
+DOWNLOAD_x86_64="UNSUPPORTED"
+MD5SUM_x86_64=""
+REQUIRES="lua luasocket luaexpat lua-filesystem"
+MAINTAINER="Andrew Tkalia"
+EMAIL="anddt@yandex.ru"
diff --git a/network/prosody/slack-desc b/network/prosody/slack-desc
new file mode 100644
index 0000000000..8d7c083519
--- /dev/null
+++ b/network/prosody/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+prosody: prosody (Lua XMPP Server)
+prosody:
+prosody: Prosody is a modern flexible communications server for Jabber XMPP
+prosody: written in Lua. It aims to be easy to set up and configure, and
+prosody: light on resources. For developers it aims to be easy to extend and
+prosody: give a flexible system on which to rapidly develop added
+prosody: functionality, or prototype new protocols.
+prosody:
+prosody: Prosody is licensed under the permissive MIT/X11 license.
+prosody:
+prosody: