summaryrefslogtreecommitdiffstats
path: root/network/wput
diff options
context:
space:
mode:
author Chris Abela2010-05-12 23:32:53 +0200
committer David Somero2010-05-12 23:32:53 +0200
commit0d9cd4b8b635e1a39d7a34e9079e3c4639248c1f (patch)
tree63b756af8082b73b49ac1bd31b15a320f1651454 /network/wput
parent9d3128ccaf04b40859fac62c05a00e900d22535b (diff)
downloadslackbuilds-0d9cd4b8b635e1a39d7a34e9079e3c4639248c1f.tar.gz
network/wput: Added to 12.2 repository
Diffstat (limited to 'network/wput')
-rw-r--r--network/wput/README5
-rw-r--r--network/wput/slack-desc18
-rw-r--r--network/wput/wput.SlackBuild79
-rw-r--r--network/wput/wput.info8
4 files changed, 110 insertions, 0 deletions
diff --git a/network/wput/README b/network/wput/README
new file mode 100644
index 0000000000..6c1fd72a3d
--- /dev/null
+++ b/network/wput/README
@@ -0,0 +1,5 @@
+wput - A utility for putting files using the FTP protocol from the
+ command line.
+
+wput is a tiny program that looks like wget and is designed to upload
+files or whole directories to remote ftp-servers.
diff --git a/network/wput/slack-desc b/network/wput/slack-desc
new file mode 100644
index 0000000000..61b5897d4c
--- /dev/null
+++ b/network/wput/slack-desc
@@ -0,0 +1,18 @@
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |--------handy-ruler------------------------------------------------------|
+wput: wput (utility for putting files using the FTP protocol)
+wput:
+wput: wput is a tiny program that looks like wget and is designed to upload
+wput: files or whole directories to remote ftp-servers.
+wput:
+wput:
+wput:
+wput:
+wput:
+wput:
+wput:
diff --git a/network/wput/wput.SlackBuild b/network/wput/wput.SlackBuild
new file mode 100644
index 0000000000..0abb5d2f84
--- /dev/null
+++ b/network/wput/wput.SlackBuild
@@ -0,0 +1,79 @@
+#!/bin/sh
+
+# Slackware build script for wput
+# May 2009
+
+# Written by Chris Abela <chris.abela@maltats.com>
+
+PRGNAM=wput
+VERSION=${VERSION:-0.6.1}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG/usr/{bin,man/man1} $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tgz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=$PKG/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --build=$ARCH-slackware-linux \
+ --host=$ARCH-slackware-linux
+
+# Maximum compression for the man file:
+sed -i 's/gzip/gzip -9/' doc/Makefile
+
+make
+
+# Unable to set --datadir for configure script:
+sed -i 's/^datadir *= $(prefix)\/share/datadir = $(prefix)/' Makefile
+
+make install
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ABOUT-NLS COPYING ChangeLog INSTALL TODO doc/{USAGE.*,passwordfile,wputrc} \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/network/wput/wput.info b/network/wput/wput.info
new file mode 100644
index 0000000000..da0a7cd001
--- /dev/null
+++ b/network/wput/wput.info
@@ -0,0 +1,8 @@
+PRGNAM="wput"
+VERSION="0.6.1"
+HOMEPAGE="http://wput.sourceforge.net/"
+DOWNLOAD="http://garr.dl.sourceforge.net/sourceforge/wput/wput-0.6.1.tgz"
+MD5SUM="92b41efed4db8eb4f3443c23bf7ceecf"
+MAINTAINER="Chris Abela"
+EMAIL="chris.abela@maltats.com"
+APPROVED="dsomero"