summaryrefslogtreecommitdiffstats
path: root/network/wireshark
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2019-03-02 01:37:52 +0100
committer Willy Sudiarto Raharjo2019-03-16 00:53:14 +0100
commitd307482fe0e38020f0cc04baea2a2077a5ff5feb (patch)
tree4b86002b840ca08a29e54b4bc1b57931c62597af /network/wireshark
parente5127021a37935871aacbd31497c73342e0d8e3f (diff)
downloadslackbuilds-d307482fe0e38020f0cc04baea2a2077a5ff5feb.tar.gz
network/wireshark: Updated for version 3.0.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/wireshark')
-rw-r--r--network/wireshark/README7
-rw-r--r--network/wireshark/wireshark.SlackBuild45
-rw-r--r--network/wireshark/wireshark.info8
3 files changed, 25 insertions, 35 deletions
diff --git a/network/wireshark/README b/network/wireshark/README
index 6214c771c0..65c3490f74 100644
--- a/network/wireshark/README
+++ b/network/wireshark/README
@@ -9,7 +9,7 @@ options. It allows the user to see all traffic being passed over the network
(usually an Ethernet network but support is being added for others) by
putting the network interface into promiscuous mode.
-Wireshark uses the cross-platform GTK+ widget toolkit. Its powerful features
+Wireshark uses the cross-platform Qt5 widget toolkit. Its powerful features
make it the tool of choice for network troubleshooting, protocol development,
and education worldwide.
@@ -25,13 +25,14 @@ when upgrading).
Optional dependencies:
- c-ares
-- portaudio
- krb5
+- nghttp2
- spandsp
- snappy
- lz4
+- libsmi
-NOTE: Wireshark 2.6 is the last release to support the legacy GTK-based UI.
+NOTE: Wireshark 3.0 no longer support legacy GTK+ UI.
NOTE: Although lua is listed as a requirement, it's possible to build
using lua52. This may be needed for some third-party Lua plugins (but,
diff --git a/network/wireshark/wireshark.SlackBuild b/network/wireshark/wireshark.SlackBuild
index 743eb6f43b..f06818c8ee 100644
--- a/network/wireshark/wireshark.SlackBuild
+++ b/network/wireshark/wireshark.SlackBuild
@@ -30,7 +30,7 @@
# Modified by B. Watson <yalhcru@gmail.com> to add lua52 support.
PRGNAM=wireshark
-VERSION=${VERSION:-2.6.7}
+VERSION=${VERSION:-3.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -73,10 +73,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Ammend hardcoded paths to /usr/lib/ which will give a problem when compiling on
-# systems with 32bit compat libs install. Thanks to Heinz Wiesinger.
-sed -i "s|/lib)|/lib$LIBDIRSUFFIX)|g" configure.ac
-
# We have 3 lua versions on SBo: lua is v5.1, lua52 is 5.2, lua53 is 5.3.
# Wireshark only supports 5.1 and 5.2, not 5.3. The lua version doesn't
# affect core wireshark, only 3rd-party plugins written in lua. Most
@@ -94,36 +90,29 @@ else
echo "=== Building with lua (v5.1)"
fi
-# run autoreconf so it'll use the correct automake version.
-autoreconf -f -i
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --with-ssl=/usr/lib${LIBDIRSUFFIX} \
- --enable-packet-editor \
- --enable-setuid-install \
- --with-gtk=3 \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+mv $PKG/usr/share/man $PKG/usr/
+
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/include/$PRGNAM/{epan/{crypt,dfilter,dissectors,ftypes,wmem},wiretap,wsutil}
-install -m644 config.h ws_diag_control.h ws_symbol_export.h $PKG/usr/include/$PRGNAM
- for d in epan epan/crypt epan/dfilter epan/dissectors epan/ftypes epan/wmem wiretap wsutil; do
+install -m644 ws_diag_control.h ws_symbol_export.h $PKG/usr/include/$PRGNAM
+ for d in epan epan/crypt epan/dfilter epan/dissectors epan/ftypes epan/wmem; do
install -m644 $d/*.h $PKG/usr/include/$PRGNAM/$d
done
@@ -134,7 +123,7 @@ cp $PRGNAM.desktop $PKG/usr/share/applications
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS* COPYING ChangeLog INSTALL* NEWS README* doc/READM* \
+cp -a AUTHORS* COPYING ChangeLog INSTALL NEWS README* doc/READM* \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/network/wireshark/wireshark.info b/network/wireshark/wireshark.info
index 1e7898407e..435f74343a 100644
--- a/network/wireshark/wireshark.info
+++ b/network/wireshark/wireshark.info
@@ -1,10 +1,10 @@
PRGNAM="wireshark"
-VERSION="2.6.7"
+VERSION="3.0.0"
HOMEPAGE="https://www.wireshark.org/"
-DOWNLOAD="https://1.as.dl.wireshark.org/src/wireshark-2.6.7.tar.xz"
-MD5SUM="6d0545309cace70e51f5555a3a966fbc"
+DOWNLOAD="https://1.as.dl.wireshark.org/src/wireshark-3.0.0.tar.xz"
+MD5SUM="258d62ac7434d126dc497303c8f7961b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="qt5 lua"
+REQUIRES="qt5 lua python3"
MAINTAINER="Willy Sudiarto Raharjo"
EMAIL="willysr@slackbuilds.org"