summaryrefslogtreecommitdiffstats
path: root/network/spice-gtk/spice-gtk.SlackBuild
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2014-02-16 09:37:53 +0100
committer Erik Hanson2014-02-18 21:59:39 +0100
commit05f1b4a064a1f4d4ff7500fbd1b8b94b2edbd026 (patch)
tree9f1a5894b2b59cf7438fa832d6b9b4cf08291aec /network/spice-gtk/spice-gtk.SlackBuild
parentb44d59789b5827e9083b7a5d38153f061067f2ca (diff)
downloadslackbuilds-05f1b4a064a1f4d4ff7500fbd1b8b94b2edbd026.tar.gz
network/spice-gtk: Updated for version 0.23.
Drop the tests or build breaks (thanks to rworkman@slackbuilds.org for the hint) Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'network/spice-gtk/spice-gtk.SlackBuild')
-rw-r--r--network/spice-gtk/spice-gtk.SlackBuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/network/spice-gtk/spice-gtk.SlackBuild b/network/spice-gtk/spice-gtk.SlackBuild
index 0623b9d330..fe573b5946 100644
--- a/network/spice-gtk/spice-gtk.SlackBuild
+++ b/network/spice-gtk/spice-gtk.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh
# Slackware build script for spice-gtk
-# Copyright 2013 Matteo Bernardini <ponce@slackbuilds.org> Pisa, Italy
+# Copyright 2013-2014 Matteo Bernardini <ponce@slackbuilds.org> Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,7 +22,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=spice-gtk
-VERSION=${VERSION:-0.21}
+VERSION=${VERSION:-0.23}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,10 +70,13 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Disable broken tests
+sed -i 's/ tests//' Makefile.am Makefile.in
rm gtk/controller/controller.c gtk/controller/controller.vala.stamp gtk/controller/menu.c
export VALAC=$(which valac)