summaryrefslogtreecommitdiffstats
path: root/network/snmpsim/snmpsim.SlackBuild
diff options
context:
space:
mode:
author Ilya Etingof2011-12-18 07:04:04 +0100
committer Robby Workman2011-12-18 07:04:04 +0100
commitad4ad1471a706b8393709a66ccd505744f69f0d4 (patch)
tree348626410ca864e17371e6e96a549fd2fbd7fca7 /network/snmpsim/snmpsim.SlackBuild
parent0a64d3902cf566ec509bca669b9bf90f0125cd16 (diff)
downloadslackbuilds-ad4ad1471a706b8393709a66ccd505744f69f0d4.tar.gz
network/snmpsim: Added (SNMP Agent simulator)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'network/snmpsim/snmpsim.SlackBuild')
-rw-r--r--network/snmpsim/snmpsim.SlackBuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/network/snmpsim/snmpsim.SlackBuild b/network/snmpsim/snmpsim.SlackBuild
new file mode 100644
index 0000000000..03e828da4c
--- /dev/null
+++ b/network/snmpsim/snmpsim.SlackBuild
@@ -0,0 +1,66 @@
+#!/bin/sh
+
+# Slackware build script for snmpsim.
+
+# Copyright 2011 Ilya Etingof <ilya@glas.net>, Moscow, RU
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+PRGNAM=snmpsim
+VERSION=${VERSION:-0.0.10}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+ARCH=noarch
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Nothing but an egg file here, so we'll wipe it and make this a noarch pack
+rm -r $PKG/usr/lib*
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.txt CHANGES.txt LICENSE.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}