summaryrefslogtreecommitdiffstats
path: root/network/radicale
diff options
context:
space:
mode:
author Johannes Schoepfer2016-07-31 03:11:26 +0200
committer Willy Sudiarto Raharjo2016-08-03 02:27:57 +0200
commit77cb7696b24fbeee3a1c9d1f784e55bc5bf2af50 (patch)
treef46d3899edebaaa8637970171e4232977cfb5718 /network/radicale
parent186154b0c9fd6568dda6366563f763e47fd2b732 (diff)
downloadslackbuilds-77cb7696b24fbeee3a1c9d1f784e55bc5bf2af50.tar.gz
network/radicale: Added (Calendar Server).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/radicale')
-rw-r--r--network/radicale/README7
-rw-r--r--network/radicale/doinst.sh26
-rw-r--r--network/radicale/radicale.SlackBuild103
-rw-r--r--network/radicale/radicale.info10
-rw-r--r--network/radicale/slack-desc19
5 files changed, 165 insertions, 0 deletions
diff --git a/network/radicale/README b/network/radicale/README
new file mode 100644
index 0000000000..a8fe67c703
--- /dev/null
+++ b/network/radicale/README
@@ -0,0 +1,7 @@
+Radicale (Calendar Server)
+
+The Radicale Project is mainly a calendar server, giving local and
+distant accessess for reading, creating, modifying and deleting
+multiple calendars through a simplified CalDAV protocol. Data can be
+encrypted by SSL, and their access can be restricted thanks to
+different authentication methods.
diff --git a/network/radicale/doinst.sh b/network/radicale/doinst.sh
new file mode 100644
index 0000000000..a2a966fe7c
--- /dev/null
+++ b/network/radicale/doinst.sh
@@ -0,0 +1,26 @@
+config() {
+NEW="$1"
+OLD="$(dirname $NEW)/$(basename $NEW .new)"
+# If there's no config file by that name, mv it over:
+if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then # toss the redundant copy
+ rm $NEW
+fi
+# Otherwise, we leave the .new copy for the admin to consider...
+}
+preserve_perms () {
+NEW="$1"
+OLD="$(dirname $NEW)/$(basename $NEW .new)"
+if [ -e $OLD ]; then
+ cp -a $OLD ${NEW}.incoming
+ cat $NEW > ${NEW}.incoming
+ mv ${NEW}.incoming $NEW
+fi
+config $NEW
+}
+
+for i in etc/radicale/config.new etc/radicale/logging.new
+do
+ preserve_perms $i
+done
diff --git a/network/radicale/radicale.SlackBuild b/network/radicale/radicale.SlackBuild
new file mode 100644
index 0000000000..335e16878f
--- /dev/null
+++ b/network/radicale/radicale.SlackBuild
@@ -0,0 +1,103 @@
+#!/bin/sh
+
+# Slackware build script for radicale
+
+# Copyright 2016 Johannes Schoepfer, Herrenberg, BW, Germany
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=radicale
+VERSION=${VERSION:-1.1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf Radicale-$VERSION
+tar vxf $CWD/Radicale-$VERSION.tar.gz
+cd Radicale-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --prefix=/usr --root=$PKG
+install -m0644 -D config $PKG/etc/radicale/config
+install -m0644 logging $PKG/etc/radicale/logging
+install -m0644 -D radicale.wsgi $PKG/var/lib/radicale/radicale.wsgi
+install -m0644 radicale.fcgi $PKG/var/lib/radicale/radicale.fcgi
+
+# docs
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp COPYING README schema.sql config logging $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# logrotate
+mkdir -p $PKG/etc/logrotate.d
+cat << EOF > $PKG/etc/logrotate.d/radicale
+/var/log/radicale {
+ rotate 10
+ notifempty
+ size=1M
+ compress
+ delaycompress
+}
+EOF
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/install
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -p -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/radicale/radicale.info b/network/radicale/radicale.info
new file mode 100644
index 0000000000..49b3f67d89
--- /dev/null
+++ b/network/radicale/radicale.info
@@ -0,0 +1,10 @@
+PRGNAM="radicale"
+VERSION="1.1.1"
+HOMEPAGE="http://www.radicale.org/"
+DOWNLOAD="http://pypi.python.org/packages/source/R/Radicale/Radicale-1.1.1.tar.gz"
+MD5SUM="a29dd538377ea24cec83237a636122ae"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="mod_wsgi"
+MAINTAINER="Johannes Schoepfer"
+EMAIL="<slackbuilds[at]schoepfer[dot]info>"
diff --git a/network/radicale/slack-desc b/network/radicale/slack-desc
new file mode 100644
index 0000000000..5677c34940
--- /dev/null
+++ b/network/radicale/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The \"handy ruler\" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+radicale: Radicale (Calendar Server)
+radicale:
+radicale: The Radicale Project is mainly a calendar server, giving local and
+radicale: distant accessess for reading, creating, modifying and deleting
+radicale: multiple calendars through a simplified CalDAV protocol. Data can be
+radicale: encrypted by SSL, and their access can be restricted thanks to
+radicale: different authentication methods.
+radicale:
+radicale: http://www.radicale.org/
+radicale:
+radicale: