summaryrefslogtreecommitdiffstats
path: root/network/mosh
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2024-03-02 13:44:50 +0100
committer Willy Sudiarto Raharjo2024-03-06 12:11:15 +0100
commitbcd160a60661dcbdfe1a377e4e745350ee3af409 (patch)
tree27a19de89a13350ee8bdab2614fec772b2cacb25 /network/mosh
parent81b4db98e6e8d336ceb40474e151dddfa2bb8fce (diff)
downloadslackbuilds-bcd160a60661dcbdfe1a377e4e745350ee3af409.tar.gz
network/mosh: Fix build with new protobuf3
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/mosh')
-rw-r--r--network/mosh/1282.patch43
-rw-r--r--network/mosh/mosh.SlackBuild6
2 files changed, 48 insertions, 1 deletions
diff --git a/network/mosh/1282.patch b/network/mosh/1282.patch
new file mode 100644
index 0000000000..c8376a2c12
--- /dev/null
+++ b/network/mosh/1282.patch
@@ -0,0 +1,43 @@
+From 8012ca9c8d16f99679c171b36ad02655549ab7ff Mon Sep 17 00:00:00 2001
+From: Alex Chernyakhovsky <alex@achernya.com>
+Date: Sun, 30 Jul 2023 16:19:46 -0400
+Subject: [PATCH] Bump C++ version to C++17
+
+Protobuf versions since 3.6.0 have long had a C++11 dependency; even
+more recent versions have picked up an Abseil dependency bumping that
+to C++14. Since it is now 2023, defaulting to C++17 is reasonable, so
+remove the conditional C++ standards version check that mosh
+previously had and replace it with an unconditional C++17 check.
+
+This means that all future commits can use C++17 features. According
+to https://en.cppreference.com/w/cpp/compiler_support/17 this means
+that minimum effective compiler versions for mosh become:
+
+gcc 7 (May 2017)
+clang 5 (September 2017)
+
+This, in turn, implies that future versions of mosh will no longer be
+available for RHEL/CentOS 7 (June 2014).
+
+Closes: #1267
+---
+ configure.ac | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index ee70c7b86..7f7dc3bc2 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -22,9 +22,9 @@ AS_IF([test x"$PROTOC" = x],
+ # automake 1.12 seems to require this, but automake 1.11 doesn't recognize it
+ m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
+
+-# Protobuf 3.6+ requires C++11.
+-AS_IF([pkg-config --atleast-version 3.6.0 protobuf],
+- [AX_CXX_COMPILE_STDCXX([11])])
++# Protobuf transitively requires at least C++14, get ahead of the
++# curve and require at least C++17.
++AX_CXX_COMPILE_STDCXX([17])
+
+ WARNING_CXXFLAGS=""
+ PICKY_CXXFLAGS=""
diff --git a/network/mosh/mosh.SlackBuild b/network/mosh/mosh.SlackBuild
index a2669bb49d..8127e0ff4d 100644
--- a/network/mosh/mosh.SlackBuild
+++ b/network/mosh/mosh.SlackBuild
@@ -21,7 +21,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mosh
VERSION=${VERSION:-1.4.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -68,6 +68,10 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+# patch to work with newer protobuf3
+patch -p1 < $CWD/1282.patch
+
+autoreconf -vif
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS -fpermissive" \
./configure \