summaryrefslogtreecommitdiffstats
path: root/network/madwifi-tools
diff options
context:
space:
mode:
author hollywoodb2010-05-11 15:01:30 +0200
committer Eric Hameleers2010-05-11 15:01:30 +0200
commit2cc630e38f72150f8427e6b8f2a0080749039ebb (patch)
tree835f88aed617ae3cb306deb0fa5a259a2141b3e5 /network/madwifi-tools
parent338430e9a7aa688c127a699dd0f1de2944d2ce9f (diff)
downloadslackbuilds-2cc630e38f72150f8427e6b8f2a0080749039ebb.tar.gz
network/madwifi-tools: Initial import
Diffstat (limited to 'network/madwifi-tools')
-rw-r--r--network/madwifi-tools/README22
-rw-r--r--network/madwifi-tools/madwifi-tools.SlackBuild61
-rw-r--r--network/madwifi-tools/madwifi-tools.info8
-rw-r--r--network/madwifi-tools/slack-desc.tools6
4 files changed, 97 insertions, 0 deletions
diff --git a/network/madwifi-tools/README b/network/madwifi-tools/README
new file mode 100644
index 0000000000..4405ef0d42
--- /dev/null
+++ b/network/madwifi-tools/README
@@ -0,0 +1,22 @@
+MadWifi - a Linux kernel device driver for Wireless LAN chipsets from Atheros.
+
+NOTE: MadWifi 0.9.2.1 and earlier do NOT compile against kernel 2.6.19 and
+ higher. MadWifi 0.9.3 will address this issue. SlackBuilds for
+ madwifi-tools and madwifi-driver will be updated when 0.9.3 is
+ released.
+
+A wireless card compatibility matrix is available at:
+http://madwifi.org/wiki/Compatibility
+
+This SlackBuild builds the madwifi tools, not the kernel module. You will
+need to use the "madwifi-driver" SlackBuild to build the madwifi module for
+your kernel version.
+
+Requirements for configuring the wireless card:
+ iwconfig -- part of "wireless-tools" package in /n for Slackware 11.0
+ wpa_supplicant -- if you use WPA encryption.
+ -- Available in /testing for Slackware 11.0
+
+NOTE: You can place the SlackBuild and slack-desc.{tools,driver} files
+ in the same directory without conflicts, and then you only have to
+ keep one copy of the madwifi source code around...
diff --git a/network/madwifi-tools/madwifi-tools.SlackBuild b/network/madwifi-tools/madwifi-tools.SlackBuild
new file mode 100644
index 0000000000..7898d91544
--- /dev/null
+++ b/network/madwifi-tools/madwifi-tools.SlackBuild
@@ -0,0 +1,61 @@
+#!/bin/sh
+
+## Slackware build script for madwifi-tools
+
+## Written by hollywoodb (hollywoodb@fastmail.fm)
+## Modified by the SlackBuilds.org project
+
+## Feel free to use, modify, redistribute this script.
+## If you make changes please modify the "Written by"
+## so that I don't recieve emails about a script I
+## did not write. Thanks.
+
+if [ "$(id -u)" != "0" ]; then
+ echo "This script must be run as root!"
+ exit
+fi
+
+NAME=madwifi
+VERSION=0.9.2.1
+ARCHIVE=tar.bz2
+PKG_NAME=madwifi-tools
+
+ARCH=${ARCH:-i486}
+CWD=`pwd`
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$NAME}
+OUTPUT=${OUTPUT:-/tmp}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $NAME-$VERSION
+tar jxvf $CWD/$NAME-$VERSION.$ARCHIVE || exit 1
+cd $NAME-$VERSION || exit 1
+
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+sed -i 's|/usr/local|/usr|g' tools/Makefile
+make tools || exit 1
+make install-tools DESTDIR=$PKG || exit 1
+
+find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+find $PKG | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+
+mkdir -p $PKG/usr/doc/$NAME-$VERSION
+cp -a {COPYRIGHT,INSTALL,README,THANKS} \
+ $PKG/usr/doc/$NAME-$VERSION/
+cp -a {docs/WEP-HOWTO.txt,docs/users-guide.pdf,docs/users-guide.tex} \
+ $PKG/usr/doc/$NAME-$VERSION/
+cat $CWD/$PKG_NAME.SlackBuild > $PKG/usr/doc/$NAME-$VERSION/$NAME.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc.tools > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n -p $OUTPUT/$PKG_NAME-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/network/madwifi-tools/madwifi-tools.info b/network/madwifi-tools/madwifi-tools.info
new file mode 100644
index 0000000000..290329e2c1
--- /dev/null
+++ b/network/madwifi-tools/madwifi-tools.info
@@ -0,0 +1,8 @@
+PRGNAM="madwifi-tools"
+VERSION="0.9.2.1"
+HOMEPAGE="http://madwifi.org/"
+DOWNLOAD="http://dl.sourceforge.net/madwifi/madwifi-0.9.2.1.tar.bz2"
+MD5SUM="bf5509fccd3852e22551826063b1b61e"
+MAINTAINER="hollywoodb"
+EMAIL="hollywoodb@fastmail.fm"
+APPROVED="alien,robw810"
diff --git a/network/madwifi-tools/slack-desc.tools b/network/madwifi-tools/slack-desc.tools
new file mode 100644
index 0000000000..0201f3de60
--- /dev/null
+++ b/network/madwifi-tools/slack-desc.tools
@@ -0,0 +1,6 @@
+ |-----handy-ruler--------------------------------------------------------|
+madwifi-tools: madwifi-tools (tools for the madwifi wireless NIC driver)
+madwifi-tools:
+madwifi-tools: This package includes the madwifi tools for the madwifi driver for
+madwifi-tools: Atheros chipsets. The kernel module itself must be built seperately.
+madwifi-tools: