summaryrefslogtreecommitdiffstats
path: root/network/iptv-analyzer/patches
diff options
context:
space:
mode:
author Mario Preksavec2017-11-24 01:56:19 +0100
committer David Spencer2017-11-24 01:56:19 +0100
commit3df30f21d4a37c14f7373e3ae8652472e1930756 (patch)
tree495826e790df118322b38a3f05b102a59bfe3b7e /network/iptv-analyzer/patches
parentd9af86bf24bd35747c10bd36bf459e7f80c1d772 (diff)
downloadslackbuilds-3df30f21d4a37c14f7373e3ae8652472e1930756.tar.gz
network/iptv-analyzer: Added (IPTV MPEG2 Transport Stream Analyzer).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'network/iptv-analyzer/patches')
-rw-r--r--network/iptv-analyzer/patches/Makefile.am.diff13
-rw-r--r--network/iptv-analyzer/patches/Makefile.in.diff11
-rw-r--r--network/iptv-analyzer/patches/e5d7c0b90cfe3218d67b56e122140456206f6a65.patch41
-rw-r--r--network/iptv-analyzer/patches/kernel-4.4.diff81
4 files changed, 146 insertions, 0 deletions
diff --git a/network/iptv-analyzer/patches/Makefile.am.diff b/network/iptv-analyzer/patches/Makefile.am.diff
new file mode 100644
index 0000000000..8e03aab10e
--- /dev/null
+++ b/network/iptv-analyzer/patches/Makefile.am.diff
@@ -0,0 +1,13 @@
+--- IPTV-Analyzer-0.9.4/Makefile.am.orig 2015-03-04 10:41:03.000000000 +0100
++++ IPTV-Analyzer-0.9.4/Makefile.am 2017-11-05 00:20:05.903209784 +0100
+@@ -21,8 +21,8 @@
+ #xtables-addons.8: FORCE
+ # ${MAKE} -f Makefile.mans all;
+
+-install-exec-hook:
+- depmod -a || :;
++#install-exec-hook:
++# depmod -a || :;
+
+ #config.status: Makefile.iptrules.in
+
diff --git a/network/iptv-analyzer/patches/Makefile.in.diff b/network/iptv-analyzer/patches/Makefile.in.diff
new file mode 100644
index 0000000000..f0c93e492d
--- /dev/null
+++ b/network/iptv-analyzer/patches/Makefile.in.diff
@@ -0,0 +1,11 @@
+--- IPTV-Analyzer-0.9.4/iptables-module/Makefile.in.orig 2015-03-04 10:41:03.000000000 +0100
++++ IPTV-Analyzer-0.9.4/iptables-module/Makefile.in 2017-11-05 03:37:21.671512778 +0100
+@@ -115,7 +115,7 @@
+ exit 2; \
+ fi
+
+-install: lib_install modules_install
++install: lib_install modules
+
+
+ clean:
diff --git a/network/iptv-analyzer/patches/e5d7c0b90cfe3218d67b56e122140456206f6a65.patch b/network/iptv-analyzer/patches/e5d7c0b90cfe3218d67b56e122140456206f6a65.patch
new file mode 100644
index 0000000000..4a84020a1e
--- /dev/null
+++ b/network/iptv-analyzer/patches/e5d7c0b90cfe3218d67b56e122140456206f6a65.patch
@@ -0,0 +1,41 @@
+From e5d7c0b90cfe3218d67b56e122140456206f6a65 Mon Sep 17 00:00:00 2001
+From: Hoai-Thu Vuong <thuvh87@gmail.com>
+Date: Tue, 12 Jan 2016 17:30:45 +0700
+Subject: [PATCH] using echo and tag php in code
+
+---
+ webfrontend/www/design.inc.php | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/webfrontend/www/design.inc.php b/webfrontend/www/design.inc.php
+index 174e04a..9fcd7b0 100644
+--- a/webfrontend/www/design.inc.php
++++ b/webfrontend/www/design.inc.php
+@@ -29,12 +29,12 @@ function doHeader($title="", $options=FALSE) {
+ <meta name="description" content="tvprobe webfrontend" />
+ <meta name="publisher" content="ComX Networks A/S" />
+
+- <link rel="stylesheet" type="text/css" href="<?=$incdir?>css/motorola.css">
++ <link rel="stylesheet" type="text/css" href="<?php echo $incdir; ?>css/motorola.css">
+ <?php
+ if ($include_javascript == TRUE) {
+ ?>
+ <script
+- src="<?=$incdir?>functions.js" type="text/javascript" language='javascript'>
++ src="<?php echo $incdir; ?>functions.js" type="text/javascript" language='javascript'>
+ </script>
+ <?php
+ }
+@@ -44,10 +44,10 @@ function doHeader($title="", $options=FALSE) {
+ ?>
+ <!--Epoch's styles-->
+ <link rel="stylesheet" type="text/css"
+- href="<?=$incdir?>js/epoch_v202_en/epoch_styles.css" />
++ href="<?php echo $incdir; ?>js/epoch_v202_en/epoch_styles.css" />
+
+ <!--Epoch's Code-->
+- <script type="text/javascript" src="<?=$incdir?>js/epoch_v202_en/epoch_classes.js">
++ <script type="text/javascript" src="<?php echo $incdir; ?>js/epoch_v202_en/epoch_classes.js">
+ </script>
+
+ <script type="text/javascript">
diff --git a/network/iptv-analyzer/patches/kernel-4.4.diff b/network/iptv-analyzer/patches/kernel-4.4.diff
new file mode 100644
index 0000000000..471305bd4f
--- /dev/null
+++ b/network/iptv-analyzer/patches/kernel-4.4.diff
@@ -0,0 +1,81 @@
+diff --git a/iptables-module/compat_xtables.c b/iptables-module/compat_xtables.c
+index c5b67a4..40f83c8 100644
+--- a/iptables-module/compat_xtables.c
++++ b/iptables-module/compat_xtables.c
+@@ -464,6 +464,7 @@ struct xt_match *xtnu_request_find_match(unsigned int af, const char *name,
+ }
+ EXPORT_SYMBOL_GPL(xtnu_request_find_match);
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 4, 0)
+ int xtnu_ip_route_me_harder(struct sk_buff **pskb, unsigned int addr_type)
+ {
+ #if LINUX_VERSION_CODE <= KERNEL_VERSION(2, 6, 17)
+@@ -476,6 +477,7 @@ int xtnu_ip_route_me_harder(struct sk_buff **pskb, unsigned int addr_type)
+ #endif
+ }
+ EXPORT_SYMBOL_GPL(xtnu_ip_route_me_harder);
++#endif
+
+ int xtnu_skb_make_writable(struct sk_buff **pskb, unsigned int len)
+ {
+diff --git a/iptables-module/compat_xtnu.h b/iptables-module/compat_xtnu.h
+index 02b6575..253e3df 100644
+--- a/iptables-module/compat_xtnu.h
++++ b/iptables-module/compat_xtnu.h
+@@ -143,7 +143,9 @@ static inline __wsum csum_unfold(__sum16 n)
+ #endif
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 4, 0)
+ extern int xtnu_ip_local_out(struct sk_buff *);
+ extern int xtnu_ip_route_me_harder(struct sk_buff **, unsigned int);
++#endif
+ extern int xtnu_skb_make_writable(struct sk_buff **, unsigned int);
+ extern int xtnu_register_match(struct xtnu_match *);
+ extern int xtnu_ip_route_output_key(void *, struct rtable **, struct flowi *);
+diff --git a/iptables-module/xt_mpeg2ts.c b/iptables-module/xt_mpeg2ts.c
+index 91ae4a0..87cfb17 100644
+--- a/iptables-module/xt_mpeg2ts.c
++++ b/iptables-module/xt_mpeg2ts.c
+@@ -99,7 +99,7 @@ static const struct file_operations dl_file_ops;
+ #endif
+
+ static int debug = -1;
+-static int msg_level;
++static int msg_level = MPEG2TS_MSG_DEFAULT;
+ module_param(debug, int, 0);
+ module_param(msg_level, int, 0664);
+ MODULE_PARM_DESC(debug, "Set low N bits of message level");
+@@ -1299,14 +1299,12 @@ static void mpeg2ts_seq_stop(struct seq_file *s, void *v)
+ static int mpeg2ts_seq_show_real(struct mpeg2ts_stream *stream,
+ struct seq_file *s, unsigned int bucket)
+ {
+- int res;
+-
+ if (!atomic_inc_not_zero(&stream->use)) {
+ /* If "use" is zero, then we about to be free'd */
+ return 0;
+ }
+
+- res = seq_printf(s, "bucket:%d dst:%pI4 src:%pI4 dport:%u sport:%u "
++ seq_printf(s, "bucket:%d dst:%pI4 src:%pI4 dport:%u sport:%u "
+ "pids:%d skips:%llu discontinuity:%llu "
+ "payload_bytes:%llu packets:%llu\n",
+ bucket,
+@@ -1323,7 +1321,7 @@ static int mpeg2ts_seq_show_real(struct mpeg2ts_stream *stream,
+
+ atomic_dec(&stream->use);
+
+- return res;
++ return seq_has_overflowed(s);
+ }
+
+ static int mpeg2ts_seq_show(struct seq_file *s, void *v)
+@@ -1434,7 +1432,7 @@ static int __init mpeg2ts_mt_init(void)
+ */
+ INIT_LIST_HEAD(&conn_htables);
+
+- msg_level = netif_msg_init(debug, MPEG2TS_MSG_DEFAULT);
++ msg_level = netif_msg_init(debug, msg_level);
+ msg_info(DRV, "Loading: %s", version);
+ msg_dbg(DRV, "Message level (msg_level): 0x%X", msg_level);
+