summaryrefslogtreecommitdiffstats
path: root/network/bottle/bottle.SlackBuild
diff options
context:
space:
mode:
author Philip Lacroix2015-09-10 20:48:16 +0200
committer Willy Sudiarto Raharjo2015-09-10 20:48:16 +0200
commit4e7c68052434879912d3eed66ac2e1c4db960df2 (patch)
tree9a4759d171e8acac202bf6cc7cd6501bede8fac3 /network/bottle/bottle.SlackBuild
parentd0add4f89dfca5eed2c2c832b8fb314bd0fb49d6 (diff)
downloadslackbuilds-4e7c68052434879912d3eed66ac2e1c4db960df2.tar.gz
network/bottle: Update EMAIL.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/bottle/bottle.SlackBuild')
-rw-r--r--network/bottle/bottle.SlackBuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/network/bottle/bottle.SlackBuild b/network/bottle/bottle.SlackBuild
index 0597abd297..abe47cf5db 100644
--- a/network/bottle/bottle.SlackBuild
+++ b/network/bottle/bottle.SlackBuild
@@ -1,8 +1,8 @@
#!/bin/sh
-# Slackware build script for Bottle
+# Slackware build script for bottle
-# Copyright 2015 Philip Lacroix <philnx at posteo dot de>
+# Copyright 2015 Philip Lacroix <slackph at posteo dot de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -55,8 +55,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
-o -perm 400 \) -exec chmod 644 {} \;
-PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
-
python setup.py install --root=$PKG
# Python 3 support.
@@ -64,9 +62,12 @@ if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+# Install documentation.
mkdir -p $PRGDOC
cp -a README.rst PKG-INFO $PRGDOC/
cat $CWD/$PRGNAM.SlackBuild > $PRGDOC/$PRGNAM.SlackBuild