summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-01-20 17:39:47 +0100
committer Erik Hanson2014-01-30 06:20:28 +0100
commit2e03105e54b52b93ad9d4d329f30f5853cf4b30c (patch)
treeafc23e27bb4c8e48b1eb735d699e42d207483a55 /multimedia
parent275d1249b6e689c2aa146e936b7b48b35c13e905 (diff)
downloadslackbuilds-2e03105e54b52b93ad9d4d329f30f5853cf4b30c.tar.gz
multimedia/beets: Added (music tagger and library organizer).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/beets/README25
-rw-r--r--multimedia/beets/beets.SlackBuild92
-rw-r--r--multimedia/beets/beets.info10
-rw-r--r--multimedia/beets/slack-desc19
4 files changed, 146 insertions, 0 deletions
diff --git a/multimedia/beets/README b/multimedia/beets/README
new file mode 100644
index 0000000000..2e0f93b951
--- /dev/null
+++ b/multimedia/beets/README
@@ -0,0 +1,25 @@
+Beets is the media library management system for obsessive-compulsive
+music geeks.
+
+The purpose of beets is to get your music collection right once and
+for all. It catalogs your collection, automatically improving its
+metadata as it goes. It then provides a bouquet of tools for
+manipulating and accessing your music.
+
+Because beets is designed as a library, it can do almost anything you
+can imagine for your music collection. Via plugins, beets becomes a
+panacea:
+
+- Fetch or calculate all the metadata you could possibly need: album
+ art, ReplayGain levels, or acoustic fingerprints.
+- Get metadata from MusicBrainz, Discogs, or Beatport. Or guess
+ metadata using songs' filenames or their acoustic fingerprints.
+- Transcode audio to any format you like.
+- Check your library for duplicate tracks and albums or for albums
+ that are missing tracks.
+- Browse your music library graphically through a Web browser and play
+ it in any browser that supports HTML5 Audio.
+- ...and lots more.
+
+If beets doesn't do what you want yet, writing your own plugin is
+shockingly simple if you know a little Python.
diff --git a/multimedia/beets/beets.SlackBuild b/multimedia/beets/beets.SlackBuild
new file mode 100644
index 0000000000..5e393f2178
--- /dev/null
+++ b/multimedia/beets/beets.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for beets
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=beets
+VERSION=${VERSION:-1.3.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+PYTHON=python
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+$PYTHON setup.py install --root=$PKG
+
+# Install man page(s) to correct location:
+install -D -m644 man/beet.1 $PKG/usr/man/man1/beet.1
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.rst PKG-INFO docs/*\
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/multimedia/beets/beets.info b/multimedia/beets/beets.info
new file mode 100644
index 0000000000..d124e925ff
--- /dev/null
+++ b/multimedia/beets/beets.info
@@ -0,0 +1,10 @@
+PRGNAM="beets"
+VERSION="1.3.2"
+HOMEPAGE="http://beets.radbox.org"
+DOWNLOAD="https://pypi.python.org/packages/source/b/beets/beets-1.3.2.tar.gz"
+MD5SUM="3da181fd9a87b302681d9bf9598a0bc6"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="mutagen munkres Unidecode musicbrainzngs PyYAML Flask pyechonest pyacoustid pylast python-requests discogs-client"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/multimedia/beets/slack-desc b/multimedia/beets/slack-desc
new file mode 100644
index 0000000000..2c53b0407a
--- /dev/null
+++ b/multimedia/beets/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+beets: beets (music tagger and library organizer)
+beets:
+beets: Beets is the media library management system for obsessive-compulsive
+beets: music geeks.
+beets:
+beets: homepage: http://beets.radbox.org
+beets:
+beets:
+beets:
+beets:
+beets: