summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2022-01-22 17:57:32 +0100
committer Willy Sudiarto Raharjo2022-01-22 17:57:32 +0100
commit1d0fa2b1b13759a5075f1d4c71c18b2ea436161a (patch)
tree5f4e29da83a01bd175a2a73a24c489c4608a4260 /multimedia
parentc9f97117f76e533abdde495a34327ef4616d9497 (diff)
downloadslackbuilds-1d0fa2b1b13759a5075f1d4c71c18b2ea436161a.tar.gz
multimedia/miro: Removed.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/miro/README5
-rw-r--r--multimedia/miro/doinst.sh14
-rw-r--r--multimedia/miro/miro-gdb-fix.patch21
-rw-r--r--multimedia/miro/miro.SlackBuild120
-rw-r--r--multimedia/miro/miro.info10
-rw-r--r--multimedia/miro/slack-desc19
6 files changed, 0 insertions, 189 deletions
diff --git a/multimedia/miro/README b/multimedia/miro/README
deleted file mode 100644
index 1200f6fddd..0000000000
--- a/multimedia/miro/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Miro is a free Internet television application for the online
-Democracy Network.
-
-Optional dependencies are gst0-ffmpeg, avahi, ffmpeg2theora,
-and gst0-plugins-ugly.
diff --git a/multimedia/miro/doinst.sh b/multimedia/miro/doinst.sh
deleted file mode 100644
index 0fb9c8b686..0000000000
--- a/multimedia/miro/doinst.sh
+++ /dev/null
@@ -1,14 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -x /usr/bin/update-mime-database ]; then
- /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
-
diff --git a/multimedia/miro/miro-gdb-fix.patch b/multimedia/miro/miro-gdb-fix.patch
deleted file mode 100644
index c14e384109..0000000000
--- a/multimedia/miro/miro-gdb-fix.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naur miro-4.0.4.orig/linux/miro miro-4.0.4/linux/miro
---- miro-4.0.4.orig/linux/miro 2011-12-22 14:45:47.000000000 +0000
-+++ miro-4.0.4/linux/miro 2011-12-28 21:26:20.298219802 +0000
-@@ -42,7 +42,7 @@
- then
- MIROREAL=./miro.real
- else
-- MIROREAL=`which gdb`
-+ MIROREAL=`which miro.real`
- fi
-
- echo "using ${MIROREAL}"
-@@ -60,7 +60,7 @@
- fi
-
- $GDB -ex 'set breakpoint pending on' \
-- -ex 'run' --args $PYTHON ./miro.real --sync "$@"
-+ -ex 'run' --args $PYTHON $MIROREAL --sync "$@"
- else
- miro.real "$@"
- fi
diff --git a/multimedia/miro/miro.SlackBuild b/multimedia/miro/miro.SlackBuild
deleted file mode 100644
index a6b5b99d1f..0000000000
--- a/multimedia/miro/miro.SlackBuild
+++ /dev/null
@@ -1,120 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for Miro
-
-# Copyright 2009-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=miro
-VERSION=${VERSION:-6.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-DIRNAME=$(tar -tf $CWD/$PRGNAM-$VERSION.tar.gz | head -1)
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $DIRNAME
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $DIRNAME/tv
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Patch to fix the gdb call from miro.
-patch -p1 < $CWD/miro-gdb-fix.patch
-
-# Fix .destkop item.
-sed -i \
- -e 's|TV;||' -e 's|P2P;News;FileTransfer;||' \
- -e 's|ogg$|ogg;|' linux/miro.desktop
-
-cd linux
- sed -i -e 's|share/man|man|' -e '/miro.test/d' setup.py
- sed -i "s|CODEC_ID_MP3|AV_CODEC_ID_MP3|g" miro-segmenter.c
- sed -i "s|CODEC_ID_AC3|AV_CODEC_ID_AC3|g" miro-segmenter.c
- CFLAGS="$SLKCFLAGS" python setup.py install --root=$PKG
-cd -
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# Remove unneeded files.
-rm -rf $PKG/usr/share/${PRGNAM}/resources/testdata
-if [ "$ARCH" == "x86_64" ]; then
- rm -f $PKG/usr/bin/codegen.Linux-i686
-else
- rm -f $PKG/usr/bin/codegen.Linux-x86_64
-fi
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CREDITS LAYOUT license.txt README $PKG/usr/doc/$PRGNAM-$VERSION
-cat linux/README > $PKG/usr/doc/$PRGNAM-$VERSION/README.linux
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/multimedia/miro/miro.info b/multimedia/miro/miro.info
deleted file mode 100644
index 7e6568723b..0000000000
--- a/multimedia/miro/miro.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="miro"
-VERSION="6.0"
-HOMEPAGE="http://www.getmiro.com/"
-DOWNLOAD="https://github.com/pculture/miro/archive/v6.0/miro-6.0.tar.gz"
-MD5SUM="0e6037687ddc7321a3a89b93743ae141"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="gnome-python gst0-python libtorrent-rasterbar mutagen pywebkitgtk"
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/multimedia/miro/slack-desc b/multimedia/miro/slack-desc
deleted file mode 100644
index 13298f7abb..0000000000
--- a/multimedia/miro/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-miro: miro (Online media aggregator)
-miro:
-miro: Miro is a free Internet television application for the online
-miro: Democracy Network.
-miro:
-miro: Homepage: http://www.getmiro.com/
-miro:
-miro:
-miro:
-miro:
-miro: