summaryrefslogtreecommitdiffstats
path: root/multimedia/gnash/patch/gnash-0.8.10-boost-1.50.patch
diff options
context:
space:
mode:
author Kyle Guinn2013-11-15 01:26:31 +0100
committer Robby Workman2013-11-15 06:00:13 +0100
commita23950a58c6382a243aeb3d0312c971e9014cf72 (patch)
tree6c2c7e4f0bbf8121fcd34db3541b0d2bada20b1c /multimedia/gnash/patch/gnash-0.8.10-boost-1.50.patch
parentb7448da42aca8d402b2332451bd61a55773240d0 (diff)
downloadslackbuilds-a23950a58c6382a243aeb3d0312c971e9014cf72.tar.gz
multimedia/gnash: Fix a linking error
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'multimedia/gnash/patch/gnash-0.8.10-boost-1.50.patch')
-rw-r--r--multimedia/gnash/patch/gnash-0.8.10-boost-1.50.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/multimedia/gnash/patch/gnash-0.8.10-boost-1.50.patch b/multimedia/gnash/patch/gnash-0.8.10-boost-1.50.patch
new file mode 100644
index 0000000000..23282d1e89
--- /dev/null
+++ b/multimedia/gnash/patch/gnash-0.8.10-boost-1.50.patch
@@ -0,0 +1,24 @@
+diff -ur a/macros/boost.m4 b/macros/boost.m4
+--- a/macros/boost.m4 2012-09-03 17:11:43.000000000 +0200
++++ b/macros/boost.m4 2012-10-16 01:58:28.000000000 +0200
+@@ -37,7 +37,7 @@
+ boost_headers="detail/lightweight_mutex.hpp thread/thread.hpp multi_index_container.hpp multi_index/key_extractors.hpp thread/mutex.hpp program_options/options_description.hpp iostreams/stream.hpp"
+ dnl this is a list of *required* libraries. If any of these are missing, this
+ dnl test will return a failure, and Gnash won't build.
+- boost_libs="thread program_options iostreams"
++ boost_libs="thread program_options iostreams system"
+
+ dnl this is a list of *recommended* libraries. If any of these are missing, this
+ dnl test will return a warning, and Gnash will build, but testing won't work.
+diff -ur a/plugin/npapi/Makefile.am b/plugin/npapi/Makefile.am
+--- a/plugin/npapi/Makefile.am 2012-09-03 17:11:43.000000000 +0200
++++ b/plugin/npapi/Makefile.am 2012-10-16 01:58:57.000000000 +0200
+@@ -78,7 +78,7 @@
+
+ libgnashplugin_la_LIBADD = \
+ $(GLIB_LIBS) \
+- -lboost_iostreams \
++ $(BOOST_LIBS) \
+ $(NULL)
+
+ # Scriptable plugin support