summaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
author Dave Woodfall2021-05-06 19:15:03 +0200
committer Willy Sudiarto Raharjo2021-05-07 20:41:56 +0200
commitd33a0b0cdeb396b28ef138d5893ce986564d15ee (patch)
treeb7179e23602e08a87dd014377986e18e4d8318c2 /misc
parent7eabd7dcee25ce0a6efeeaf6e08c89e54a8d07c2 (diff)
downloadslackbuilds-d33a0b0cdeb396b28ef138d5893ce986564d15ee.tar.gz
misc/gourmet: Fix REQUIRES for python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'misc')
-rw-r--r--misc/gourmet/README11
-rw-r--r--misc/gourmet/gourmet.SlackBuild8
-rw-r--r--misc/gourmet/gourmet.info2
3 files changed, 11 insertions, 10 deletions
diff --git a/misc/gourmet/README b/misc/gourmet/README
index 3fb7a02e9a..6d6db521b0 100644
--- a/misc/gourmet/README
+++ b/misc/gourmet/README
@@ -1,8 +1,9 @@
-Gourmet Recipe Manager is a recipe-organizer available for Linux and Windows
-that allows you to collect, search, organize, and browse your recipes.
+Gourmet Recipe Manager is a recipe-organizer available for Linux and
+Windows that allows you to collect, search, organize, and browse your
+recipes.
-Gourmet can also generate shopping lists and calculate nutritional information.
-It imports Mealmaster, MasterCook and KRecipe files and exports PDFs,
-webpages and other formats.
+Gourmet can also generate shopping lists and calculate nutritional
+information. It imports Mealmaster, MasterCook and KRecipe files and
+exports PDFs, webpages and other formats.
Gourmet is free software.
diff --git a/misc/gourmet/gourmet.SlackBuild b/misc/gourmet/gourmet.SlackBuild
index 0121943095..3296d887e6 100644
--- a/misc/gourmet/gourmet.SlackBuild
+++ b/misc/gourmet/gourmet.SlackBuild
@@ -29,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -72,7 +72,7 @@ find -L . \
# Patch to replace removed tostring() with tobytes()
patch -p1 < $CWD/tostring-to-tobytes.patch
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/misc/gourmet/gourmet.info b/misc/gourmet/gourmet.info
index 64f0f25902..3fc74822ab 100644
--- a/misc/gourmet/gourmet.info
+++ b/misc/gourmet/gourmet.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/thinkle/gourmet/archive/0.17.4.tar.gz"
MD5SUM="937334364abc3093709a604c1d473e9f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="SQLAlchemy lxml python-distutils-extra reportlab pygtkspell gst0-python python-elib.intl pypoppler"
+REQUIRES="SQLAlchemy lxml python-distutils-extra reportlab pygtkspell gst0-python python2-elib.intl pypoppler"
MAINTAINER="Erwin van Zanten"
EMAIL="e.van.zanten.evz@gmail.com"