summaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
author Hunter Sezen2019-07-20 04:24:33 +0200
committer Willy Sudiarto Raharjo2019-07-20 04:24:33 +0200
commit12c3455364a6b49e63323c2b52a8680e3f6f5c35 (patch)
treee87f3648143332470d324d152f6281334fd3a6f2 /misc
parent3557fcd162c6ce29c0b9e6e8c21b007b63a7d9d2 (diff)
downloadslackbuilds-12c3455364a6b49e63323c2b52a8680e3f6f5c35.tar.gz
misc/xdelta3: Updated for version 3.1.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'misc')
-rw-r--r--misc/xdelta3/c11.patch39
-rw-r--r--misc/xdelta3/xdelta3.SlackBuild10
-rw-r--r--misc/xdelta3/xdelta3.info6
3 files changed, 49 insertions, 6 deletions
diff --git a/misc/xdelta3/c11.patch b/misc/xdelta3/c11.patch
new file mode 100644
index 0000000000..393e5fac00
--- /dev/null
+++ b/misc/xdelta3/c11.patch
@@ -0,0 +1,39 @@
+From 483bafb4179229714d920de49ba964170c212ef9 Mon Sep 17 00:00:00 2001
+From: Weida Hong <wdhongtw@gmail.com>
+Date: Thu, 29 Mar 2018 18:37:20 +0800
+Subject: [PATCH] Fix assertion related compile failure
+
+static_assert is declared in assert.h and should only be used after c11.
+---
+ xdelta3/Makefile.am | 2 +-
+ xdelta3/xdelta3.h | 1 +
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/xdelta3/Makefile.am b/xdelta3/Makefile.am
+index 2280083..2d41213 100644
+--- a/xdelta3/Makefile.am
++++ b/xdelta3/Makefile.am
+@@ -73,7 +73,7 @@ WFLAGS = -Wall -Wshadow -fno-builtin -Wextra -Wsign-compare \
+ # -Wno-variadic-macros \
+ # -Wno-c++98-compat-pedantic
+
+-C_WFLAGS = $(WFLAGS) -pedantic -std=c99
++C_WFLAGS = $(WFLAGS) -pedantic -std=c11
+ CXX_WFLAGS = $(WFLAGS) -pedantic -std=c++11
+
+ common_CFLAGS = \
+diff --git a/xdelta3/xdelta3.h b/xdelta3/xdelta3.h
+index 0c1ae0d..7d5e230 100644
+--- a/xdelta3/xdelta3.h
++++ b/xdelta3/xdelta3.h
+@@ -32,6 +32,7 @@
+ #include "config.h"
+ #endif
+
++#include <assert.h>
+ #include <errno.h>
+ #include <stdarg.h>
+ #include <stddef.h>
+--
+2.22.0
+
diff --git a/misc/xdelta3/xdelta3.SlackBuild b/misc/xdelta3/xdelta3.SlackBuild
index 5fefaac68a..d62489cc0b 100644
--- a/misc/xdelta3/xdelta3.SlackBuild
+++ b/misc/xdelta3/xdelta3.SlackBuild
@@ -24,8 +24,8 @@
PRGNAM=xdelta3
SRCNAM=${PRGNAM%3}
-VERSION=${VERSION:-3.0.11}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-3.1.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -64,7 +64,7 @@ rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
# dangling symlink
-rm -f ./$PRGNAM/py-compile
+rm -f ./$PRGNAM/install-sh
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -72,6 +72,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Fix assertion related compile failure
+# https://github.com/jmacd/xdelta/pull/241
+patch -p1 < $CWD/c11.patch
+
cd $PRGNAM
autoreconf -fi
diff --git a/misc/xdelta3/xdelta3.info b/misc/xdelta3/xdelta3.info
index 633014d935..6494093898 100644
--- a/misc/xdelta3/xdelta3.info
+++ b/misc/xdelta3/xdelta3.info
@@ -1,8 +1,8 @@
PRGNAM="xdelta3"
-VERSION="3.0.11"
+VERSION="3.1.0"
HOMEPAGE="http://xdelta.org/"
-DOWNLOAD="https://github.com/jmacd/xdelta/archive/v3.0.11/xdelta-3.0.11.tar.gz"
-MD5SUM="6ed23efecea471dfa0ed5c00216fe31e"
+DOWNLOAD="https://github.com/jmacd/xdelta/archive/v3.1.0/xdelta-3.1.0.tar.gz"
+MD5SUM="fa9b598194d82adeaec2f3c30e827dd6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""