summaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
author Andrew Clemons2021-08-22 11:16:50 +0200
committer Willy Sudiarto Raharjo2021-08-25 07:11:35 +0200
commit2db83ba1a808f6ed8980da57a91e96f5caeb91cc (patch)
tree354b6bbc55ccd4cd7f89e9ca67f49b63c02f49c7 /misc
parentf950a678cfd7027bcb7199ece3d849e8929c48ad (diff)
downloadslackbuilds-2db83ba1a808f6ed8980da57a91e96f5caeb91cc.tar.gz
misc/funny-manpages: Updated for version 2.3.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'misc')
-rw-r--r--misc/funny-manpages/funny-manpages.SlackBuild48
-rw-r--r--misc/funny-manpages/funny-manpages.info8
-rw-r--r--misc/funny-manpages/funny-manpages_1.3-5.diff244
3 files changed, 22 insertions, 278 deletions
diff --git a/misc/funny-manpages/funny-manpages.SlackBuild b/misc/funny-manpages/funny-manpages.SlackBuild
index 65e8fb25cc..209cedf7f1 100644
--- a/misc/funny-manpages/funny-manpages.SlackBuild
+++ b/misc/funny-manpages/funny-manpages.SlackBuild
@@ -26,15 +26,13 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=funny-manpages
-VERSION=${VERSION:-1.3.5}
-SRC_VERSION=$( echo $VERSION | cut -d. -f1,2 )
-DEB_VERSION=5
-
-ARCH=noarch
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.3}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
+ARCH=noarch
+
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
@@ -52,45 +50,35 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/${PRGNAM}_$SRC_VERSION.orig.tar.gz
-cd $PRGNAM-$SRC_VERSION.orig
+rm -rf $PRGNAM
+tar xvf $CWD/${PRGNAM}_$VERSION.orig.tar.gz
+cd $PRGNAM
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Patch the manpages to the latest version.
-patch -p1 < $CWD/${PRGNAM}_$SRC_VERSION-$DEB_VERSION.diff
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Create the directories we need
-mkdir -p $PKG/usr/man/man{1,3,6,7}
+make install DESTDIR=$PKG
-for manpage in $(echo *fun); do
- section=$(echo $manpage | awk -F. '{print $2}' | colrm 2 4)
- install -m 0644 $manpage $PKG/usr/man/man$section/$manpage
-done
+mv $PKG/usr/share/man $PKG/usr
+rm -rf $PKG/usr/share
# Move date.1fun over to mansection 6. It is kinda screwing with upstream,
# but right now causes a conflict with the systems date(1)
( cd $PKG/usr/man/man1
- ln -sf grope.1fun egrope.1fun
- ln -sf grope.1fun fgrope.1fun
mv date.1fun ../man6/date.6fun
)
# Add custom noobfarm manpage. Thanks to Matt Hayes.
-install -m 0644 $CWD/noobfarm.7 $PKG/usr/man/man7/noobfarm.7fun
+install -m644 -D $CWD/noobfarm.7 $PKG/usr/man/man7/noobfarm.7fun
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a debian/README.Debian debian/changelog debian/copyright \
+cp -a CHANGELOG LICENSE README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/misc/funny-manpages/funny-manpages.info b/misc/funny-manpages/funny-manpages.info
index 351b73cb35..a36d546ab1 100644
--- a/misc/funny-manpages/funny-manpages.info
+++ b/misc/funny-manpages/funny-manpages.info
@@ -1,8 +1,8 @@
PRGNAM="funny-manpages"
-VERSION="1.3.5"
-HOMEPAGE="http://packages.debian.org/etch/funny-manpages"
-DOWNLOAD="http://ftp.de.debian.org/debian/pool/main/f/funny-manpages/funny-manpages_1.3.orig.tar.gz"
-MD5SUM="bed1deef82218d42fb230a2176a11ed4"
+VERSION="2.3"
+HOMEPAGE="https://github.com/ltworf/funny-manpages"
+DOWNLOAD="https://github.com/ltworf/funny-manpages/releases/download/2.3/funny-manpages_2.3.orig.tar.gz"
+MD5SUM="43ac37d9173da676ca71e4e09591c472"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/misc/funny-manpages/funny-manpages_1.3-5.diff b/misc/funny-manpages/funny-manpages_1.3-5.diff
deleted file mode 100644
index 78e394e2ee..0000000000
--- a/misc/funny-manpages/funny-manpages_1.3-5.diff
+++ /dev/null
@@ -1,244 +0,0 @@
---- funny-manpages-1.3.orig/debian/README.Debian
-+++ funny-manpages-1.3/debian/README.Debian
-@@ -0,0 +1,9 @@
-+funny-manpages for Debian
-+----------------------
-+
-+The sources for funny manpages were collected from various sources.
-+This basically means that the only 'original' thing in .orig.tar.gz is the
-+fact, that there are debian control files and some manpages' contents have
-+bugs fixed in the package.
-+
-+ -- Pawel Wiecek <coven@debian.org>, Fri, 15 Dec 2000 12:13:37 +0100
---- funny-manpages-1.3.orig/debian/changelog
-+++ funny-manpages-1.3/debian/changelog
-@@ -0,0 +1,77 @@
-+funny-manpages (1.3-5) unstable; urgency=low
-+
-+ * Added lintian override to remove reports of missing manpage for woman (as
-+ this is intentional) (closes: #219907)
-+ * Changed Build-Depends to Build-Depends-Indep (as per policy)
-+ * Updated standards version (no changes required)
-+
-+ -- Pawel Wiecek <coven@debian.org> Thu, 12 Feb 2004 14:49:22 +0100
-+
-+funny-manpages (1.3-4) unstable; urgency=low
-+
-+ * Changed description so it's less confusing (closes: #129502)
-+
-+ -- Pawel Wiecek <coven@debian.org> Wed, 23 Jan 2002 13:17:44 +0100
-+
-+funny-manpages (1.3-3) unstable; urgency=low
-+
-+ * Added sumlinks for [ef]grope.1fun.gz (closes: #99528)
-+ * Now compliant with 3.5.5 policy
-+
-+ -- Pawel Wiecek <coven@debian.org> Fri, 8 Jun 2001 09:27:43 +0200
-+
-+funny-manpages (1.3-2) unstable; urgency=low
-+
-+ * Corrected Build-Depends line in debian/control (was missing debhelper
-+ version)
-+
-+ -- Pawel Wiecek <coven@debian.org> Tue, 22 May 2001 12:38:20 +0200
-+
-+funny-manpages (1.3-1) unstable; urgency=low
-+
-+ * Rebuilt source -- all manpages are now in fun subsection (closes: #96463)
-+ * General cleaning (standards version, etc.)
-+
-+ -- Pawel Wiecek <coven@debian.org> Mon, 7 May 2001 10:59:02 +0200
-+
-+funny-manpages (1.2-1) unstable frozen; urgency=low
-+
-+ * Rebuilt source -- added date.1fun, echo.1fun, rm.1fun, strfry.3fun,
-+ xkill.1fun (closes: #28990)
-+ * uubp.1 now in orig source
-+ * should no longer create sex.1 (closes: #52543)
-+ * fixes to party.1 (closes: #52659)
-+ * added woman.6 (closes: #63862)
-+ * updated to newest standards version and moved to debhelper
-+
-+ -- Pawel Wiecek <coven@debian.org> Fri, 15 Dec 2000 12:26:02 +0100
-+
-+funny-manpages (1.1-3) unstable frozen; urgency=low
-+
-+ * Minor fixes in manpages for sex (fixes bugs #45120)
-+ * Changed section for sex from 1 to 6 (fixes #30977, #37897, #45120)
-+ * Updated standards version to 3.0.1
-+
-+ -- Pawel Wiecek <coven@debian.org> Tue, 26 Oct 1999 21:11:51 +0200
-+
-+funny-manpages (1.1-2) unstable frozen; urgency=low
-+
-+ * Changed path in rtfm.1 as suggested by Yann Dirson (fixes bug #25393)
-+ * Updated Standards-Version
-+
-+ -- Pawel Wiecek <coven@debian.org> Sat, 31 Oct 1998 22:13:20 +0100
-+
-+funny-manpages (1.1-1) unstable; urgency=low
-+
-+ * Added uubp(1) which was previously in asr-manpages.
-+ * Removed strfry (conflicted with libc) - this closes bugs #16785 and
-+ #16840.
-+
-+ -- Pawel Wiecek <coven@pwr.wroc.pl> Tue, 23 Dec 1997 00:05:14 +0100
-+
-+funny-manpages (1.0-1) unstable; urgency=low
-+
-+ * Initial Release.
-+
-+ -- Pawel Wiecek <coven@pwr.wroc.pl> Wed, 10 Dec 1997 01:10:17 +0100
-+
---- funny-manpages-1.3.orig/debian/copyright
-+++ funny-manpages-1.3/debian/copyright
-@@ -0,0 +1,32 @@
-+This package was debianized by Pawel Wiecek coven@pwr.wroc.pl on
-+Wed, 10 Dec 1997 01:10:17 +0100.
-+
-+This set of manpages was collected from all over the net. No specific
-+location can be given.
-+
-+Copyright:
-+
-+To the best of my knowledge all of these manpages are free to use and
-+redistribute.
-+
-+The authors are:
-+
-+baby.1fun - unknown, based on man page by Joe Beck <beck@cs.ualberta.ca>
-+celibacy.1fun - unknown
-+condom.1fun - Ken Maupin <maupin@cs.washington.edu>
-+flame.1fun - unknown
-+flog.1fun - unknown
-+gong.1fun - unknown
-+grope.1fun - unknown
-+party.1fun - unknown
-+rescrog.1fun - unknown
-+rtfm.1fun - unknown
-+sex.1fun - unknown
-+tm.1fun - unknown
-+xlart.1fun - James McPherson
-+date.1fun - Glen Overby <overby@sendit.nodak.edu>
-+echo.1fun - unknown
-+rm.1fun - Matthew Farwell <dylan@ibmpcug.co.uk>
-+strfry.3fun - <chuck@druco.att.com>
-+xkill.1fun - Claudio Calvelli <Claudio@edinburgh.ac.uk>
-+uubp.1fun - unknown
---- funny-manpages-1.3.orig/debian/dirs
-+++ funny-manpages-1.3/debian/dirs
-@@ -0,0 +1,2 @@
-+/usr/share/man/man1
-+/usr/share/lintian/overrides
---- funny-manpages-1.3.orig/debian/lintian
-+++ funny-manpages-1.3/debian/lintian
-@@ -0,0 +1 @@
-+funny-manpages: link-to-undocumented-manpage usr/share/man/man6/woman.6fun.gz
---- funny-manpages-1.3.orig/debian/control
-+++ funny-manpages-1.3/debian/control
-@@ -0,0 +1,15 @@
-+Source: funny-manpages
-+Section: doc
-+Priority: optional
-+Maintainer: Pawel Wiecek <coven@debian.org>
-+Build-Depends-Indep: debhelper (>> 3.0.0)
-+Standards-Version: 3.6.1
-+
-+Package: funny-manpages
-+Architecture: all
-+Suggests: asr-manpages (>=1.3-4)
-+Description: more funny manpages
-+ A set of miscellaneous humorous manpages (don't take them too seriously!).
-+ Includes, amongst others, rtfm (1).
-+ Warning! Some of these manpages might be treated offensive.
-+ You've been warned.
---- funny-manpages-1.3.orig/debian/rules
-+++ funny-manpages-1.3/debian/rules
-@@ -0,0 +1,87 @@
-+#!/usr/bin/make -f
-+# Sample debian/rules that uses debhelper.
-+# GNU copyright 1997 to 1999 by Joey Hess.
-+
-+# Uncomment this to turn on verbose mode.
-+#export DH_VERBOSE=1
-+
-+# This is the debhelper compatability version to use.
-+export DH_COMPAT=3
-+
-+configure: configure-stamp
-+configure-stamp:
-+ dh_testdir
-+ # Add here commands to configure the package.
-+
-+
-+ touch configure-stamp
-+
-+build: configure-stamp build-stamp
-+build-stamp:
-+ dh_testdir
-+
-+ # Add here commands to compile the package.
-+# $(MAKE)
-+ #/usr/bin/docbook-to-man debian/funny-manpages.sgml > funny-manpages.1
-+
-+ touch build-stamp
-+
-+clean:
-+ dh_testdir
-+ dh_testroot
-+ rm -f build-stamp configure-stamp
-+
-+ # Add here commands to clean up after the build process.
-+# -$(MAKE) clean
-+
-+ dh_clean
-+
-+install: build
-+ dh_testdir
-+ dh_testroot
-+ dh_clean -k
-+ dh_installdirs
-+
-+ # Add here commands to install the package into debian/tmp.
-+# $(MAKE) install DESTDIR=`pwd`/debian/tmp
-+ ln -s grope.1fun.gz debian/funny-manpages/usr/share/man/man1/egrope.1fun.gz
-+ ln -s grope.1fun.gz debian/funny-manpages/usr/share/man/man1/fgrope.1fun.gz
-+ cp debian/lintian debian/funny-manpages/usr/share/lintian/overrides/$(package)
-+
-+
-+# Build architecture-independent files here.
-+binary-indep: build install
-+# We have nothing to do by default.
-+
-+# Build architecture-dependent files here.
-+binary-arch: build install
-+ dh_testdir
-+ dh_testroot
-+# dh_installdebconf
-+ dh_installdocs
-+# dh_installexamples
-+# dh_installmenu
-+# dh_installemacsen
-+# dh_installpam
-+# dh_installinit
-+# dh_installcron
-+ dh_installmanpages
-+# dh_installinfo
-+ dh_undocumented woman.6fun
-+ dh_installchangelogs
-+# dh_link
-+ dh_strip
-+ dh_compress
-+ dh_fixperms
-+ # You may want to make some executables suid here.
-+# dh_suidregister
-+# dh_makeshlibs
-+ dh_installdeb
-+# dh_perl
-+ dh_shlibdeps
-+ dh_gencontrol
-+ dh_md5sums
-+ dh_builddeb
-+
-+binary: binary-indep binary-arch
-+.PHONY: build clean binary-indep binary-arch binary install configure