summaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
author Howard Pepper2012-12-03 01:58:19 +0100
committer dsomero2012-12-11 22:21:57 +0100
commit2c8780a3ed7cd98824e5fb1ce0193fff3ed5eb46 (patch)
tree5dc8d7c71cab4a14d989cdcc432ade8cc32072b2 /misc
parentd86d2953205c2eb6ec68c7ccbda09d2394f1d5e6 (diff)
downloadslackbuilds-2c8780a3ed7cd98824e5fb1ce0193fff3ed5eb46.tar.gz
ham/xlog: Moved from libraries
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'misc')
-rw-r--r--misc/xlog/README4
-rw-r--r--misc/xlog/doinst.sh8
-rw-r--r--misc/xlog/slack-desc19
-rw-r--r--misc/xlog/xlog.SlackBuild110
-rw-r--r--misc/xlog/xlog.info10
5 files changed, 0 insertions, 151 deletions
diff --git a/misc/xlog/README b/misc/xlog/README
deleted file mode 100644
index 8c0f98bce8..0000000000
--- a/misc/xlog/README
+++ /dev/null
@@ -1,4 +0,0 @@
-xlog (ham radio contact logging program)
-
-Xlog is an easy to use program for logging your ham radio contacts.
-Contacts are saved in a browsable list which can be edited.
diff --git a/misc/xlog/doinst.sh b/misc/xlog/doinst.sh
deleted file mode 100644
index e4e6459838..0000000000
--- a/misc/xlog/doinst.sh
+++ /dev/null
@@ -1,8 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -x /usr/bin/update-mime-database ]; then
- /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
-fi
-
diff --git a/misc/xlog/slack-desc b/misc/xlog/slack-desc
deleted file mode 100644
index 631d9fe9da..0000000000
--- a/misc/xlog/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-xlog: xlog (ham radio contact logging program)
-xlog:
-xlog: Xlog is an easy to use program for logging your ham radio contacts.
-xlog: Contacts are saved in a browsable list which can be edited.
-xlog:
-xlog: Homepage: http://savannah.nongnu.org/projects/Xlog
-xlog:
-xlog:
-xlog:
-xlog:
-xlog:
diff --git a/misc/xlog/xlog.SlackBuild b/misc/xlog/xlog.SlackBuild
deleted file mode 100644
index 1808b39f76..0000000000
--- a/misc/xlog/xlog.SlackBuild
+++ /dev/null
@@ -1,110 +0,0 @@
-#!/bin/sh
-
-# SlackBuild script for hamlib.
-#
-# Copyright 2010 Howard Pepper <h_pepper {at} bellsouth [dot] net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=xlog
-VERSION=2.0.5
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCFILES="AUTHORS COPYING ChangeLog INSTALL NEWS README"
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-# As upstreams INSTALL file mentions, packagers should not run
-# 'update-mime-database' neither 'update-desktop-database' and
-# this should be disabled by default and enabled (if so desired)
-# with --enable-mime-update. But...
-# Make still runs 'update-desktop-database', creating a new
-# index that would overwrite the one on the box receiving the
-# package.
-# This fixes it in the Makefile.in:
-sed "/^@HAVE_DESKTOP_TRUE/s/\(@HAVE_DESKTOP_TRUE@\)/\1@MIMEUPDATE_TRUE@/g" \
- -i data/desktop/Makefile.in
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --mandir=/usr/man
-
-# Fix linking when --libdir=/usr/lib64
-sed -i \
- -e '/RANLIB/s:$(libdir)/\(.*LIBNAME)\):$(libdir)/`basename \1`:g' \
- src/Makefile || exit
-
-make
-make install DESTDIR=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/
-cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/misc/xlog/xlog.info b/misc/xlog/xlog.info
deleted file mode 100644
index d0643d75bc..0000000000
--- a/misc/xlog/xlog.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="xlog"
-VERSION="2.0.5"
-HOMEPAGE="http://savannah.nongnu.org/projects/Xlog"
-DOWNLOAD="http://download.savannah.gnu.org/releases/xlog/xlog-2.0.5.tar.gz"
-MD5SUM="dbdf0f29d5039165799ba0a8e53209be"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="hamlib"
-MAINTAINER="Howard Pepper"
-EMAIL="h_pepper <at> bellsouth {dot} net"