summaryrefslogtreecommitdiffstats
path: root/misc/chm2pdf
diff options
context:
space:
mode:
author João Felipe Santos2010-05-12 23:31:35 +0200
committer Robby Workman2010-05-12 23:31:35 +0200
commit0a7277747bad59882d879d0630d3feb95265d4a5 (patch)
tree89db42ea07674e38252227783b95bf7de5f19b33 /misc/chm2pdf
parentab2950f6c05b8b0ccb70ae615489bbe7b4432d02 (diff)
downloadslackbuilds-0a7277747bad59882d879d0630d3feb95265d4a5.tar.gz
misc/chm2pdf: Added to 12.2 repository
Diffstat (limited to 'misc/chm2pdf')
-rw-r--r--misc/chm2pdf/README4
-rw-r--r--misc/chm2pdf/chm2pdf.SlackBuild71
-rw-r--r--misc/chm2pdf/chm2pdf.info8
-rw-r--r--misc/chm2pdf/slack-desc19
4 files changed, 102 insertions, 0 deletions
diff --git a/misc/chm2pdf/README b/misc/chm2pdf/README
new file mode 100644
index 0000000000..524e42cb27
--- /dev/null
+++ b/misc/chm2pdf/README
@@ -0,0 +1,4 @@
+chm2pdf is a simple Python script that converts CHM files into
+PDF files.
+
+It requires chmlib, pychm and htmldoc, all available at SlackBuilds.org.
diff --git a/misc/chm2pdf/chm2pdf.SlackBuild b/misc/chm2pdf/chm2pdf.SlackBuild
new file mode 100644
index 0000000000..9411605ee0
--- /dev/null
+++ b/misc/chm2pdf/chm2pdf.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for chm2pdf
+
+# Written by João Felipe Santos (joao.eel@gmail.com)
+
+# Copyright (c) 2009 João Felipe Santos
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+# THE SOFTWARE.
+
+PRGNAM=chm2pdf
+VERSION=${VERSION:-0.9.1}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py build
+python setup.py install --root $PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/misc/chm2pdf/chm2pdf.info b/misc/chm2pdf/chm2pdf.info
new file mode 100644
index 0000000000..fc0f0bc5a0
--- /dev/null
+++ b/misc/chm2pdf/chm2pdf.info
@@ -0,0 +1,8 @@
+PRGNAM="chm2pdf"
+VERSION="0.9.1"
+HOMEPAGE="http://code.google.com/p/chm2pdf"
+DOWNLOAD="http://chm2pdf.googlecode.com/files/chm2pdf-0.9.1.tar.gz"
+MD5SUM="2d5518e3284cca496270566c2554b713"
+MAINTAINER="João Felipe Santos"
+EMAIL="joao.eel[at]gmail.com"
+APPROVED="rworkman"
diff --git a/misc/chm2pdf/slack-desc b/misc/chm2pdf/slack-desc
new file mode 100644
index 0000000000..3546096a51
--- /dev/null
+++ b/misc/chm2pdf/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+chm2pdf: chm2pdf (CHM to PDF converter)
+chm2pdf:
+chm2pdf: chm2pdf is a simple Python script that converts CHM files into PDF
+chm2pdf: files.
+chm2pdf:
+chm2pdf: Homepage: http://code.google.com/p/chm2pdf
+chm2pdf:
+chm2pdf:
+chm2pdf:
+chm2pdf:
+chm2pdf: