summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Evandro Alves Rodrigues2010-08-03 09:33:41 +0200
committer Erik Hanson2010-08-11 08:53:00 +0200
commite389e347dbf9aa4997ac87a1c2c95d41b7b525d0 (patch)
treeb0b3544f8d1b7fcb51c1f1297513e7469e11e5af /libraries
parent0753bf962e4eeb3b33525a3dd62df9068cc846e1 (diff)
downloadslackbuilds-e389e347dbf9aa4997ac87a1c2c95d41b7b525d0.tar.gz
libraries/PyOpenGL: Added (Python binding to OpenGL)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/PyOpenGL/PyOpenGL.SlackBuild57
-rw-r--r--libraries/PyOpenGL/PyOpenGL.info10
-rw-r--r--libraries/PyOpenGL/README10
-rw-r--r--libraries/PyOpenGL/slack-desc19
4 files changed, 96 insertions, 0 deletions
diff --git a/libraries/PyOpenGL/PyOpenGL.SlackBuild b/libraries/PyOpenGL/PyOpenGL.SlackBuild
new file mode 100644
index 0000000000..41a199268e
--- /dev/null
+++ b/libraries/PyOpenGL/PyOpenGL.SlackBuild
@@ -0,0 +1,57 @@
+#!/bin/sh
+
+# Slackware build script for PyOpenGL
+# Written by Evandro Alves Rodrigues
+
+PRGNAM=PyOpenGL
+VERSION=${VERSION:-3.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "x86_64" ]; then
+ LIBDIRSUFFIX="64"
+else
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ ChangeLog.txt PKG-INFO license.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/PyOpenGL/PyOpenGL.info b/libraries/PyOpenGL/PyOpenGL.info
new file mode 100644
index 0000000000..a95c1aad2a
--- /dev/null
+++ b/libraries/PyOpenGL/PyOpenGL.info
@@ -0,0 +1,10 @@
+PRGNAM="PyOpenGL"
+VERSION="3.0.1"
+HOMEPAGE="http://pyopengl.sourceforge.net/"
+DOWNLOAD="http://sourceforge.net/projects/pyopengl/files/PyOpenGL/3.0.1/PyOpenGL-3.0.1.tar.gz/download"
+MD5SUM="cdf03284f24279b8d9914bb680a37b5e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Evandro Alves Rodrigues"
+EMAIL="evandrofisico@gmail.com"
+APPROVED="rworkman"
diff --git a/libraries/PyOpenGL/README b/libraries/PyOpenGL/README
new file mode 100644
index 0000000000..1fa6273a21
--- /dev/null
+++ b/libraries/PyOpenGL/README
@@ -0,0 +1,10 @@
+PyOpenGL is the cross platform Python binding to OpenGL and related APIs.
+The binding is created using the standard (in Python 2.5 and above) ctypes
+library and is provided under a BSD-style Open-Source license.
+
+PyOpenGL includes support for OpenGL v1.1 through 3.2, GLU, GLUT v3.7 (and
+FreeGLUT), and GLE 3. It also has support for hundreds of OpenGL extensions.
+
+PyOpenGL is interoperable with a large number of external GUI libraries for
+Python including wxPython, Pygame, PyGTK, and Qt. It can also use the GLUT
+library to provide basic windowing and user interface mechanisms.
diff --git a/libraries/PyOpenGL/slack-desc b/libraries/PyOpenGL/slack-desc
new file mode 100644
index 0000000000..ddbcea1cc4
--- /dev/null
+++ b/libraries/PyOpenGL/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+PyOpenGL: PyOpenGL (Python binding to OpenGL)
+PyOpenGL:
+PyOpenGL: PyOpenGL is the cross platform Python binding to OpenGL and related
+PyOpenGL: APIs. The binding is created using the standard (in Python 2.5 and
+PyOpenGL: above) ctypes library, and is provided under an extremely liberal
+PyOpenGL: BSD-style Open-Source license.
+PyOpenGL:
+PyOpenGL:
+PyOpenGL:
+PyOpenGL:
+PyOpenGL: