summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Mikko Värri2010-08-14 22:36:01 +0200
committer Erik Hanson2010-08-15 02:04:52 +0200
commitd970547cd90e3d7b5f0e2f05406893dbd82cbcf7 (patch)
treea6693ed3aa544edf417da895037ca1351ea17fc9 /libraries
parent77120800238e0fe84df22cfbae1714b9bd0b3cb9 (diff)
downloadslackbuilds-d970547cd90e3d7b5f0e2f05406893dbd82cbcf7.tar.gz
libraries/zope.location: Added (Zope Location)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/zope.location/README9
-rw-r--r--libraries/zope.location/slack-desc19
-rw-r--r--libraries/zope.location/zope.location.SlackBuild51
-rw-r--r--libraries/zope.location/zope.location.info10
4 files changed, 89 insertions, 0 deletions
diff --git a/libraries/zope.location/README b/libraries/zope.location/README
new file mode 100644
index 0000000000..3ef0d5f526
--- /dev/null
+++ b/libraries/zope.location/README
@@ -0,0 +1,9 @@
+zope.location (Zope Location)
+
+In Zope3, location are special objects that has a structural
+location.
+
+This requires zope.interface, zope.schema, zope.proxy and
+zope.component.
+
+To build, this requires pysetuptools.
diff --git a/libraries/zope.location/slack-desc b/libraries/zope.location/slack-desc
new file mode 100644
index 0000000000..70ac39560a
--- /dev/null
+++ b/libraries/zope.location/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+zope.location: zope.location (Zope Location)
+zope.location:
+zope.location: In Zope3, location are special objects that has a structural
+zope.location: location.
+zope.location:
+zope.location:
+zope.location:
+zope.location:
+zope.location:
+zope.location:
+zope.location:
diff --git a/libraries/zope.location/zope.location.SlackBuild b/libraries/zope.location/zope.location.SlackBuild
new file mode 100644
index 0000000000..dbafe3d59e
--- /dev/null
+++ b/libraries/zope.location/zope.location.SlackBuild
@@ -0,0 +1,51 @@
+#!/bin/sh
+
+# Slackware build script for zope.location
+
+# Written by Mikko Värri (vmj@linuxbox.fi)
+# Public domain.
+
+PRGNAM=zope.location
+VERSION=${VERSION:-3.9.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.txt README.txt PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/zope.location/zope.location.info b/libraries/zope.location/zope.location.info
new file mode 100644
index 0000000000..aecb9278f5
--- /dev/null
+++ b/libraries/zope.location/zope.location.info
@@ -0,0 +1,10 @@
+PRGNAM="zope.location"
+VERSION="3.9.0"
+HOMEPAGE="http://pypi.python.org/pypi/zope.location"
+DOWNLOAD="http://pypi.python.org/packages/source/z/zope.location/zope.location-3.9.0.zip"
+MD5SUM="d4546ea3baf40c0ee6e217c39b351824"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Mikko Värri"
+EMAIL="vmj@linuxbox.fi"
+APPROVED="Erik Hanson"