summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Mikko Värri2010-08-14 22:28:44 +0200
committer Erik Hanson2010-08-15 02:04:52 +0200
commitb9ddaf080a23fdc7a3b8c834f19d8a40ae1059d4 (patch)
tree3a2a5ce7dc58c560d13a97c6f70466fdc41be19b /libraries
parent8fd56589b5eb6a7ea2f4019591db2d552062f690 (diff)
downloadslackbuilds-b9ddaf080a23fdc7a3b8c834f19d8a40ae1059d4.tar.gz
libraries/zope.i18nmessageid: Added (Message Identifiers for internationalization)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/zope.i18nmessageid/README7
-rw-r--r--libraries/zope.i18nmessageid/slack-desc19
-rw-r--r--libraries/zope.i18nmessageid/zope.i18nmessageid.SlackBuild54
-rw-r--r--libraries/zope.i18nmessageid/zope.i18nmessageid.info10
4 files changed, 90 insertions, 0 deletions
diff --git a/libraries/zope.i18nmessageid/README b/libraries/zope.i18nmessageid/README
new file mode 100644
index 0000000000..abffbb433a
--- /dev/null
+++ b/libraries/zope.i18nmessageid/README
@@ -0,0 +1,7 @@
+zope.i18nmessageid (Message Identifiers for internationalization)
+
+This package provides facilities for declaring messages, which are
+unicode strings which carry a translation source domain and possibly
+a default translation, within program source text.
+
+To build, this requires pysetuptools.
diff --git a/libraries/zope.i18nmessageid/slack-desc b/libraries/zope.i18nmessageid/slack-desc
new file mode 100644
index 0000000000..bdf25ecd44
--- /dev/null
+++ b/libraries/zope.i18nmessageid/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+zope.i18nmessageid: zope.i18nmessageid (Message Identifiers for internationalization)
+zope.i18nmessageid:
+zope.i18nmessageid: This package provides facilities for declaring messages, which are
+zope.i18nmessageid: unicode strings which carry a translation source domain and possibly
+zope.i18nmessageid: a default translation, within program source text.
+zope.i18nmessageid:
+zope.i18nmessageid:
+zope.i18nmessageid:
+zope.i18nmessageid:
+zope.i18nmessageid:
+zope.i18nmessageid:
diff --git a/libraries/zope.i18nmessageid/zope.i18nmessageid.SlackBuild b/libraries/zope.i18nmessageid/zope.i18nmessageid.SlackBuild
new file mode 100644
index 0000000000..62e42020b5
--- /dev/null
+++ b/libraries/zope.i18nmessageid/zope.i18nmessageid.SlackBuild
@@ -0,0 +1,54 @@
+#!/bin/sh
+
+# Slackware build script for zope.i18nmessageid
+
+# Written by Mikko Värri (vmj@linuxbox.fi)
+# Public domain.
+
+PRGNAM=zope.i18nmessageid
+VERSION=${VERSION:-3.5.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.txt COPYRIGHT.txt LICENSE.txt README.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/zope.i18nmessageid/zope.i18nmessageid.info b/libraries/zope.i18nmessageid/zope.i18nmessageid.info
new file mode 100644
index 0000000000..cbea940d59
--- /dev/null
+++ b/libraries/zope.i18nmessageid/zope.i18nmessageid.info
@@ -0,0 +1,10 @@
+PRGNAM="zope.i18nmessageid"
+VERSION="3.5.3"
+HOMEPAGE="http://pypi.python.org/pypi/zope.i18nmessageid"
+DOWNLOAD="http://pypi.python.org/packages/source/z/zope.i18nmessageid/zope.i18nmessageid-3.5.3.tar.gz"
+MD5SUM="cb84bf61c2b7353e3b7578057fbaa264"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Mikko Värri"
+EMAIL="vmj@linuxbox.fi"
+APPROVED="Erik Hanson"