summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2014-02-02 00:43:32 +0100
committer Robby Workman2014-02-02 09:09:50 +0100
commit67d814690931dadc6cc8fa69eb3a688674d38c35 (patch)
tree8231d5ec93f43b1eb0811b9447ea73bf06c00796 /libraries
parent3e6b03c740ba59020bed017da5fbc522a413f2b3 (diff)
downloadslackbuilds-67d814690931dadc6cc8fa69eb3a688674d38c35.tar.gz
gis/SFCGAL: Moved from Libraries category.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/SFCGAL/README4
-rw-r--r--libraries/SFCGAL/SFCGAL.SlackBuild107
-rw-r--r--libraries/SFCGAL/SFCGAL.info10
-rw-r--r--libraries/SFCGAL/slack-desc19
4 files changed, 0 insertions, 140 deletions
diff --git a/libraries/SFCGAL/README b/libraries/SFCGAL/README
deleted file mode 100644
index 8826780db4..0000000000
--- a/libraries/SFCGAL/README
+++ /dev/null
@@ -1,4 +0,0 @@
-SFCGAL is a C++ wrapper library around CGAL, written with the aim of supporting
-ISO 19107:2013 and OGC Simple Features Access 1.2 for 3D operations.
-
-OpenSceneGraph is an optional dependency.
diff --git a/libraries/SFCGAL/SFCGAL.SlackBuild b/libraries/SFCGAL/SFCGAL.SlackBuild
deleted file mode 100644
index 466c6aa0de..0000000000
--- a/libraries/SFCGAL/SFCGAL.SlackBuild
+++ /dev/null
@@ -1,107 +0,0 @@
-#!/bin/sh
-
-# SlackBuild script for SFCGAL
-
-# Copyright 2013 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions are
-# met:
-#
-# * Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=SFCGAL
-VERSION=${VERSION:-1.0.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-rm -rf $TMP/$PRGNAM-$VERSION
-cd $TMP
-if [ -e $CWD/v$VERSION.tar.gz ]; then
- tar xvf $CWD/v$VERSION.tar.gz
-else
- tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-fi
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-WITH_DOC=${WITH_DOC:-NO}
-
-# respect LIBDIRSUFFIX
-sed -i "s|/lib|/lib$LIBDIRSUFFIX|" sfcgal-config.in CMakeLists.txt
-sed -i "s|\ lib$| lib$LIBDIRSUFFIX|" src/CMakeLists.txt
-
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- ..
-
- make VERBOSE=1
- make install VERBOSE=1 DESTDIR=$PKG
-cd ..
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS LICENSE NEWS README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/SFCGAL/SFCGAL.info b/libraries/SFCGAL/SFCGAL.info
deleted file mode 100644
index 1452bddd05..0000000000
--- a/libraries/SFCGAL/SFCGAL.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="SFCGAL"
-VERSION="1.0.4"
-HOMEPAGE="http://www.sfcgal.org"
-DOWNLOAD="https://github.com/Oslandia/SFCGAL/archive/v1.0.4.tar.gz"
-MD5SUM="ddc466fd2f38ab2bea70d35665ac95df"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="CGAL"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/libraries/SFCGAL/slack-desc b/libraries/SFCGAL/slack-desc
deleted file mode 100644
index 6d285edd38..0000000000
--- a/libraries/SFCGAL/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-SFCGAL: SFCGAL (C++ wrapper around CGAL)
-SFCGAL:
-SFCGAL: SFCGAL is a C++ wrapper library around CGAL, written with the aim of
-SFCGAL: supporting ISO 19107:2013 and OGC Simple Features Access 1.2 for 3D
-SFCGAL: operations.
-SFCGAL:
-SFCGAL:
-SFCGAL:
-SFCGAL: homepage: http://www.sfcgal.org
-SFCGAL:
-SFCGAL: