summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-02-07 08:01:10 +0100
committer Erik Hanson2014-02-08 18:10:12 +0100
commit63b2827619263f39435fca867df796181d5b886b (patch)
tree72ece68ce37824db4e8cc178992e93ce09348a04 /libraries
parent91d599542bc41aafa03b9a2fd54196a3321406ea (diff)
downloadslackbuilds-63b2827619263f39435fca867df796181d5b886b.tar.gz
libraries/facebook-python: Added (Client library for Facebook SDK).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/facebook-python/README5
-rw-r--r--libraries/facebook-python/facebook-python.SlackBuild90
-rw-r--r--libraries/facebook-python/facebook-python.info11
-rw-r--r--libraries/facebook-python/slack-desc19
4 files changed, 125 insertions, 0 deletions
diff --git a/libraries/facebook-python/README b/libraries/facebook-python/README
new file mode 100644
index 0000000000..e0b73b3932
--- /dev/null
+++ b/libraries/facebook-python/README
@@ -0,0 +1,5 @@
+This client library is designed to support the Facebook Graph API and the
+official Facebook JavaScript SDK, which is the canonical way to implement
+Facebook authentication. You can read more about the Graph API by accessing its
+official documentation.
+
diff --git a/libraries/facebook-python/facebook-python.SlackBuild b/libraries/facebook-python/facebook-python.SlackBuild
new file mode 100644
index 0000000000..95a37478e5
--- /dev/null
+++ b/libraries/facebook-python/facebook-python.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for facebook-python
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=facebook-python
+SCRNAM=facebook-sdk
+VERSION=${VERSION:-0.4.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SCRNAM-$VERSION
+tar xvf $CWD/$SCRNAM-$VERSION.tar.gz
+cd $SCRNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/facebook-python/facebook-python.info b/libraries/facebook-python/facebook-python.info
new file mode 100644
index 0000000000..f3c41164e8
--- /dev/null
+++ b/libraries/facebook-python/facebook-python.info
@@ -0,0 +1,11 @@
+PRGNAM="facebook-python"
+VERSION="0.4.0"
+HOMEPAGE="https://github.com/pythonforfacebook/facebook-sdk"
+DOWNLOAD="https://pypi.python.org/packages/source/f/facebook-sdk/facebook-sdk-0.4.0.tar.gz"
+MD5SUM="ac9f38e197e54b8ba9f3a61988cc33b7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
+
diff --git a/libraries/facebook-python/slack-desc b/libraries/facebook-python/slack-desc
new file mode 100644
index 0000000000..b0eca85eb0
--- /dev/null
+++ b/libraries/facebook-python/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+facebook-python: facebook-python (Client library for Facebook SDK)
+facebook-python:
+facebook-python: This client library is designed to support the Facebook Graph
+facebook-python: PI and the official Facebook JavaScript SDK, which is the
+facebook-python: canonical way to implement Facebook authentication.
+facebook-python:
+facebook-python: Homepage: https://github.com/pythonforfacebook/facebook-sdk
+facebook-python:
+facebook-python:
+facebook-python:
+facebook-python: