summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-02-08 06:00:48 +0100
committer Erik Hanson2014-02-08 18:10:12 +0100
commit3e03a575d0ca3433459458660e6d2593a2515b61 (patch)
treeafc9a013726051af0eeae94b8ce9a7c45c3b474a /libraries
parent5bec9ee83ecc012f4bbc35c84e9d66d1cf9445b4 (diff)
downloadslackbuilds-3e03a575d0ca3433459458660e6d2593a2515b61.tar.gz
libraries/GitPython: Added (Python Git Library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/GitPython/GitPython.SlackBuild86
-rw-r--r--libraries/GitPython/GitPython.info10
-rw-r--r--libraries/GitPython/README2
-rw-r--r--libraries/GitPython/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/libraries/GitPython/GitPython.SlackBuild b/libraries/GitPython/GitPython.SlackBuild
new file mode 100644
index 0000000000..d41a9196bc
--- /dev/null
+++ b/libraries/GitPython/GitPython.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for GitPython
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=GitPython
+VERSION=${VERSION:-0.3.2_RC1}
+SRCVERSION=$(echo $VERSION | tr _ .)
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$SRCVERSION
+tar xvf $CWD/$PRGNAM-$SRCVERSION.tar.gz
+cd $PRGNAM-$SRCVERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGES LICENSE PKG-INFO VERSION $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/GitPython/GitPython.info b/libraries/GitPython/GitPython.info
new file mode 100644
index 0000000000..5c6e2b2c6d
--- /dev/null
+++ b/libraries/GitPython/GitPython.info
@@ -0,0 +1,10 @@
+PRGNAM="GitPython"
+VERSION="0.3.2_RC1"
+HOMEPAGE="https://github.com/gitpython-developers/GitPython"
+DOWNLOAD="https://pypi.python.org/packages/source/G/GitPython/GitPython-0.3.2.RC1.tar.gz"
+MD5SUM="849082fe29adc653a3621465213cab96"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="mock gitdb"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/GitPython/README b/libraries/GitPython/README
new file mode 100644
index 0000000000..effb9088b0
--- /dev/null
+++ b/libraries/GitPython/README
@@ -0,0 +1,2 @@
+GitPython is a python library used to interact with git repositories,
+high-level like git-porcelain, or low-level like git-plumbing.
diff --git a/libraries/GitPython/slack-desc b/libraries/GitPython/slack-desc
new file mode 100644
index 0000000000..071a40df6f
--- /dev/null
+++ b/libraries/GitPython/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+GitPython: GitPython (Python Git Library)
+GitPython:
+GitPython: GitPython is a python library used to interact with Git repositories.
+GitPython: GitPython provides object model read and write access to your git
+GitPython: repository. Access repository information conveniently, alter the
+GitPython: index directly, handle remotes, or go down to low-level object
+GitPython: database access with big-files support.
+GitPython:
+GitPython: Homepage: https://github.com/gitpython-developers/GitPython
+GitPython:
+GitPython: