summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Heinz Wiesinger2010-05-11 20:30:37 +0200
committer Heinz Wiesinger2010-05-11 20:30:37 +0200
commit441c0ece45f0757fdabf977edeb3055d1b52b571 (patch)
tree975767b90dfd70966a7bb9493e89b8007127bcb5 /libraries
parent44fb51ac9874d01746b3ff825f52155993132269 (diff)
downloadslackbuilds-441c0ece45f0757fdabf977edeb3055d1b52b571.tar.gz
libraries/Pyrex: Removed from 12.1 repository
Diffstat (limited to 'libraries')
-rw-r--r--libraries/Pyrex/Pyrex.SlackBuild88
-rw-r--r--libraries/Pyrex/Pyrex.info8
-rw-r--r--libraries/Pyrex/README5
-rw-r--r--libraries/Pyrex/slack-desc19
4 files changed, 0 insertions, 120 deletions
diff --git a/libraries/Pyrex/Pyrex.SlackBuild b/libraries/Pyrex/Pyrex.SlackBuild
deleted file mode 100644
index ce5687c7a5..0000000000
--- a/libraries/Pyrex/Pyrex.SlackBuild
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/sh
-# Slackware build script for Pyrex
-
-# Copyright 2007 David Somero <dsomero@hotmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=Pyrex
-VERSION=0.9.6.2
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "${ARCH}" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-
-cd $PRGNAM-$VERSION
-chown -R root:root .
-chmod -R a-s,u+w,go+r-w .
-
-python setup.py install --root=$PKG
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
-
-if [ -d $PKG/usr/man ]; then
- ( cd $PKG/usr/man
- find . -type f -exec gzip -9 \;
- for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
- )
-fi
-
-if [ -d $PKG/usr/info ]; then
- ( cd $PKG/usr/info
- rm -f dir
- gzip -9 *.info*
- )
-fi
-
-# If there are docs, move them:
-if [ -d $PKG/usr/share/doc ]; then
- mkdir -p $PKG/usr/doc/
- mv $PKG/usr/share/doc/* $PKG/usr/doc
- rmdir $PKG/usr/share/doc
-fi
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README* INSTALL* USAGE* ToDo* $CWD/*.SlackBuild \
- $PKG/usr/doc/$PRGNAM-$VERSION
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/Pyrex/Pyrex.info b/libraries/Pyrex/Pyrex.info
deleted file mode 100644
index bf8f05bea5..0000000000
--- a/libraries/Pyrex/Pyrex.info
+++ /dev/null
@@ -1,8 +0,0 @@
-PRGNAM="Pyrex"
-VERSION="0.9.6.2"
-HOMEPAGE="http://www.cosc.canterbury.ac.nz/greg.ewing/python/Pyrex/"
-DOWNLOAD="http://www.cosc.canterbury.ac.nz/greg.ewing/python/Pyrex/oldtar/Pyrex-0.9.6.2.tar.gz"
-MD5SUM="58c1c56fd4e27decd11b4e5f53eb6511"
-MAINTAINER="David Somero"
-EMAIL="dsomero@hotmail.com"
-APPROVED="rworkman"
diff --git a/libraries/Pyrex/README b/libraries/Pyrex/README
deleted file mode 100644
index 5ad870d7d8..0000000000
--- a/libraries/Pyrex/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Pyrex is a language specially designed for writing Python extension modules.
-It's designed to bridge the gap between the nice, high-level, easy-to-use
-world of Python and the messy, low-level world of C. Pyrex lets you write
-code that mixes Python and C data types any way you want, and compiles it
-into a C extension for Python. \ No newline at end of file
diff --git a/libraries/Pyrex/slack-desc b/libraries/Pyrex/slack-desc
deleted file mode 100644
index fd5290052c..0000000000
--- a/libraries/Pyrex/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-Pyrex: Pyrex (Python C extension library)
-Pyrex:
-Pyrex: Pyrex lets you write code that mixes Python and C data types any
-Pyrex: way you want, and compiles it into a C extension for Python.
-Pyrex:
-Pyrex:
-Pyrex:
-Pyrex:
-Pyrex:
-Pyrex:
-Pyrex: