summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Alexander Verbovetsky2019-11-01 19:02:15 +0100
committer Willy Sudiarto Raharjo2019-11-01 19:02:15 +0100
commitfcbcf721767ffdd1481b0ea1fc9161be7b788d65 (patch)
tree158191eae3b1108dc62936945400141ab71548e4 /libraries
parent75af4c0d656103c9c1707bf263e6c68c229c61b4 (diff)
downloadslackbuilds-fcbcf721767ffdd1481b0ea1fc9161be7b788d65.tar.gz
libraries/python-ruamel.yaml: Added (YAML 1.2 parser and emitter).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/python-ruamel.yaml/README15
-rw-r--r--libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild72
-rw-r--r--libraries/python-ruamel.yaml/python-ruamel.yaml.info10
-rw-r--r--libraries/python-ruamel.yaml/slack-desc19
4 files changed, 116 insertions, 0 deletions
diff --git a/libraries/python-ruamel.yaml/README b/libraries/python-ruamel.yaml/README
new file mode 100644
index 0000000000..28dd43dc00
--- /dev/null
+++ b/libraries/python-ruamel.yaml/README
@@ -0,0 +1,15 @@
+YAML is a human friendly data serialization standard for all programming
+languages. It is commonly used for configuration files, logs, etc.
+
+ruamel.yaml is a YAML 1.2 loader/dumper package for Python. It is a
+derivative of Kirill Simonov’s PyYAML 3.11.
+
+ruamel.yaml supports YAML 1.2 and has round-trip loaders and dumpers
+that preserves, among others:
+
+* comments
+* block style and key ordering are kept, so you can diff the
+ round-tripped source
+* flow style sequences ( ‘a: b, c, d’)
+* anchor names that are hand-crafted (i.e. not of the form``idNNN``)
+* merges in dictionaries are preserved
diff --git a/libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild b/libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild
new file mode 100644
index 0000000000..17b1b8ee01
--- /dev/null
+++ b/libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for python-ruamel.yaml
+
+# Copyright 2019, Alexander Verbovetsky, Moscow, Russia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-ruamel.yaml
+VERSION=${VERSION:-0.16.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf ${PRGNAM:7}-$VERSION
+tar xvf $CWD/${PRGNAM:7}-$VERSION.tar.gz
+cd ${PRGNAM:7}-$VERSION
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+RUAMEL_NO_PIP_INSTALL_CHECK=1 python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/python-ruamel.yaml/python-ruamel.yaml.info b/libraries/python-ruamel.yaml/python-ruamel.yaml.info
new file mode 100644
index 0000000000..e9438e67af
--- /dev/null
+++ b/libraries/python-ruamel.yaml/python-ruamel.yaml.info
@@ -0,0 +1,10 @@
+PRGNAM="python-ruamel.yaml"
+VERSION="0.16.0"
+HOMEPAGE="https://bitbucket.org/ruamel/yaml"
+DOWNLOAD="https://pypi.org/packages/source/r/ruamel.yaml/ruamel.yaml-0.16.0.tar.gz"
+MD5SUM="ce481f80ee02dedcde75a0404209ee55"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Alexander Verbovetsky"
+EMAIL="alik@ejik.org"
diff --git a/libraries/python-ruamel.yaml/slack-desc b/libraries/python-ruamel.yaml/slack-desc
new file mode 100644
index 0000000000..06953f1a3a
--- /dev/null
+++ b/libraries/python-ruamel.yaml/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-ruamel.yaml: python-ruamel.yaml (YAML 1.2 parser and emitter for Python)
+python-ruamel.yaml:
+python-ruamel.yaml: ruamel.yaml is a YAML 1.2 parser and emitter for Python that support
+python-ruamel.yaml: comment preservation.
+python-ruamel.yaml:
+python-ruamel.yaml:
+python-ruamel.yaml: Homepage: https://bitbucket.org/ruamel/yaml
+python-ruamel.yaml:
+python-ruamel.yaml:
+python-ruamel.yaml:
+python-ruamel.yaml: