summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Dimitris Zlatanidis2019-12-10 11:08:00 +0100
committer Willy Sudiarto Raharjo2019-12-15 11:06:34 +0100
commit20ce18160ce23feedb371e65f8877b30af42b21c (patch)
tree573bd364041627333f934417e1a0580cba0142a9 /libraries
parent51ec3240fb312ac809c3114ffc18507563a784f7 (diff)
downloadslackbuilds-20ce18160ce23feedb371e65f8877b30af42b21c.tar.gz
libraries/dropbox-python: Updated for version 9.4.0.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/dropbox-python/README2
-rw-r--r--libraries/dropbox-python/dropbox-python.SlackBuild9
-rw-r--r--libraries/dropbox-python/dropbox-python.info6
3 files changed, 12 insertions, 5 deletions
diff --git a/libraries/dropbox-python/README b/libraries/dropbox-python/README
index 2da12fb763..f87416e916 100644
--- a/libraries/dropbox-python/README
+++ b/libraries/dropbox-python/README
@@ -1,2 +1,4 @@
Official Dropbox REST API Client. Dropbox Core SDK for Python.
A Python library that for Dropbox's HTTP-based Core and Datastore APIs.
+
+NOTE: for python3 build python3 and python3-six requires.
diff --git a/libraries/dropbox-python/dropbox-python.SlackBuild b/libraries/dropbox-python/dropbox-python.SlackBuild
index 9afd173e09..11f45dab81 100644
--- a/libraries/dropbox-python/dropbox-python.SlackBuild
+++ b/libraries/dropbox-python/dropbox-python.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for dropbox-python
-# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=dropbox-python
SCRNAM=$(printf $PRGNAM | cut -c1-7)
-VERSION=${VERSION:-8.7.1}
+VERSION=${VERSION:-9.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -72,6 +72,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/libraries/dropbox-python/dropbox-python.info b/libraries/dropbox-python/dropbox-python.info
index 91ec204efe..05a9a95933 100644
--- a/libraries/dropbox-python/dropbox-python.info
+++ b/libraries/dropbox-python/dropbox-python.info
@@ -1,8 +1,8 @@
PRGNAM="dropbox-python"
-VERSION="8.7.1"
+VERSION="9.4.0"
HOMEPAGE="https://www.dropbox.com/"
-DOWNLOAD="https://pypi.python.org/packages/f3/5e/39bf5507db73b9fd47ef2d39ffa41b14c6627f0bdf5ea947414161e6285b/dropbox-8.7.1.tar.gz"
-MD5SUM="f5c9941e72ed2347c25755b92b61cd5b"
+DOWNLOAD="https://files.pythonhosted.org/packages/88/c9/899c5d112eb4aa48fb611153c2f2eadafd859cbdee637b376d140a60e50d/dropbox-9.4.0.tar.gz"
+MD5SUM="25f2106e9d4ee7b063749c8f22a567dc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="pytest-runner six python-requests"