summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2017-01-02 01:32:53 +0100
committer Willy Sudiarto Raharjo2017-01-06 15:04:20 +0100
commit2a94481929da3142f83b16fada69b5d8d38b972e (patch)
tree5ae36d86b6a862ec8f48289524bbce4b05b51e6e /libraries
parent1fd4eb914026a0871eb115f1c0dd8ace7af97a24 (diff)
downloadslackbuilds-2a94481929da3142f83b16fada69b5d8d38b972e.tar.gz
libraries/notify-sharp: Removed (maintainer request).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/notify-sharp/README7
-rw-r--r--libraries/notify-sharp/doinst.sh38
-rw-r--r--libraries/notify-sharp/notify-sharp.SlackBuild115
-rw-r--r--libraries/notify-sharp/notify-sharp.info10
-rw-r--r--libraries/notify-sharp/slack-desc19
5 files changed, 0 insertions, 189 deletions
diff --git a/libraries/notify-sharp/README b/libraries/notify-sharp/README
deleted file mode 100644
index 719378518a..0000000000
--- a/libraries/notify-sharp/README
+++ /dev/null
@@ -1,7 +0,0 @@
-notify-sharp is a C# client implementation for Desktop Notifications, i.e.
-notification-daemon. It is inspired by the libnotify API.
-
-Desktop Notifications provide a standard way of doing passive pop-up
-notifications on the Linux desktop. These are designed to notify the user of
-something without interrupting their work with a dialog box that they must
-close. Passive popups can automatically disappear after a short period of time.
diff --git a/libraries/notify-sharp/doinst.sh b/libraries/notify-sharp/doinst.sh
deleted file mode 100644
index df314821d4..0000000000
--- a/libraries/notify-sharp/doinst.sh
+++ /dev/null
@@ -1,38 +0,0 @@
-config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-config etc/somefile.conf.new
-
-# Keep same perms on rc.INIT.new:
-if [ -e etc/rc.d/rc.INIT ]; then
- cp -a etc/rc.d/rc.INIT etc/rc.d/rc.INIT.new.incoming
- cat etc/rc.d/rc.INIT.new > etc/rc.d/rc.INIT.new.incoming
- mv etc/rc.d/rc.INIT.new.incoming etc/rc.d/rc.INIT.new
-fi
-
-config etc/rc.d/rc.INIT.new
-config etc/configfile.new
-
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -x /usr/bin/update-mime-database ]; then
- /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
diff --git a/libraries/notify-sharp/notify-sharp.SlackBuild b/libraries/notify-sharp/notify-sharp.SlackBuild
deleted file mode 100644
index a7b59e1c51..0000000000
--- a/libraries/notify-sharp/notify-sharp.SlackBuild
+++ /dev/null
@@ -1,115 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for notify-sharp.
-
-# Copyright 2012 Pierre Cazenave <pwcazenave {at} gmail [dor] com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Revised and updated by Donald Cooley La Porte, IN USA
-
-PRGNAM=notify-sharp
-VERSION=${VERSION:-0.4.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/${PRGNAM}-${VERSION}.tar.?z*
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-sed -i \
- -e 's/dbus-sharp-1.0/dbus-sharp-2.0/' \
- -e 's/dbus-sharp-glib-1.0/dbus-sharp-glib-2.0/' \
- configure.ac
-
-# We set libdir to /usr/lib because that is where mono lives.
-# We will fix the pkgconfig location on 64bit later.
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-GMCS=/usr/bin/mcs \
-./autogen.sh \
- --prefix=/usr \
- --libdir=/usr/lib \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# Fix pkgconfig location on x86_64.
-if [ "$ARCH" = "x86_64" ]; then
- mkdir -p $PKG/usr/lib64
- mv $PKG/usr/lib/pkgconfig $PKG/usr/lib64
-fi
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS COPYING ChangeLog NEWS README docs \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/notify-sharp/notify-sharp.info b/libraries/notify-sharp/notify-sharp.info
deleted file mode 100644
index 2be32a97cf..0000000000
--- a/libraries/notify-sharp/notify-sharp.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="notify-sharp"
-VERSION="0.4.1"
-HOMEPAGE="https://git.gnome.org/browse/notify-sharp/"
-DOWNLOAD="https://git.gnome.org/browse/notify-sharp/snapshot/notify-sharp-0.4.1.tar.gz"
-MD5SUM="b340acd5e3eff40963503855140f8c05"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="gtk-sharp dbus-sharp-glib"
-MAINTAINER="Donald Cooley"
-EMAIL="dfc@warpmail.net"
diff --git a/libraries/notify-sharp/slack-desc b/libraries/notify-sharp/slack-desc
deleted file mode 100644
index 2b2e72e460..0000000000
--- a/libraries/notify-sharp/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-notify-sharp: notify-sharp (a notification daemon in C#)
-notify-sharp:
-notify-sharp: notify-sharp is a C# client implementation for Desktop
-notify-sharp: Notifications, i.e. notification-daemon. It is inspired by the
-notify-sharp: libnotify API.
-notify-sharp:
-notify-sharp: Desktop Notifications provide a standard way of doing passive
-notify-sharp: pop-up notifications on the Linux desktop. These are designed
-notify-sharp: to notify the user of something without interrupting their
-notify-sharp: work with a dialog box that they must close. Passive popups
-notify-sharp: can automatically disappear after a short period of time.