summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Robby Workman2011-03-14 22:02:39 +0100
committer Robby Workman2011-03-14 22:02:39 +0100
commitaa5c82d947b49e41d6564983b304e93a8a35408f (patch)
treea93d80cd1cedfd31d586ecd3d92b294d2ece20ca /libraries
parent6c4382b845e9bb15dcb92087efa97f86be18700d (diff)
downloadslackbuilds-aa5c82d947b49e41d6564983b304e93a8a35408f.tar.gz
libraries/python-prctl: Removed (unmaintained)
Reference: http://lists.slackbuilds.org/pipermail/slackbuilds-users/2010-October/006570.html Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org> Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/python-prctl/README6
-rw-r--r--libraries/python-prctl/python-prctl.SlackBuild71
-rw-r--r--libraries/python-prctl/python-prctl.info10
-rw-r--r--libraries/python-prctl/slack-desc19
4 files changed, 0 insertions, 106 deletions
diff --git a/libraries/python-prctl/README b/libraries/python-prctl/README
deleted file mode 100644
index 34b846b61b..0000000000
--- a/libraries/python-prctl/README
+++ /dev/null
@@ -1,6 +0,0 @@
-The linux prctl function allows you to control specific characteristics of
-a process' behaviour. This module provides a nice non-messy python(ic)
-interface to prctl(2).
-
-Besides prctl, this library also wraps libcap for complete capabilities(7)
-handling and allows you to set the process name as seen in ps and top.
diff --git a/libraries/python-prctl/python-prctl.SlackBuild b/libraries/python-prctl/python-prctl.SlackBuild
deleted file mode 100644
index cce2e13017..0000000000
--- a/libraries/python-prctl/python-prctl.SlackBuild
+++ /dev/null
@@ -1,71 +0,0 @@
-#!/bin/sh
-
-# Slackware build script of an prctl(2)/libcap(3) wrapper for Python
-
-# Written by Menno Duursma <druiloor@zonnet.nl>
-
-# This program is free software. It comes without any warranty.
-# Granted WTFPL, Version 2, as published by Sam Hocevar. See
-# http://sam.zoy.org/wtfpl/COPYING for more details.
-
-PRGNAM=python-prctl
-VERSION=${VERSION:-1.2.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO README docs/index.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/python-prctl/python-prctl.info b/libraries/python-prctl/python-prctl.info
deleted file mode 100644
index c51c5862b8..0000000000
--- a/libraries/python-prctl/python-prctl.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-prctl"
-VERSION="1.2.0"
-HOMEPAGE="http://blogs.ubuntu-nl.org/dennis/2010/03/23/using-linux-capabilitiesprctl-from-python/"
-DOWNLOAD="http://www.kaarsemaker.net/code/python-prctl-1.2.0.tar.gz"
-MD5SUM="f312f5cd400353cc18474536657acd74"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Menno Duursma"
-EMAIL="druiloor@zonnet.nl"
-APPROVED="rworkman"
diff --git a/libraries/python-prctl/slack-desc b/libraries/python-prctl/slack-desc
deleted file mode 100644
index b42d6b21a7..0000000000
--- a/libraries/python-prctl/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-----------------------------------------------------|
-python-prctl: python-prctl (Linux capabilities/prctl from python)
-python-prctl:
-python-prctl: python-prctl is a Python wrapper for process handiling and libcap.
-python-prctl:
-python-prctl: python-prctl was written by Dennis Kaarsemaker.
-python-prctl:
-python-prctl:
-python-prctl:
-python-prctl:
-python-prctl:
-python-prctl: