summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Larry Hajali2013-11-14 06:49:22 +0100
committer Robby Workman2013-11-14 07:06:37 +0100
commit7a4bb77308c8df61bcd10f593823d1f0a8ecb285 (patch)
treede285e794cd31cea7b5d0e3669a58223baf3c317 /libraries
parentd3007343bab92e0d248d72b0accf4ec0632ae0b4 (diff)
downloadslackbuilds-7a4bb77308c8df61bcd10f593823d1f0a8ecb285.tar.gz
libraries/ClientForm: Removed
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/ClientForm/ClientForm.SlackBuild60
-rw-r--r--libraries/ClientForm/ClientForm.info10
-rw-r--r--libraries/ClientForm/README5
-rw-r--r--libraries/ClientForm/pysetuptools.diff12
-rw-r--r--libraries/ClientForm/slack-desc19
5 files changed, 0 insertions, 106 deletions
diff --git a/libraries/ClientForm/ClientForm.SlackBuild b/libraries/ClientForm/ClientForm.SlackBuild
deleted file mode 100644
index aa5177eb8a..0000000000
--- a/libraries/ClientForm/ClientForm.SlackBuild
+++ /dev/null
@@ -1,60 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for ClientForm
-
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
-
-PRGNAM=ClientForm
-VERSION=${VERSION:-0.2.10}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -eu
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Use system pysetuptools
-patch -p1 < $CWD/pysetuptools.diff
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-mv testdata $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.txt *.html $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a test/test_clientform.py examples/* $PKG/usr/doc/$PRGNAM-$VERSION/testdata
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/ClientForm/ClientForm.info b/libraries/ClientForm/ClientForm.info
deleted file mode 100644
index a4941e97ce..0000000000
--- a/libraries/ClientForm/ClientForm.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="ClientForm"
-VERSION="0.2.10"
-HOMEPAGE="http://wwwsearch.sourceforge.net/ClientForm/"
-DOWNLOAD="http://wwwsearch.sourceforge.net/ClientForm/src/ClientForm-0.2.10.tar.gz"
-MD5SUM="832c0ca78674f9263d1fc5fab8756e66"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pysetuptools"
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/libraries/ClientForm/README b/libraries/ClientForm/README
deleted file mode 100644
index 77456e97a1..0000000000
--- a/libraries/ClientForm/README
+++ /dev/null
@@ -1,5 +0,0 @@
-ClientForm is a Python module for handling HTML forms on the client
-side, useful for parsing HTML forms, filling them in and returning
-the completed forms to the server. It developed from a port of Gisle
-Aas' Perl module HTML::Form, from the libwww-perl library, but the
-interface is not the same.
diff --git a/libraries/ClientForm/pysetuptools.diff b/libraries/ClientForm/pysetuptools.diff
deleted file mode 100644
index 4b143c9b42..0000000000
--- a/libraries/ClientForm/pysetuptools.diff
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur ClientForm-0.2.10.orig/setup.py ClientForm-0.2.10/setup.py
---- ClientForm-0.2.10.orig/setup.py 2008-12-03 23:12:31.000000000 +0000
-+++ ClientForm-0.2.10/setup.py 2009-03-16 15:48:45.000000000 +0000
-@@ -89,8 +89,6 @@
- del kwargs["py_modules"]
- apply(_setup, (), kwargs)
- else:
-- import ez_setup
-- ez_setup.use_setuptools()
- from setuptools import setup
-
- setup(
diff --git a/libraries/ClientForm/slack-desc b/libraries/ClientForm/slack-desc
deleted file mode 100644
index 29e499aace..0000000000
--- a/libraries/ClientForm/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-ClientForm: ClientForm (Python module for handling HTML forms)
-ClientForm:
-ClientForm: ClientForm is a Python module for handling HTML forms on the client
-ClientForm: side, useful for parsing HTML forms, filling them in and returning
-ClientForm: the completed forms to the server.
-ClientForm:
-ClientForm: Homepage: http://wwwsearch.sourceforge.net/ClientForm/
-ClientForm:
-ClientForm:
-ClientForm:
-ClientForm: