summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-02-07 07:57:14 +0100
committer Erik Hanson2014-02-08 18:10:12 +0100
commit91d599542bc41aafa03b9a2fd54196a3321406ea (patch)
tree2418ee221a65379eb67aff56fa759bb5d528f27b /libraries
parentd553a717252a1c0407c637165d2c7c18572b1f64 (diff)
downloadslackbuilds-91d599542bc41aafa03b9a2fd54196a3321406ea.tar.gz
libraries/dropbox-python: Added (Official Dropbox REST API Client).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/dropbox-python/README3
-rw-r--r--libraries/dropbox-python/dropbox-python.SlackBuild92
-rw-r--r--libraries/dropbox-python/dropbox-python.info11
-rw-r--r--libraries/dropbox-python/slack-desc19
4 files changed, 125 insertions, 0 deletions
diff --git a/libraries/dropbox-python/README b/libraries/dropbox-python/README
new file mode 100644
index 0000000000..cfcc6ffeb2
--- /dev/null
+++ b/libraries/dropbox-python/README
@@ -0,0 +1,3 @@
+Official Dropbox REST API Client. Dropbox Core SDK for Python.
+
+A Python library that for Dropbox's HTTP-based Core and Datastore APIs.
diff --git a/libraries/dropbox-python/dropbox-python.SlackBuild b/libraries/dropbox-python/dropbox-python.SlackBuild
new file mode 100644
index 0000000000..91a990d884
--- /dev/null
+++ b/libraries/dropbox-python/dropbox-python.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for dropbox-python
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=dropbox-python
+SCRNAM=dropbox
+VERSION=${VERSION:-2.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SCRNAM-$VERSION
+unzip $CWD/$SCRNAM-$VERSION.zip
+cd $SCRNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.mdown LICENSE PKG-INFO README.rst TESTING conf.py \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+
diff --git a/libraries/dropbox-python/dropbox-python.info b/libraries/dropbox-python/dropbox-python.info
new file mode 100644
index 0000000000..6adf9a2a19
--- /dev/null
+++ b/libraries/dropbox-python/dropbox-python.info
@@ -0,0 +1,11 @@
+PRGNAM="dropbox-python"
+VERSION="2.0.0"
+HOMEPAGE="http://www.dropbox.com/"
+DOWNLOAD="https://pypi.python.org/packages/source/d/dropbox/dropbox-2.0.0.zip"
+MD5SUM="372c82d74bfc597615c1657d531376ac"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools python-urllib3"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
+
diff --git a/libraries/dropbox-python/slack-desc b/libraries/dropbox-python/slack-desc
new file mode 100644
index 0000000000..c318f8d5b1
--- /dev/null
+++ b/libraries/dropbox-python/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+dropbox-python: dropbox-python: (Official Dropbox REST API Client)
+dropbox-python:
+dropbox-python: A Python library for Dropbox's HTTP-based Core and Datastore APIs.
+dropbox-python:
+dropbox-python: Homepage: https://www.dropbox.com/
+dropbox-python:
+dropbox-python:
+dropbox-python:
+dropbox-python:
+dropbox-python:
+dropbox-python: