summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-02-06 01:43:29 +0100
committer Erik Hanson2014-02-08 18:10:10 +0100
commit86d7a33d47c9228f214ec5dad1a0eff89960d1a3 (patch)
tree7d1d56f5ca0fdb5b267815fac3c511457e85cd70 /libraries
parented44ea23854d901e92f83bc21311bc0a91bba929 (diff)
downloadslackbuilds-86d7a33d47c9228f214ec5dad1a0eff89960d1a3.tar.gz
libraries/python-gnupg: Added (A wrapper for the GnuPG).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/python-gnupg/README8
-rw-r--r--libraries/python-gnupg/python-gnupg.SlackBuild89
-rw-r--r--libraries/python-gnupg/python-gnupg.info10
-rw-r--r--libraries/python-gnupg/slack-desc19
4 files changed, 126 insertions, 0 deletions
diff --git a/libraries/python-gnupg/README b/libraries/python-gnupg/README
new file mode 100644
index 0000000000..6c78b449d5
--- /dev/null
+++ b/libraries/python-gnupg/README
@@ -0,0 +1,8 @@
+A Python wrapper for GnuPG
+The gnupg module allows Python programs to make use of the functionality
+provided by the GNU Privacy Guard (abbreviated GPG or GnuPG).
+
+Using this module, Python programs can encrypt and decrypt data, digitally
+sign documents and verify signatures, manage (generate, list and delete)
+encryption keys, using proven Public Key Infrastructure (PKI) encryption
+technology based on OpenPGP.
diff --git a/libraries/python-gnupg/python-gnupg.SlackBuild b/libraries/python-gnupg/python-gnupg.SlackBuild
new file mode 100644
index 0000000000..80f0f64b6b
--- /dev/null
+++ b/libraries/python-gnupg/python-gnupg.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for python-gnupg
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-gnupg
+VERSION=${VERSION:-0.3.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO README LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/python-gnupg/python-gnupg.info b/libraries/python-gnupg/python-gnupg.info
new file mode 100644
index 0000000000..a54bc46b11
--- /dev/null
+++ b/libraries/python-gnupg/python-gnupg.info
@@ -0,0 +1,10 @@
+PRGNAM="python-gnupg"
+VERSION="0.3.6"
+HOMEPAGE="http://pythonhosted.org/python-gnupg/index.html"
+DOWNLOAD="https://pypi.python.org/packages/source/p/python-gnupg/python-gnupg-0.3.6.tar.gz"
+MD5SUM="27415bead227e8c6906900b7c777120c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/python-gnupg/slack-desc b/libraries/python-gnupg/slack-desc
new file mode 100644
index 0000000000..6bf8d580c7
--- /dev/null
+++ b/libraries/python-gnupg/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-gnupg: python-gnupg (A wrapper for the GnuPG)
+python-gnupg:
+python-gnupg: This module allows easy access to GnuPG's key management,
+python-gnupg: encryption and signature functionality from Python programs. It is
+python-gnupg: intended for use with Python 2.4 or greater.
+python-gnupg:
+python-gnupg: Homepage: http://pythonhosted.org/python-gnupg/index.html
+python-gnupg:
+python-gnupg:
+python-gnupg:
+python-gnupg: