summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author David Spencer2014-02-04 17:53:33 +0100
committer Erik Hanson2014-02-08 18:10:09 +0100
commit1ffa20b9dcccba7f3e0ca1f90583b865e652118a (patch)
treeb647934e900f9d06c89f77fb2d38def75c67ac0b /libraries
parentcdf9839b661522eb93d09b61d9625b0541d9d2df (diff)
downloadslackbuilds-1ffa20b9dcccba7f3e0ca1f90583b865e652118a.tar.gz
gis/gdal: Moved from Libraries category.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/gdal/README16
-rw-r--r--libraries/gdal/gdal-python-install.patch10
-rw-r--r--libraries/gdal/gdal.SlackBuild166
-rw-r--r--libraries/gdal/gdal.info10
-rw-r--r--libraries/gdal/slack-desc19
5 files changed, 0 insertions, 221 deletions
diff --git a/libraries/gdal/README b/libraries/gdal/README
deleted file mode 100644
index 2d13ccb84d..0000000000
--- a/libraries/gdal/README
+++ /dev/null
@@ -1,16 +0,0 @@
-GDAL is a library for reading and writing raster geospatial data
-formats, and is released under an X/MIT style Open Source license by
-the Open Source Geospatial Foundation. As a library, it presents a
-single abstract data model to the calling application for all
-supported formats. It may also be built with a variety of useful
-command-line utilities for data translation and processing.
-
-The related OGR library (which is part of the GDAL source tree)
-provides a similar capability for simple features vector data.
-
-The following optional requirements are detected automatically:
-cfitsio, freexl, hdf5, libwebp, netcdf, postgresql, xerces-c
-
-To enable OpenCL GPU-accelerated performance, specify the option
-OPENCL=yes (requires opencl-headers to build, and either nvidia-driver
-or amd-app-sdk with suitable GPU hardware to run).
diff --git a/libraries/gdal/gdal-python-install.patch b/libraries/gdal/gdal-python-install.patch
deleted file mode 100644
index 8ec414d37a..0000000000
--- a/libraries/gdal/gdal-python-install.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- swig/python/GNUmakefile.orig 2010-04-24 01:22:07.000000000 +0200
-+++ swig/python/GNUmakefile 2010-05-05 19:14:58.000000000 +0200
-@@ -72,5 +72,5 @@
- ifeq ($(PY_HAVE_SETUPTOOLS),1)
-- $(PYTHON) setup.py install
-+ $(PYTHON) setup.py install --root=$(DESTDIR)
- else
-- $(PYTHON) setup.py install --prefix=$(DESTDIR)$(prefix)
-+ $(PYTHON) setup.py install --root=$(DESTDIR) --prefix=$(prefix)
- endif
diff --git a/libraries/gdal/gdal.SlackBuild b/libraries/gdal/gdal.SlackBuild
deleted file mode 100644
index d48e6939e9..0000000000
--- a/libraries/gdal/gdal.SlackBuild
+++ /dev/null
@@ -1,166 +0,0 @@
-#!/bin/sh
-# Slackware build script for GDAL
-
-# Copyright 2009 Marco Cecchetti <mrc.ild@gmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# Maintained by David Spencer <baildon.research@googlemail.com>
-
-PRGNAM=gdal
-VERSION=${VERSION:-1.10.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# OpenCL, webp, Spatialite and Grass support need special arrangements.
-# Everything else is handled automatically by configure.
-WITHLIST=""
-
-# Request OpenCL support:
-if [ ${OPENCL:-no} = "yes" ]; then
- WITHLIST+=" --with-opencl"
-fi
-
-# Request webp support if it's installed:
-if pkg-config --exists libwebp; then
- WITHLIST+=" --with-webp"
-fi
-
-# Spatialite support in gdal optionally has a circular dependency
-# via the postgis 'liblwgeom' library (postgis depends on gdal).
-# Here is an undocumented option to request Spatialite support,
-# if you promise to be careful :-)
-if pkg-config --exists spatialite; then
- if [ ${SPATIALITE:-no} = "yes" ]; then
- WITHLIST+=" --with-spatialite"
- fi
-fi
-
-# Also, enabling Grass support in gdal introduces a circular dependency,
-# so here is another undocumented option.
-if pkg-config --exists grass; then
- if [ ${GRASS:-no} = "yes" ]; then
- WITHLIST+=" --with-grass=$(pkg-config --variable=prefix grass)"
- fi
-fi
-
-# 12 bit JPEG support is handled by internal modified versions of libjpeg
-# and libtiff, but this can cause segfaults in other software linked against
-# the real libjpeg (eg. qgis calling qt). Enable JPEG12 only if you need it:
-if [ ${JPEG12:-no} = "yes" ]; then
- WITHLIST+=" --with-jpeg=internal --with-libtiff=internal"
-else
- WITHLIST+=" --with-jpeg=/usr/lib${LIBDIRSUFFIX} --with-libtiff=/usr/lib${LIBDIRSUFFIX}"
-fi
-
-# Thanks to the people at Arch for this:
-patch -p0 <$CWD/gdal-python-install.patch
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --enable-static=no \
- --with-threads \
- --with-geos=yes \
- --with-ogr=yes \
- --with-libz=/usr/lib${LIBDIRSUFFIX} \
- --with-liblzma \
- --with-curl=/usr/bin/curl-config \
- --without-grib \
- --with-static-proj4 \
- --with-mysql \
- --with-python \
- --with-poppler \
- $WITHLIST \
- --build=$ARCH-slackware-linux
-
-make -j1
-make install DESTDIR=$PKG
-
-# Kill erroneously installed .dox files
-rm $PKG/usr/bin/*.dox
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-make -f GNUmakefile -B man
-make install-man DESTDIR=$PKG
-gzip -9 $PKG/usr/man/man?/* || exit 1
-
-make -f GNUmakefile -B docs
-# --docdir is ignored :-(
-make install-docs DESTDIR=$PKG INST_DOCS=/usr/doc/$PRGNAM-$VERSION
-cp -a \
- COMMITERS HOWTO-RELEASE LICENSE.TXT NEWS PROVENANCE.TXT VERSION \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/gdal/gdal.info b/libraries/gdal/gdal.info
deleted file mode 100644
index 092df41919..0000000000
--- a/libraries/gdal/gdal.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="gdal"
-VERSION="1.10.1"
-HOMEPAGE="http://www.gdal.org/"
-DOWNLOAD="http://download.osgeo.org/gdal/1.10.1/gdal-1.10.1.tar.xz"
-MD5SUM="f354c614aea76e5630e4edbf06e5c292"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="geos proj %README%"
-MAINTAINER="David Spencer"
-EMAIL="baildon.research@googlemail.com"
diff --git a/libraries/gdal/slack-desc b/libraries/gdal/slack-desc
deleted file mode 100644
index 9bfe528cf2..0000000000
--- a/libraries/gdal/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-gdal: GDAL (translator library for raster geospatial data formats)
-gdal:
-gdal: The Geospatial Data Abstraction Library (GDAL) is a unifying
-gdal: C/C++ API for accessing raster geospatial data. The related OGR
-gdal: library (included with GDAL) provides a similar capability for vector
-gdal: data.
-gdal:
-gdal: Homepage: http://www.gdal.org
-gdal:
-gdal:
-gdal: