summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Larry Hajali2013-05-19 15:12:09 +0200
committer dsomero2013-05-19 15:12:09 +0200
commit0fa725094732c3bb45d94cdb90374c46480bd04d (patch)
tree7d70daa1da6d2698ebdc6ebe2804ad0949f33ccd /libraries
parent155f4dceb481fc6995a33038e7a3349278f09533 (diff)
downloadslackbuilds-0fa725094732c3bb45d94cdb90374c46480bd04d.tar.gz
libraries/miniupnpc: Updated for version 1.8.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/miniupnpc/README3
-rw-r--r--libraries/miniupnpc/miniupnpc.SlackBuild37
-rw-r--r--libraries/miniupnpc/miniupnpc.info6
-rw-r--r--libraries/miniupnpc/slack-desc10
4 files changed, 43 insertions, 13 deletions
diff --git a/libraries/miniupnpc/README b/libraries/miniupnpc/README
index 7d1ff06c3d..702b316b8f 100644
--- a/libraries/miniupnpc/README
+++ b/libraries/miniupnpc/README
@@ -1,3 +1,6 @@
MiniUPnPc, the client library, enabling applications to access the
services provided by an UPnP "Internet Gateway Device" present on
the network. In UPnP terminology, it is a UPnP Control Point.
+
+MiniUPnPc will install a Python3 module if Python3 is installed on
+the system during compile time.
diff --git a/libraries/miniupnpc/miniupnpc.SlackBuild b/libraries/miniupnpc/miniupnpc.SlackBuild
index e910674036..d885afaeb3 100644
--- a/libraries/miniupnpc/miniupnpc.SlackBuild
+++ b/libraries/miniupnpc/miniupnpc.SlackBuild
@@ -2,10 +2,28 @@
# Slackware build script for miniupnpc
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=miniupnpc
-VERSION=${VERSION:-1.7}
+VERSION=${VERSION:-1.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -53,14 +71,23 @@ find . \
# Slackware/Slackbuilds.org specific info.
patch -p1 < $CWD/slackware-version.patch
-sed -i -e "/^CFLAGS/ s|-O|$SLKCFLAGS|" -e 's|share/man|man|' Makefile
+sed -i 's|share/man|man|' Makefile
+sed -i -e 's|\.a"|\.so"|' -e "s|version=\".*\"|version=\"$VERSION\"|" setup.py
# Upstream Cmake causes build problems. We're going to use the makefile instead.
-make
-make install PREFIX=$PKG INSTALLDIRLIB="$PKG/usr/lib$LIBDIRSUFFIX"
+CFLAGS="$SLKCFLAGS" LIBDIR="lib${LIBDIRSUFFIX}" make
+make install PREFIX=$PKG LIBDIR="lib${LIBDIRSUFFIX}"
+CFLAGS="$SLKCFLAGS" \
python setup.py install --root=$PKG
+# For python 3.x support.
+if `python3 -c 'import distutils' 2>/dev/null`; then
+ CFLAGS="$SLKCFLAGS" \
+ python3 setup.py build
+ python3 setup.py install --root=$PKG --no-compile
+fi
+
# Remove static library.
rm -f $PKG/usr/lib$LIBDIRSUFFIX/lib$PRGNAM.a
diff --git a/libraries/miniupnpc/miniupnpc.info b/libraries/miniupnpc/miniupnpc.info
index 390327534e..9ea6db8a97 100644
--- a/libraries/miniupnpc/miniupnpc.info
+++ b/libraries/miniupnpc/miniupnpc.info
@@ -1,8 +1,8 @@
PRGNAM="miniupnpc"
-VERSION="1.7"
+VERSION="1.8"
HOMEPAGE="http://miniupnp.free.fr/"
-DOWNLOAD="http://miniupnp.free.fr/files/miniupnpc-1.7.tar.gz"
-MD5SUM="297bee441b56af87c6622fc4002179fd"
+DOWNLOAD="http://miniupnp.free.fr/files/miniupnpc-1.8.tar.gz"
+MD5SUM="065bf20a20ebe605c675b7a5aaef340a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/libraries/miniupnpc/slack-desc b/libraries/miniupnpc/slack-desc
index f02527a4b8..c9e425ea4e 100644
--- a/libraries/miniupnpc/slack-desc
+++ b/libraries/miniupnpc/slack-desc
@@ -1,13 +1,13 @@
# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
miniupnpc: miniupnpc (UPnP Control Point library)
-miniupnpc:
+miniupnpc:
miniupnpc: MiniUPnPc, the client library, enabling applications to access the
miniupnpc: services provided by an UPnP "Internet Gateway Device" present on the
miniupnpc: network. In UPnP terminology, it is a UPnP Control Point.