summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author David Spencer2013-06-06 01:45:06 +0200
committer dsomero2013-06-06 01:45:06 +0200
commit06435eea38af2693c641bc11f8d526a686b2a815 (patch)
tree973044dfe987abf3b322045f0e6f623891900378 /libraries
parent9c74d9d473dbf2f2e7586c94f6a29ac88d64998f (diff)
downloadslackbuilds-06435eea38af2693c641bc11f8d526a686b2a815.tar.gz
libraries/gdal: Updated for version 1.9.2.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/gdal/README7
-rw-r--r--libraries/gdal/gdal-1.9.1-poppler-0.20.1.patch143
-rw-r--r--libraries/gdal/gdal.SlackBuild38
-rw-r--r--libraries/gdal/gdal.info8
-rw-r--r--libraries/gdal/slack-desc10
5 files changed, 43 insertions, 163 deletions
diff --git a/libraries/gdal/README b/libraries/gdal/README
index 33aaaa0ebc..2d13ccb84d 100644
--- a/libraries/gdal/README
+++ b/libraries/gdal/README
@@ -8,4 +8,9 @@ command-line utilities for data translation and processing.
The related OGR library (which is part of the GDAL source tree)
provides a similar capability for simple features vector data.
-xerces-c is an optional dependency.
+The following optional requirements are detected automatically:
+cfitsio, freexl, hdf5, libwebp, netcdf, postgresql, xerces-c
+
+To enable OpenCL GPU-accelerated performance, specify the option
+OPENCL=yes (requires opencl-headers to build, and either nvidia-driver
+or amd-app-sdk with suitable GPU hardware to run).
diff --git a/libraries/gdal/gdal-1.9.1-poppler-0.20.1.patch b/libraries/gdal/gdal-1.9.1-poppler-0.20.1.patch
deleted file mode 100644
index 3e7f0355a6..0000000000
--- a/libraries/gdal/gdal-1.9.1-poppler-0.20.1.patch
+++ /dev/null
@@ -1,143 +0,0 @@
-Index: /branches/1.9/gdal/nmake.opt
-===================================================================
---- /branches/1.9/gdal/nmake.opt (revision 23610)
-+++ /branches/1.9/gdal/nmake.opt (revision 24437)
-@@ -469,8 +469,10 @@
- # Uncomment for PDF support
- # Uncomment POPPLER_BASE_STREAM_HAS_TWO_ARGS = YES for Poppler >= 0.16.0
-+# Uncomment POPPLER_0_20_OR_LATER = YES for Poppler >= 0.20.0
- #POPPLER_ENABLED = YES
- #POPPLER_CFLAGS = -Ie:/kde/include -Ie:/kde/include/poppler
- #POPPLER_HAS_OPTCONTENT = YES
- #POPPLER_BASE_STREAM_HAS_TWO_ARGS = YES
-+#POPPLER_0_20_OR_LATER = YES
- #POPPLER_LIBS = e:/kde/lib/poppler.lib e:/kde/lib/freetype.lib e:/kde/lib/liblcms-1.lib advapi32.lib gdi32.lib
-
-Index: /branches/1.9/gdal/configure.in
-===================================================================
---- /branches/1.9/gdal/configure.in (revision 24333)
-+++ /branches/1.9/gdal/configure.in (revision 24437)
-@@ -2941,4 +2941,5 @@
- POPPLER_HAS_OPTCONTENT=no
- POPPLER_BASE_STREAM_HAS_TWO_ARGS=no
-+POPPLER_0_20_OR_LATER=no
-
- AC_MSG_CHECKING([for poppler])
-@@ -3000,4 +3001,17 @@
- POPPLER_BASE_STREAM_HAS_TWO_ARGS=yes
- AC_MSG_RESULT([yes])
-+
-+ # And now we check if we have Poppler >= 0.20.0
-+ AC_MSG_CHECKING([if we have Poppler >= 0.20.0])
-+ rm -f testpoppler.*
-+ echo '#include <poppler/Error.h>' > testpoppler.cpp
-+ echo 'int main(int argc, char** argv) { setErrorCallback(0,0); return 0; }' >> testpoppler.cpp
-+ if test -z "`${CXX} testpoppler.cpp -c ${POPPLER_INC} 2>&1`" ; then
-+ POPPLER_0_20_OR_LATER=yes
-+ AC_MSG_RESULT([yes])
-+ else
-+ AC_MSG_RESULT([no])
-+ fi
-+
- else
- AC_MSG_RESULT([no])
-@@ -3015,4 +3029,5 @@
- AC_SUBST(POPPLER_HAS_OPTCONTENT, $POPPLER_HAS_OPTCONTENT)
- AC_SUBST(POPPLER_BASE_STREAM_HAS_TWO_ARGS, $POPPLER_BASE_STREAM_HAS_TWO_ARGS)
-+AC_SUBST(POPPLER_0_20_OR_LATER, $POPPLER_0_20_OR_LATER)
- AC_SUBST(POPPLER_INC, $POPPLER_INC)
-
-Index: /branches/1.9/gdal/frmts/pdf/pdfdataset.cpp
-===================================================================
---- /branches/1.9/gdal/frmts/pdf/pdfdataset.cpp (revision 23986)
-+++ /branches/1.9/gdal/frmts/pdf/pdfdataset.cpp (revision 24437)
-@@ -327,5 +327,9 @@
- poSplashOut = new SplashOutputDev(splashModeRGB8, 4, gFalse, sColor);
- PDFDoc* poDoc = poGDS->poDoc;
-+#ifdef POPPLER_0_20_OR_LATER
-+ poSplashOut->startDoc(poDoc);
-+#else
- poSplashOut->startDoc(poDoc->getXRef());
-+#endif
- double dfDPI = poGDS->dfDPI;
-
-@@ -518,4 +522,19 @@
-
- #ifdef USE_POPPLER
-+#ifdef POPPLER_0_20_OR_LATER
-+static void PDFDatasetErrorFunction(void* userData, ErrorCategory eErrCatagory, int nPos, char *pszMsg)
-+{
-+ CPLString osError;
-+
-+ if (nPos >= 0)
-+ osError.Printf("Pos = %d, ", nPos);
-+ osError += pszMsg;
-+
-+ if (strcmp(osError.c_str(), "Incorrect password") == 0)
-+ return;
-+
-+ CPLError(CE_Failure, CPLE_AppDefined, "%s", osError.c_str());
-+}
-+#else
- static void PDFDatasetErrorFunction(int nPos, char *pszMsg, va_list args)
- {
-@@ -531,4 +550,5 @@
- CPLError(CE_Failure, CPLE_AppDefined, "%s", osError.c_str());
- }
-+#endif
- #endif
-
-@@ -567,5 +587,9 @@
-
- /* Set custom error handler for poppler errors */
-+#ifdef POPPLER_0_20_OR_LATER
-+ setErrorCallback(PDFDatasetErrorFunction, NULL);
-+#else
- setErrorFunction(PDFDatasetErrorFunction);
-+#endif
-
- /* poppler global variable */
-Index: /branches/1.9/gdal/frmts/pdf/makefile.vc
-===================================================================
---- /branches/1.9/gdal/frmts/pdf/makefile.vc (revision 22493)
-+++ /branches/1.9/gdal/frmts/pdf/makefile.vc (revision 24437)
-@@ -7,5 +7,5 @@
-
- !IFDEF POPPLER_ENABLED
--EXTRAFLAGS = $(POPPLER_CFLAGS) $(POPPLER_HAS_OPTCONTENT_FLAGS) $(POPPLER_BASE_STREAM_HAS_TWO_ARGS_FLAGS) -DUSE_POPPLER
-+EXTRAFLAGS = $(POPPLER_CFLAGS) $(POPPLER_HAS_OPTCONTENT_FLAGS) $(POPPLER_BASE_STREAM_HAS_TWO_ARGS_FLAGS) $(POPPLER_0_20_OR_LATER_FLAGS) -DUSE_POPPLER
-
- !IFDEF POPPLER_HAS_OPTCONTENT
-@@ -15,4 +15,8 @@
- !IFDEF POPPLER_BASE_STREAM_HAS_TWO_ARGS
- POPPLER_BASE_STREAM_HAS_TWO_ARGS_FLAGS = -DPOPPLER_BASE_STREAM_HAS_TWO_ARGS
-+!ENDIF
-+
-+!IFDEF POPPLER_0_20_OR_LATER
-+POPPLER_0_20_OR_LATER_FLAGS = -DPOPPLER_0_20_OR_LATER
- !ENDIF
-
-Index: /branches/1.9/gdal/frmts/pdf/GNUmakefile
-===================================================================
---- /branches/1.9/gdal/frmts/pdf/GNUmakefile (revision 22491)
-+++ /branches/1.9/gdal/frmts/pdf/GNUmakefile (revision 24437)
-@@ -16,4 +16,9 @@
- endif
-
-+ifeq ($(POPPLER_0_20_OR_LATER),yes)
-+CPPFLAGS += -DPOPPLER_0_20_OR_LATER
-+endif
-+
-+
- CPPFLAGS := $(GDAL_INCLUDE) $(CPPFLAGS) $(POPPLER_INC) $(PODOFO_INC)
-
-Index: /branches/1.9/gdal/GDALmake.opt.in
-===================================================================
---- /branches/1.9/gdal/GDALmake.opt.in (revision 24419)
-+++ /branches/1.9/gdal/GDALmake.opt.in (revision 24437)
-@@ -386,4 +386,5 @@
- POPPLER_HAS_OPTCONTENT = @POPPLER_HAS_OPTCONTENT@
- POPPLER_BASE_STREAM_HAS_TWO_ARGS = @POPPLER_BASE_STREAM_HAS_TWO_ARGS@
-+POPPLER_0_20_OR_LATER = @POPPLER_0_20_OR_LATER@
- POPPLER_INC = @POPPLER_INC@
-
diff --git a/libraries/gdal/gdal.SlackBuild b/libraries/gdal/gdal.SlackBuild
index 70fbdd5e97..109396aef6 100644
--- a/libraries/gdal/gdal.SlackBuild
+++ b/libraries/gdal/gdal.SlackBuild
@@ -24,7 +24,7 @@
# Maintained by David Spencer <baildon.research@googlemail.com>
PRGNAM=gdal
-VERSION=${VERSION:-1.9.1}
+VERSION=${VERSION:-1.9.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,9 +70,32 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# OpenCL, webp, Grass and Spatialite support need special arrangements.
+# Everything else is handled automatically by configure.
WITHLIST=""
-# Grass support is buggy. If you really want it,
-# here is an undocumented option to enable it :-/
+
+# Request OpenCL support:
+if [ ${OPENCL:-no} = "yes" ]; then
+ WITHLIST+=" --with-opencl"
+fi
+
+# Request webp support if it's installed:
+if pkg-config --exists libwebp; then
+ WITHLIST+=" --with-webp"
+fi
+
+# Spatialite support in gdal optionally has a circular dependency
+# via the postgis 'liblwgeom' library (postgis depends on gdal).
+# Here is an undocumented option to request Spatialite support,
+# if you promise to be careful :-)
+if pkg-config --exists spatialite; then
+ if [ ${SPATIALITE:-no} = "yes" ]; then
+ WITHLIST+=" --with-spatialite"
+ fi
+fi
+
+# Also, enabling Grass support in gdal introduces a circular dependency,
+# so here is another undocumented option.
if pkg-config --exists grass; then
if [ ${GRASS:-no} = "yes" ]; then
WITHLIST+=" --with-grass=$(pkg-config --variable=prefix grass)"
@@ -81,14 +104,9 @@ fi
# Thanks to the people at Arch for this:
patch -p0 <$CWD/gdal-python-install.patch
-# and to the ones at Gentoo for this:
-patch -p4 <$CWD/gdal-1.9.1-poppler-0.20.1.patch
-
-echo "ACLOCAL_AMFLAGS = -I m4" > Makefile.am
-autoreconf -i
-CFLAGS="$SLKCFLAGS -Wno-error" \
-CXXFLAGS="$SLKCFLAGS -Wno-error" \
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
diff --git a/libraries/gdal/gdal.info b/libraries/gdal/gdal.info
index d9b4840a0b..6075600418 100644
--- a/libraries/gdal/gdal.info
+++ b/libraries/gdal/gdal.info
@@ -1,10 +1,10 @@
PRGNAM="gdal"
-VERSION="1.9.1"
+VERSION="1.9.2"
HOMEPAGE="http://www.gdal.org/"
-DOWNLOAD="http://download.osgeo.org/gdal/gdal-1.9.1.tar.gz"
-MD5SUM="c5cf09b92dac1f5775db056e165b34f5"
+DOWNLOAD="http://download.osgeo.org/gdal/gdal-1.9.2.tar.gz"
+MD5SUM="3f39db89f4710269b3a8bf94178e07aa"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="geos proj"
+REQUIRES="geos proj %README%"
MAINTAINER="David Spencer"
EMAIL="baildon.research@googlemail.com"
diff --git a/libraries/gdal/slack-desc b/libraries/gdal/slack-desc
index a17ab6f6e9..9e7c2c4b77 100644
--- a/libraries/gdal/slack-desc
+++ b/libraries/gdal/slack-desc
@@ -1,9 +1,9 @@
# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
gdal: GDAL (translator library for raster geospatial data formats)