summaryrefslogtreecommitdiffstats
path: root/libraries/wxPython3/wxPython3.SlackBuild
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2016-09-11 03:51:02 +0200
committer Willy Sudiarto Raharjo2016-09-11 03:51:02 +0200
commitd236a3d3b85de96c347c87c12310a69642838799 (patch)
treed7a160b12e160004089d4304e884d4db8eee68b6 /libraries/wxPython3/wxPython3.SlackBuild
parent62a0fb786a427b6d832a3553ab05762a460045e4 (diff)
downloadslackbuilds-d236a3d3b85de96c347c87c12310a69642838799.tar.gz
libraries/wxPython3: Added (Crossplatform GUI Toolkit).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/wxPython3/wxPython3.SlackBuild')
-rw-r--r--libraries/wxPython3/wxPython3.SlackBuild158
1 files changed, 158 insertions, 0 deletions
diff --git a/libraries/wxPython3/wxPython3.SlackBuild b/libraries/wxPython3/wxPython3.SlackBuild
new file mode 100644
index 0000000000..181ff3e867
--- /dev/null
+++ b/libraries/wxPython3/wxPython3.SlackBuild
@@ -0,0 +1,158 @@
+#!/bin/sh
+
+# Slackware build script for wxPython3
+
+# Copyright 2007-2014 Heinz Wiesinger, Amsterdam, The Netherlands
+# Copyright 2016 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=wxPython3
+SRCNAM=wxPython
+VERSION=${VERSION:-3.0.2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-src-$VERSION
+tar xvf $CWD/$SRCNAM-src-$VERSION.tar.bz2
+cd $SRCNAM-src-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --with-gtk=2 \
+ --with-sdl \
+ --with-opengl \
+ --enable-unicode \
+ --enable-graphics_ctx \
+ --enable-display \
+ --enable-mediactrl \
+ --enable-sound \
+ --disable-precomp-headers \
+ --libdir=/usr/lib$LIBDIRSUFFIX \
+ --build=$ARCH-slackware-linux
+
+make
+
+cd wxPython
+ python setup.py \
+ WXPORT=gtk2 \
+ UNICODE=1 \
+ EP_ADD_OPTS=1 \
+ EP_FULL_VER=0 \
+ NO_SCRIPTS=0 \
+ WX_CONFIG="$TMP/$SRCNAM-src-$VERSION/wx-config --no_rpath" \
+ build_ext --include-dirs=$TMP/$PRGNAM-src-$VERSION/lib/wx/include/gtk2-unicode-release-2.8 \
+ --library-dirs=$TMP/$PRGNAM-src-$VERSION/lib \
+ --rpath=/usr/lib$LIBDIRSUFFIX \
+ build
+
+ python setup.py \
+ WXPORT=gtk2 \
+ UNICODE=1 \
+ EP_ADD_OPTS=1 \
+ EP_FULL_VER=0 \
+ NO_SCRIPTS=0 \
+ WX_CONFIG="$TMP/$SRCNAM-src-$VERSION/wx-config --prefix=$PKG/usr/bin/ --no_rpath" \
+ SYS_WX_CONFIG="wx-config --enable-unicode" \
+ build_ext --include-dirs=$TMP/$PRGNAM-src-$VERSION/lib/wx/include/gtk2-unicode-release-2.8 \
+ --library-dirs=$TMP/$PRGNAM-src-$VERSION/lib \
+ --rpath=/usr/lib$LIBDIRSUFFIX \
+ install --root=$PKG
+
+ mkdir -p $PKG/usr/share/{applications,pixmaps} $PKG/usr/share/icons/hicolor/{16x16,32x32}/apps
+ install -m 644 distrib/*.desktop $PKG/usr/share/applications/
+
+ install -m 644 wx/py/PyCrust_16.png $PKG/usr/share/icons/hicolor/16x16/apps/PyCrust.png
+ install -m 644 wx/py/PyCrust_32.png $PKG/usr/share/icons/hicolor/32x32/apps/PyCrust.png
+ ln -s /usr/share/icons/hicolor/32x32/apps/PyCrust.png $PKG/usr/share/pixmaps/PyCrust.png
+ install -m 644 wx/py/PySlices_16.png $PKG/usr/share/icons/hicolor/16x16/apps/PySlices.png
+ install -m 644 wx/py/PySlices_32.png $PKG/usr/share/icons/hicolor/32x32/apps/PySlices.png
+ ln -s /usr/share/icons/hicolor/32x32/apps/PySlices.png $PKG/usr/share/pixmaps/PySlices.png
+ install -m 644 wx/tools/XRCed/XRCed_16.png $PKG/usr/share/icons/hicolor/16x16/apps/XRCed.png
+ install -m 644 wx/tools/XRCed/XRCed_32.png $PKG/usr/share/icons/hicolor/32x32/apps/XRCed.png
+ ln -s /usr/share/icons/hicolor/32x32/apps/XRCed.png $PKG/usr/share/pixmaps/XRCed.png
+
+ rm -rf $PKG/usr/bin/editra
+ rm -rf $PKG/usr/lib$LIBDIRSUFFIX/python2.7/site-packages/wx-3.0-gtk2/wx/tools/Editra
+cd -
+
+# install wxPython includes
+mkdir -p $PKG/usr/include/wx-3.0/wx/
+cp -rf wxPython/include/wx/wxPython $PKG/usr/include/wx-3.0/wx/
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/wxPython
+cp -a README.1st.txt docs* $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a wxPython/docs/* $PKG/usr/doc/$PRGNAM-$VERSION/wxPython
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# Remove unnecessary docs
+cd $PKG/usr/doc/$PRGNAM-$VERSION/docs
+rm -rf cocoa latex mac metrowerks microwin msw palmos word
+
+mkdir -p $PKG/install
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}