summaryrefslogtreecommitdiffstats
path: root/libraries/tre
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2021-04-18 16:01:56 +0200
committer Robby Workman2021-04-19 08:07:14 +0200
commit329f3491b3150d4af0f51b99f48bcf53e9ea6bfc (patch)
tree1bf66249763574d8c1ef92fc71e37926903fd961 /libraries/tre
parentf4c37b72af4c1f6dbd48f05ce4bebc79ff1dc547 (diff)
downloadslackbuilds-329f3491b3150d4af0f51b99f48bcf53e9ea6bfc.tar.gz
libraries/tre: Removed Python 2 support.
Signed-off-by: Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
Diffstat (limited to 'libraries/tre')
-rw-r--r--libraries/tre/tre.SlackBuild16
1 files changed, 4 insertions, 12 deletions
diff --git a/libraries/tre/tre.SlackBuild b/libraries/tre/tre.SlackBuild
index 54560e0c0c..9701d5a62f 100644
--- a/libraries/tre/tre.SlackBuild
+++ b/libraries/tre/tre.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for TRE
# Copyright 2008 Frank Caraballo <fecaraballo{at}gmail{dot}com>
+# Maintained 2013-2021 by Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -80,23 +81,14 @@ CFLAGS="$SLKCFLAGS" \
make install-strip DESTDIR=$PKG
-cp -r python python3
cd python
+ # Python 3 support from https://github.com/ahomansikka/tre/commit/d6a0220
+ patch -p0 < $CWD/python3.patch
CFLAGS="-I$PKG/usr/include" \
LDFLAGS="-L$PKG/usr/lib$LIBDIRSUFFIX" \
- python setup.py install --root=$PKG
+ python3 setup.py install --root=$PKG
cd -
-if $(python3 -c 'import sys' 2>/dev/null); then
- cd python3
- # Python 3 support from https://github.com/ahomansikka/tre/commit/d6a0220
- patch -p0 < $CWD/python3.patch
- CFLAGS="-I$PKG/usr/include" \
- LDFLAGS="-L$PKG/usr/lib$LIBDIRSUFFIX" \
- python3 setup.py install --root=$PKG
- cd -
-fi
-
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done