summaryrefslogtreecommitdiffstats
path: root/libraries/sdformat/cmake.patch
diff options
context:
space:
mode:
author Matteo Bernardini2021-04-08 19:35:50 +0200
committer Matteo Bernardini2021-04-08 19:35:50 +0200
commitafc9e42772de8a69a6c2a028e98dc5ca8d96df52 (patch)
tree1005b4879f8fb6b3be051d8ac93d1b40220fbecd /libraries/sdformat/cmake.patch
parenta6bf666d73b4dccae0636e4ca04113d5953b956c (diff)
downloadslackbuilds-2d14715f971a22b9a4c22db06955477bd153b298.tar.gz
20210408.1 global branch merge.current-20210408.1
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'libraries/sdformat/cmake.patch')
-rw-r--r--libraries/sdformat/cmake.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/libraries/sdformat/cmake.patch b/libraries/sdformat/cmake.patch
new file mode 100644
index 0000000000..38e6b6cca6
--- /dev/null
+++ b/libraries/sdformat/cmake.patch
@@ -0,0 +1,20 @@
+diff -Naur osrf-sdformat-e5ac5aaa49f2.orig/CMakeLists.txt osrf-sdformat-e5ac5aaa49f2/CMakeLists.txt
+--- osrf-sdformat-e5ac5aaa49f2.orig/CMakeLists.txt 2016-10-10 23:51:37.000000000 +0200
++++ osrf-sdformat-e5ac5aaa49f2/CMakeLists.txt 2017-07-29 19:46:16.021921859 +0200
+@@ -186,11 +186,13 @@
+ # OS Specific initialization
+ if (UNIX)
+ sdf_setup_unix()
+-else (WIN32)
++endif ()
++if (WIN32)
+ sdf_setup_windows()
+-else (APPLE)
++endif ()
++if (APPLE)
+ sdf_setup_apple()
+-endif()
++endif ()
+
+ #################################################
+ # Print warnings and errors