summaryrefslogtreecommitdiffstats
path: root/libraries/sdformat/cmake.patch
diff options
context:
space:
mode:
author Matteo Bernardini2019-12-31 15:55:40 +0100
committer Matteo Bernardini2019-12-31 15:55:40 +0100
commit30778e822d6ef153cd8936acaa45deeeb8f5374a (patch)
tree9605719730f63b62fb4e9c22167b36c60ceb950f /libraries/sdformat/cmake.patch
parent82bbd880da5d554ddb98a82fcf8c17cc2131d56a (diff)
downloadslackbuilds-30778e822d6ef153cd8936acaa45deeeb8f5374a.tar.gz
20191231.1 global branch merge.current-20191231.1
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'libraries/sdformat/cmake.patch')
-rw-r--r--libraries/sdformat/cmake.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/libraries/sdformat/cmake.patch b/libraries/sdformat/cmake.patch
new file mode 100644
index 0000000000..38e6b6cca6
--- /dev/null
+++ b/libraries/sdformat/cmake.patch
@@ -0,0 +1,20 @@
+diff -Naur osrf-sdformat-e5ac5aaa49f2.orig/CMakeLists.txt osrf-sdformat-e5ac5aaa49f2/CMakeLists.txt
+--- osrf-sdformat-e5ac5aaa49f2.orig/CMakeLists.txt 2016-10-10 23:51:37.000000000 +0200
++++ osrf-sdformat-e5ac5aaa49f2/CMakeLists.txt 2017-07-29 19:46:16.021921859 +0200
+@@ -186,11 +186,13 @@
+ # OS Specific initialization
+ if (UNIX)
+ sdf_setup_unix()
+-else (WIN32)
++endif ()
++if (WIN32)
+ sdf_setup_windows()
+-else (APPLE)
++endif ()
++if (APPLE)
+ sdf_setup_apple()
+-endif()
++endif ()
+
+ #################################################
+ # Print warnings and errors