summaryrefslogtreecommitdiffstats
path: root/libraries/reportlab/reportlab.SlackBuild
diff options
context:
space:
mode:
author LukenShiro2014-10-15 16:13:31 +0200
committer Willy Sudiarto Raharjo2014-10-15 16:13:31 +0200
commit068b1c86f47a2c5a12b4aac4968171e2610a85ba (patch)
tree5e79a0f3ddaaaa48a55ce9704c1ee034cdb314d1 /libraries/reportlab/reportlab.SlackBuild
parent7ebc0e080e135ee99fae6c3cfae27d9c6711be47 (diff)
downloadslackbuilds-068b1c86f47a2c5a12b4aac4968171e2610a85ba.tar.gz
libraries/reportlab: Updated for version 3.1.8.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/reportlab/reportlab.SlackBuild')
-rw-r--r--libraries/reportlab/reportlab.SlackBuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/libraries/reportlab/reportlab.SlackBuild b/libraries/reportlab/reportlab.SlackBuild
index d9f06d5231..18e200b5ea 100644
--- a/libraries/reportlab/reportlab.SlackBuild
+++ b/libraries/reportlab/reportlab.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for reportlab
-# Copyright 2007-2013 LukenShiro, Italy
+# Copyright 2007-2014 LukenShiro, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
# Modified by SlackBuilds.org
PRGNAM=reportlab
-VERSION=${VERSION:-2.7}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-3.1.8}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -68,10 +68,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Generate pdf documentation
( cd docs
@@ -94,7 +94,7 @@ sed -i \
python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
# Move documentation .pdf files and text files to avoid file duplication in