summaryrefslogtreecommitdiffstats
path: root/libraries/python3-CherryPy
diff options
context:
space:
mode:
author fourtysixandtwo2023-12-17 19:34:56 +0100
committer Willy Sudiarto Raharjo2023-12-22 02:00:21 +0100
commit2116a6f07e6143d6e515350105f2fa69ca15f16f (patch)
tree1451bc1f4e428e0fd837f4a5a86b3e307c649706 /libraries/python3-CherryPy
parentcbb7bd5c007ab66b23f232964d65939fabc626bb (diff)
downloadslackbuilds-2116a6f07e6143d6e515350105f2fa69ca15f16f.tar.gz
libraries/python3-CherryPy: Updated for version 18.9.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/python3-CherryPy')
-rw-r--r--libraries/python3-CherryPy/python3-CherryPy.SlackBuild25
-rw-r--r--libraries/python3-CherryPy/python3-CherryPy.info6
2 files changed, 7 insertions, 24 deletions
diff --git a/libraries/python3-CherryPy/python3-CherryPy.SlackBuild b/libraries/python3-CherryPy/python3-CherryPy.SlackBuild
index 0b16104175..0e50f9cc44 100644
--- a/libraries/python3-CherryPy/python3-CherryPy.SlackBuild
+++ b/libraries/python3-CherryPy/python3-CherryPy.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-CherryPy
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-CherryPy
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-18.8.0}
+VERSION=${VERSION:-18.9.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -76,9 +59,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
diff --git a/libraries/python3-CherryPy/python3-CherryPy.info b/libraries/python3-CherryPy/python3-CherryPy.info
index 510d9521e3..f27ae07f2b 100644
--- a/libraries/python3-CherryPy/python3-CherryPy.info
+++ b/libraries/python3-CherryPy/python3-CherryPy.info
@@ -1,8 +1,8 @@
PRGNAM="python3-CherryPy"
-VERSION="18.8.0"
+VERSION="18.9.0"
HOMEPAGE="http://www.cherrypy.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/c/cherrypy/CherryPy-18.8.0.tar.gz"
-MD5SUM="033c58bf3da497f283b039911d1c882b"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/c/cherrypy/CherryPy-18.9.0.tar.gz"
+MD5SUM="014dbd400aeda9d2b098ed01c95b4a30"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-cheroot python3-portend python3-jaraco.collections python3-zc.lockfile"