summaryrefslogtreecommitdiffstats
path: root/libraries/python2-reportlab
diff options
context:
space:
mode:
author LukenShiro2022-11-05 14:23:42 +0100
committer Willy Sudiarto Raharjo2022-11-05 15:15:14 +0100
commitbe9ebe8e506d116711bf4e9db7473253a222e092 (patch)
tree19a7b165d562b6785782735177f03e4183d7902b /libraries/python2-reportlab
parent66a7d7c87c53654c5d76e8eaade3a471b1f50801 (diff)
downloadslackbuilds-be9ebe8e506d116711bf4e9db7473253a222e092.tar.gz
libraries/python2-reportlab: Added (Python2 PDF generation toolkit).
Renamed from reportlab. Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/python2-reportlab')
-rw-r--r--libraries/python2-reportlab/README23
-rw-r--r--libraries/python2-reportlab/python2-reportlab.SlackBuild126
-rw-r--r--libraries/python2-reportlab/python2-reportlab.info12
-rw-r--r--libraries/python2-reportlab/slack-desc19
4 files changed, 180 insertions, 0 deletions
diff --git a/libraries/python2-reportlab/README b/libraries/python2-reportlab/README
new file mode 100644
index 0000000000..43391124d9
--- /dev/null
+++ b/libraries/python2-reportlab/README
@@ -0,0 +1,23 @@
+The ReportLab Open Source PDF library is a proven industry-strength
+python-based PDF generating solution, suitable for web publishers,
+developers or creative design professionals who need to quickly and
+easily create or automate complex (even data-driven) documents.
+It is released by ReportLab Inc., under BSD license.
+
+It includes binary extensions (previously available separately)
+_rl_accel and renderPM
+
+It has the following features:
+- create professional portable documents
+- real document layout engine (Platypus)
+- flowable objects (paragraphs headlines tables images graphics etc)
+- arbitrary Type-1 fonts
+- bitmap images, vector graphics
+- library of reusable primitive shapes
+- extensible widget library
+- layered architecture
+- includes simple demos and more complex tools
+- allows for any data sources
+- strong community support
+- platform-independent
+- includes PythonPoint - PDF Presentation Tool
diff --git a/libraries/python2-reportlab/python2-reportlab.SlackBuild b/libraries/python2-reportlab/python2-reportlab.SlackBuild
new file mode 100644
index 0000000000..cf15da5439
--- /dev/null
+++ b/libraries/python2-reportlab/python2-reportlab.SlackBuild
@@ -0,0 +1,126 @@
+#!/bin/bash
+
+# Slackware build script for reportlab
+
+# Copyright 2007-2015 LukenShiro, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Modified by SlackBuilds.org
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python2-reportlab
+SRCNAM=reportlab
+VERSION=${VERSION:-3.2.0}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ LIBDIRSUFFIX="64"
+else
+ LIBDIRSUFFIX=""
+fi
+
+# directory for python packages
+PYTHONDIR=$(python2 -c "import sys, os; print os.path.join('/usr/lib${LIBDIRSUFFIX}', 'python%s' % sys.version[:3], 'site-packages')")
+
+DOCFILES="CHANGES.md LICENSE.txt README.txt INSTALL.txt"
+OTHERPYFILES="demos tools tests"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Unzip T1 font curves
+cd src/reportlab/fonts/
+unzip $CWD/pfbfer-20070710.zip
+cd -
+
+# Generate pdf documentation
+( cd docs
+ # workaround due to dependency loop if reportlab isn't previously installed
+ PYTHONPATH=$PYTHONPATH:$TMP/$SRCNAM-$VERSION/src/ python2 genAll.py
+)
+
+# Move demos, tests and tools directories into python package's home
+# and remove duplicated file
+mkdir -p $PKG/$PYTHONDIR/$SRCNAM/
+mv $OTHERPYFILES $PKG/$PYTHONDIR/$SRCNAM
+rm -f $PKG/$PYTHONDIR/$SRCNAM/tools/docco/*.pdf
+
+# Fix some fonts search paths
+sed -i \
+ -e "s|usr/share/fonts/truetype|usr/share/fonts/TTF|" \
+ -e "s|usr/local/Acrobat9|opt/Adobe/Reader9|" \
+ -e "s|%(HOME)s/fonts|%(HOME)s/.fonts|" \
+ src/reportlab/rl_config.py || exit 1
+
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Move documentation .pdf files and text files to avoid file duplication in
+# python directory
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+mv $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION/
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/python2-reportlab/python2-reportlab.info b/libraries/python2-reportlab/python2-reportlab.info
new file mode 100644
index 0000000000..620f547102
--- /dev/null
+++ b/libraries/python2-reportlab/python2-reportlab.info
@@ -0,0 +1,12 @@
+PRGNAM="python2-reportlab"
+VERSION="3.2.0"
+HOMEPAGE="https://bitbucket.org/rptlab/reportlab/overview"
+DOWNLOAD="https://pypi.python.org/packages/source/r/reportlab/reportlab-3.2.0.tar.gz \
+ http://www.reportlab.com/ftp/pfbfer-20070710.zip"
+MD5SUM="79d059e797c557aed4b40c68dd6c7eae \
+ 35d20e26490cb2a8646fab6276ac6a4c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="LukenShiro"
+EMAIL="lukenshiro@ngi.it"
diff --git a/libraries/python2-reportlab/slack-desc b/libraries/python2-reportlab/slack-desc
new file mode 100644
index 0000000000..d9bc68fa33
--- /dev/null
+++ b/libraries/python2-reportlab/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-reportlab: python2-reportlab (PDF generation toolkit using python)
+python2-reportlab:
+python2-reportlab: The ReportLab Open Source PDF library is a proven industry-strength
+python2-reportlab: PDF generating solution, suitable for web publishers, developers
+python2-reportlab: or creative design professionals who need to quickly and easily
+python2-reportlab: create or automate complex (even data-driven) documents.
+python2-reportlab: It is released by ReportLab Inc., under BSD license.
+python2-reportlab:
+python2-reportlab:
+python2-reportlab:
+python2-reportlab: